Jump to content

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png click.png click.png

Erro 400 ao cancelar NFC-e


tporto
Go to solution Solved by BigWings,
  • Este tópico foi criado há 757 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Consultores

Boa tarde.

O problema foi solucionado? Se sim, como?

Att.

Consultora SAC ACBr

Juliana Tamizou
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil


Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

Link to comment
Share on other sites

1 hora atrás, Juliana Tamizou disse:

Boa tarde.

O problema foi solucionado? Se sim, como?

Att.

Boa tarde! Semana passada atualizei o componente diversas vezes para solucionar o problema e o erro persistiu. Tive que instalar uma versão mais antiga do componente para "solucionar".

Link to comment
Share on other sites

Em 05/11/2019 at 13:44, Juliana Tamizou disse:

Boa tarde.

O problema foi solucionado? Se sim, como?

Att.

A revisão que estou utilizando sem problemas é a 17231 (28/06/2019). Novamente precisei atualizar (09/11/2019) para corrigir uns problemas no mdfe e voltou a ocorrer o erro http 400. Isso só ocorre ao inutilizar e/ou cancelar, tanto nos ambientes homologação quanto produção. Comparei o arquivo ACBrNFeServicos.ini nas duas revisões e não há mudança.

Edited by tporto
add info
Link to comment
Share on other sites

Em 05/11/2019 at 13:44, Juliana Tamizou disse:

Boa tarde.

O problema foi solucionado? Se sim, como?

Att.

Fazendo mais testes comparando as duas revisões, a mais nova o arquivo "-eve-soap.xml" está sendo gerado sem informações (limpo).

Edited by tporto
correção
Link to comment
Share on other sites

  • Moderadores
Em 09/11/2019 at 10:43, tporto disse:

A revisão que estou utilizando sem problemas é a 17231 (28/06/2019). Novamente precisei atualizar (09/11/2019) para corrigir uns problemas no mdfe e voltou a ocorrer o erro http 400. Isso só ocorre ao inutilizar e/ou cancelar, tanto nos ambientes homologação quanto produção. Comparei o arquivo ACBrNFeServicos.ini nas duas revisões e não há mudança.

A SVRS que é usada pelo MA para NFCe também é usada na maioria dos estados do Brasil.

Então é estranho que só você esteja com problemas...

Como está configurando as propriedades SSLLib?

Como copiou as DLLs da OpenSSL/LibXML/XmlSec?

Já tentou isolar a conexão de Internet? Usando uma ponte 3G/4G por exemplo?

Vi que está testando pelo demo... anexe os arquivos XML *-ped-eve.xml

  • Like 1
Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

1 hora atrás, BigWings disse:

A SVRS que é usada pelo MA para NFCe também é usada na maioria dos estados do Brasil.

Então é estranho que só você esteja com problemas...

Como está configurando as propriedades SSLLib?

Como copiou as DLLs da OpenSSL/LibXML/XmlSec?

Já tentou isolar a conexão de Internet? Usando uma ponte 3G/4G por exemplo?

Vi que está testando pelo demo... anexe os arquivos XML *-ped-eve.xml

Testei com a SSLLib Openssl e WinCrypt.
De acordo com a url que está sendo mostrada no erro, o ambiente é o NFe_SVAN
Copiei as dlls Openssl 0.9.8.14, LibXml2 x64, MingGW x64. Copiei para junto do exe e para a system32 e system64
Meu ambiente é windows 10 x64 Lazarus 2.0.6 x64.

O que me deixa mais intrigado é que a revisão mais antiga funciona tudo normal e que a revisão atual consegue emitir sem problemas.

63-ped-eve.xml 63-ped-eve-soap.xml

Edited by tporto
add info
Link to comment
Share on other sites

  • Moderadores
3 minutos atrás, tporto disse:

De acordo com a url que está sendo mostrada no erro, o ambiente é o NFe_SVAN

O MA usa SVAN para NFe e SVRS para NFCe.

A imagem mostrada no primeiro post mostra endereço da SVRS.

O MDFe também todos os estados são atendidos pela SVRS.

4 minutos atrás, tporto disse:

Copiei as dlls Openssl 0.9.8.14, LibXml2 x64, MingGW x64.

Se está copiando as DLLS MinGW, fez alteração no ACBr.inc para ativar a diretiva {$DEFINE USE_MINGW}?

Para qual diretório está copiando as DLLs?

5 minutos atrás, tporto disse:

Meu ambiente é windows 10 x64 Lazarus 2.0.6 x64.

Em se tratando de Lazarus já tem menos usuários... pode ser algo relacionado ao ambiente Lazarus e 64bits...

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

7 minutos atrás, BigWings disse:

O MA usa SVAN para NFe e SVRS para NFCe.

A imagem mostrada no primeiro post mostra endereço da SVRS.

O MDFe também todos os estados são atendidos pela SVRS.

Se está copiando as DLLS MinGW, fez alteração no ACBr.inc para ativar a diretiva {$DEFINE USE_MINGW}?

Para qual diretório está copiando as DLLs?

Em se tratando de Lazarus já tem menos usuários... pode ser algo relacionado ao ambiente Lazarus e 64bits...

Copiei as dlls Openssl 0.9.8.14, LibXml2 x64, MingGW x64. Copiei para junto do exe e para a system32 e system64.
Uso o lazarus há mais de uma ano com acbr, e essa é a primeira vez que acontece isso.

Edited by tporto
add info
Link to comment
Share on other sites

  • Moderadores
  • Solution
37 minutos atrás, tporto disse:

Uso o lazarus há mais de uma ano com acbr, e essa é a primeira vez que acontece isso.

Por favor, atualize os fontes e faça novo teste.

Foi enviado um ajuste para uso do ACBr com Lazarus em 64 bits.

  • Like 1
Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

  • Fundadores

Enviei um novo ajuste, preservando um pouco mais, a otimização da FastStringReplace, em FPC 64...
Seria possível atualizar novamente e efetuar novo teste ?

  • Like 1
Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Este tópico foi criado há 757 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.