Jump to content

Delphi chamada_delphi.png acbr.png

C6 chamada_c6.png botao.png

Impressão sat extratofortes descrição produto em branco


Obr Junior
Go to solution Solved by Obr Junior,
  • Este tópico foi criado há 915 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Fundadores

Aqui imprimiu normal... (veja o anexo)

Verifique se seus fontes estão corretamente atualizados...

CFe 3519 1111 1111 1111 1111 5912 3456 7890 0010 2177 8271.pdf

Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Fundadores

Como eu já disse.. não tenho como lhe ajudar, pois não consigo reproduzir o problema...

Se você conseguir reproduzir o problema no Demo do ACBr, favor informar um passo a passo

  • Like 1
Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • 2 weeks later...
  • Moderadores
Em 16/11/2019 at 12:01, Obr Junior disse:

ate hoje ainda nao descobri , se alguem pode ajudar , grato

Bom dia, Obr Junior. 

Você tentou realizar os passos informados pelo Daniel? 

  • Like 1
Equipe ACBr

Felipe Eduardo Resende Mesquita

Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

 

 

 

Link to comment
Share on other sites

sim , outro problema que antes da atualização funcionava o PREVIEW , visualizava o sat , agora não funciona mais , atualizei o fortes reporte , mais não funciona PREVIEW

tem outro aplicação em outra maquina que funciona normal impressão extratofortes , coloque na outra maquina  que não funciona, e aplicação que funcionava apos compilar não funcionou também , então acredito que seja o problema em algum componente ou no Delphi , se alguém tem algum ideá me ajude , grato

Link to comment
Share on other sites

unit SAT;

interface

uses
  Winapi.Windows, Winapi.Messages, System.SysUtils, System.Variants, System.Classes, Vcl.Graphics,
  Vcl.Controls, Vcl.Forms, Vcl.Dialogs, ACBrSAT, ACBrBase, ACBrDFeReport,
  ACBrSATExtratoClass, ACBrSATExtratoReportClass, ACBrSATExtratoFortesFr,
  Vcl.StdCtrls;

type
  TForm1 = class(TForm)
    btn1: TButton;
    ACBrSATExtratoFortes1: TACBrSATExtratoFortes;
    ACBrSAT1: TACBrSAT;
    procedure btn1Click(Sender: TObject);
  private
    { Private declarations }
  public
    { Public declarations }
  end;

var
  Form1: TForm1;

implementation

{$R *.dfm}

procedure TForm1.btn1Click(Sender: TObject);
VAR caminho_arquivo, tipo_fiscal: string;
    FExtrato : TACBrSATExtratoFortes;
    FAcbrSAT : TACBrSAT;

begin


            caminho_arquivo := 'c:\102030.xml';

            FAcbrSAT := TACBrSAT.Create(Nil);
            FExtrato := TACBrSATExtratoFortes.Create(Nil);

            FExtrato.LarguraBobina    := 280;
            FExtrato.MargemSuperior   := 2;
            FExtrato.MargemEsquerda   := 0;
            FExtrato.MargemDireita    := 2;

          FExtrato.MostraPreview    := True;
            FExtrato.MostraSetup      := True;

            FAcbrSAT.Extrato := FExtrato;
           FAcbrSAT.CFe.LoadFromFile( caminho_arquivo );
            FAcbrSAT.ImprimirExtrato();
end;
end.

 

NESTE SIMPLES TESTE EM UM MAQUINA COM DELPHI FUNCIONA NA OUTRA NAO , AS DUAS MAQUINAS ESTAO COM DELPHI 10 SEATTLE

Link to comment
Share on other sites

Problema nas imagens abaixo , a mesma aplicação  a versão do Delphi é seatlle , mas maquinas diferente , uma no windows 7 esta ok , outra com windows 10  com erro abaixo , o acbr e fortes atualizados 

 

obs maquina virtual com erro não da preview  e na impressão  não sai descrição do produto

sat OK.jpg

SAT ERRO.jpeg

Link to comment
Share on other sites

5 horas atrás, Daniel Simoes disse:

Sua pasta dos fontes do ACBr, deve ter fontes diferentes do repositório oficial

uma coisa eu percebi , mesmo apagando tudo e baixando o novo , eu faço um modificação ACBrSATExtratoFortesFr , mas ele não muda nada , eu faço isso outro delphi onde funciona ele aceita essa mundana normal apos remover ACBrSATExtratoFortesFr e instalar novamente.

Link to comment
Share on other sites

  • Administradores

Obrigado por reportar.

Fechando. Para novas dúvidas, criar um novo tópico.

Consultora SAC ACBr

Juliana Tamizou
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil


Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

Link to comment
Share on other sites

  • Este tópico foi criado há 915 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.