Jump to content

Promoção de Natal SAC Mensal

Contrate e ganhe 1 Kit agenda + Caneta
Saiba mais

LANÇAMENTO
Curso Completo - Dominando o ACBrMonitor

Conheça o Curso

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Wladimir

Código do Serviço Prestado inexistente

Recommended Posts

Bom dia Prezados
Estou com dificuldades para enviar a NFS-e, é retornada uma mensagem de Código do Serviço Prestado inexistente, ja consultei  o código de serviço utilizado hoje que é 01.07 com CNAE 0291700, tentei enviar com  o código que está no exemplo do ACBr, o método de envio é Homologação, mudei para Podução e o erro persiste.

Infelizmente não tenho como gerar o XML da NFS-e da Prefeitura de SP, mas estou anexando o gerado pelo ACBr.

Antecipadamente já agradeço a todos.

Wladimir

3519111270976500018456000000000000007-rps.xml 3519111270976500018456000000000000008-rps.xml

Share this post


Link to post
Share on other sites

Bom dia Wladimir,

Você anexou 2 XML um com o código de serviço 01.07 e o outro com o código 14.01

Ambos estão sendo rejeitados?

Tanto o ambiente de homologação quanto o de produção rejeita a nota?


Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites
47 minutos atrás, Italo Jurisato Junior disse:

Bom dia Wladimir,

Você anexou 2 XML um com o código de serviço 01.07 e o outro com o código 14.01

Ambos estão sendo rejeitados?

Tanto o ambiente de homologação quanto o de produção rejeita a nota?

Boa tarde Italo!

Primeiramente agradeço a atenção!

Em anexo mensagem e 4 XML sendo os mesmos registros com o código de serviço 14.01

Dois XMLs em Homologação e os outros dois em Produção...Ambos com os mesmos erros.

Grato

Wladimir

ErroCodServiço.png

3519111270976500018456000000000000008(Producao)-rps.xml 3519111270976500018456000000000000007(Homolocacao)-rps.xml 3519111270976500018456000000000000007(Producao)-rps.xml 3519111270976500018456000000000000008(Homologacao)-rps.xml

Share this post


Link to post
Share on other sites
58 minutos atrás, Dercide Alvarez disse:

Boa tarde Dercide!

Consultei a interface da Prefeitura de SP e tenho os seguintes códigos, são eles:
Código do serviço Principal

02919 - Suporte técnico em informática, inclusive instalação, configuração e manutenção de programas de computação e bancos de dados.  -  Item Lei 01.07

07285 - Instalação e montagem de aparelhos, máquinas e equipamentos, prestados ao usuário final, exclusivamente com material por ele fornecido.  -  Item Lei 14.06

07498 - Conserto, restauração, manutenção e conservação de máquinas, aparelhos, equipamentos, motores, elevadores ou de quaisquer outros objetos, exceto veículos (exceto peças e partes empregadas, que ficam sujeitas ao ICMS). - Item Lei 14.01

 

Eu já havia consultado este link que informou, só não havia relacionado os itens aqui no fórum, e veja o resultado.

Quando tento gerar a RPS pelo ewxemplo da ACBR, sou informado que a inscrição municipal do Tomador inexistente ou inválida!ExemploACBrIM.thumb.png.55987dbdc10307b9171d0fce0da99c86.png

 

812861109_ErroCodServio1406.png.ab0c6ec822cc0be754c5603ce3f2a442.png1139372378_ErroCodServio0107.png.7e34aba1408f8e13c955778c2e4e7a5d.pngExemploACBr.png.1d206708e0b6ede6867d78066cbaacdf.png

 

Grato

Wladimir

Share this post


Link to post
Share on other sites
3 minutos atrás, Dercide Alvarez disse:

@Wladimir

Já consultou na prefeitura pra verificar se existe alguma pendencia fiscal junto ao CADIN ?

Não sei se é isso que esta provocando os erros.

 

CNPJ_127097650001-84.pdf 140 kB · 0 downloads

Pedi para meu contador realizar esta consulta, não existe nada pendende!
O que é mais estranho é que consigo emitir pelo site da prefeitura, e veja o exemplo da ACBr, a IM é inexistente.

  • Like 1

Share this post


Link to post
Share on other sites

@Wladimir

É a inscrição do TOMADOR  e não a tua (PRESTADOR).

É a do cliente que esta na nota, deve ter alguma inconsistencia nos dados que voce informou.

 

Dercide.

Edited by Dercide Alvarez

Share this post


Link to post
Share on other sites
25 minutos atrás, Dercide Alvarez disse:

@Wladimir

É a inscrição do TOMADOR  e não a tua (PRESTADOR).

É a do cliente que esta na nota, deve ter alguma inconsistencia nos dados que voce informou.

 

Dercide.

É o exemplo que está no ACBr, por isso achei estranho.

Share this post


Link to post
Share on other sites
42 minutos atrás, Daniel Port disse:

@Wladimir o código do serviço prestado não precisa ser previamente  cadastrado para aquele prestador de serviço na prefeitura ?

 

Daniel,
Sim, tanto que pelo site da Prefeitura de SP eu consigo emitir minha nota tranquilamente, sem nenhum problema.

Att
Wladimir

  • Like 1

Share this post


Link to post
Share on other sites
3 horas atrás, Wladimir disse:

Sim, tanto que pelo site da Prefeitura de SP eu consigo emitir minha nota tranquilamente, sem nenhum problema.

Em tese sim, o destino é o mesmo, mas por caminhos diferentes.

Me chamou atenção pois uma das msg de erro reporta isso

image.png.c4e81cfda7baf636ef1162b0cd7ec883.png

Edited by Daniel Port

Share this post


Link to post
Share on other sites
1 minuto atrás, Daniel Port disse:

Em tese sim, o destino é o mesmo, mas por caminhos diferentes.

Me chamou atenção pois uma das msg de erro reporta isso

Daniel,
Falei com meu contador e não há nada que impeça a emissão da nota e não sei mais por onde ir, já comparei o exemplo do ACBr e não encontrei diferença a não ser os dados que são enviados por banco nada mais, uma situação que me chamou a atenção é que o código do serviço está saindo sem "." ou seja, será que ao invés de enviar 01.07 enviar 0107 pode ser o problema?

 

att
Wladimir

Share this post


Link to post
Share on other sites
3 horas atrás, Daniel Port disse:

Em tese sim, o destino é o mesmo, mas por caminhos diferentes.

Me chamou atenção pois uma das msg de erro reporta isso

image.png.c4e81cfda7baf636ef1162b0cd7ec883.png

Daniel,
Neste erro, eu utilizei um código que está relacionado com meu código de serviço, e apenas este código está informando que não está cadastrado para a minha I.M.

  • Like 1

Share this post


Link to post
Share on other sites

Boa noite Wladimir,

Você esta enviando a nota para o webservice da cidade de São Paulo, correto?

Até onde sei, esse webservice espera que o código do serviço seja informado sem formatação, portanto não devemos incluir o ponto.

  • Like 2

Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites
14 horas atrás, Italo Jurisato Junior disse:

Boa noite Wladimir,

Você esta enviando a nota para o webservice da cidade de São Paulo, correto?

Até onde sei, esse webservice espera que o código do serviço seja informado sem formatação, portanto não devemos incluir o ponto.

Bom dia Italo!

Sim, para o webservice de SP. Imaginei que fosse sem ponto, mas em alguns fóruns foi cogitado a ideia de ser com ponto.
A questão é continuo sem conseguir enviar a nota de serviço por conta deste problema.

Att

Wladimir

Share this post


Link to post
Share on other sites

Bom dia Wladimir,

Você pode fazer um teste.

Altere a linha que gera a tag referente ao código do serviço, ela se encontra na unit: pnfsNFSeW_SP.

  • Like 1

Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites
38 minutos atrás, Italo Jurisato Junior disse:

Bom dia Wladimir,

Você pode fazer um teste.

Altere a linha que gera a tag referente ao código do serviço, ela se encontra na unit: pnfsNFSeW_SP.

Italo,

Seguindo sua sugestão alterei a unit pnfsNFSeW_SP para os valores a seguir;

Anterior:
Gerador.wCampoNFSe(tcStr, '', 'CodigoServico'   , 1, 05, 1, OnlyNumber(NFSe.Servico.ItemListaServico), '');

Atual: 
Gerador.wCampoNFSe(tcStr, '', 'CodigoServico', 1, 05, 1, NFSe.Servico.ItemListaServico, '');

Ao gerar a NFS-e recebi a mensagem que está em anexo, ou seja, creio que o webservice não recebe este código com ponto e sim sem ponto.

Att
Wladimir

AtomicType.png

Edited by Wladimir

Share this post


Link to post
Share on other sites

Wladimir,

Na verdade o seu RPS nem sequer foi enviado para o webservice.

O componente ao submeter ele a validação, acusou um erro e justamente no código do serviço.

Conclusão, o código não pode conter ponto.

Veja a definição do código de serviço que se encontra no Schema.

  <xs:simpleType name="tpCodigoServico">
    <xs:annotation>
      <xs:documentation>Tipo código de serviço.</xs:documentation>
    </xs:annotation>
    <xs:restriction base="xs:int">
      <xs:pattern value="[0-9]{4,5}" />
    </xs:restriction>
  </xs:simpleType>

Note que o código do serviço tem que ser um numero inteiro com no mínimo 4 dígitos e no máximo 5.

  • Like 1

Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites
11 minutos atrás, Italo Jurisato Junior disse:

Wladimir,

Na verdade o seu RPS nem sequer foi enviado para o webservice.

O componente ao submeter ele a validação, acusou um erro e justamente no código do serviço.

Conclusão, o código não pode conter ponto.

Veja a definição do código de serviço que se encontra no Schema.

  <xs:simpleType name="tpCodigoServico">
    <xs:annotation>
      <xs:documentation>Tipo código de serviço.</xs:documentation>
    </xs:annotation>
    <xs:restriction base="xs:int">
      <xs:pattern value="[0-9]{4,5}" />
    </xs:restriction>
  </xs:simpleType>

Note que o código do serviço tem que ser um numero inteiro com no mínimo 4 dígitos e no máximo 5.

Italo,
Não sei mais por onde seguir, o código está correto, está enviando corretamente conforme os anexos, se puder me ajudar com mais alguma informação.

Att
Wladimir

Share this post


Link to post
Share on other sites

Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites

Conforme orientações do @Italo Jurisato Junior, a Prefeitura de São Paulo segue o código da tabela da SUREM (instruo_normativa_sf-surem_ano_2011_n__08_anexo_1_atualizada_at_in_23-17_1545234368), onde deve ser informado o código do serviço da coluna Código de Serviço e não o Item da Lei que é o que geralmente os outros municípios utilizam, por exemplo o código "01.07".

Obrigado pelo empenho @Italo Jurisato Junior e a toda equipe do ACBr.

Att

Wladimir

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...