Jump to content

Delphi Enterprise 
pela METADE DO PREÇO

botao_delphi.png

 

 

tp_550_logo.png Homologação ACBr Apresenta:
Nova  Impressora
TP-550

botao_saibamais.png

 

 

Curso Dominando o ACBrMonitor
Novo Módulo Soluções de Varejo
Assine o SAC ACBr em qualquer plano e tenha acesso

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

ROSENILDO

ANSWERED Certificado VALID ATENAS

  • Este tópico foi criado há 141 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

Boa tarde.

Tenho um cliente que utiliza um novo certificado da VALID o Atenas, o mesmo precisa de um programa assistente instalado para responder as solicitações feitas para o certificado de qualquer que seja o software ou página web solicitante. O problema é: quando consulto o serviço ou tento emitir uma NFe o utilizando o ACBR o nosso sistema simplesmente é encerrado, (como se acontecesse algum problema ou incompatibilidade com o Windows). 

Quando eu desinstalo o assistente do VALID ATENAS, o ACBR não fecha, ele consegue comunicar normalmente, só não finaliza a operação, pq não consegue encontrar o certificado!

Informações: Windows 10 atualizado, Cadeias de certificado da VALID instaladas e atualizadas, Schemas atualizados.

Em anexo segue foto do certificado utilizado!

 

VALID.png

Share this post


Link to post
Share on other sites

Pode ser que esse certificado seja específico para soluções baseada em Navegadores...

 

  • Like 1

Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
15 horas atrás, Daniel Simoes disse:

Pode ser que esse certificado seja específico para soluções baseada em Navegadores...

 

Bom dia Daniel, ele também funciona normalmente naquele emissor gratuito de NFe. Que por sua vez é em JAVA.

Estamos tentando ver alguma solução!

  • Like 1

Share this post


Link to post
Share on other sites
16 horas atrás, Daniel Simoes disse:

Pode ser que esse certificado seja específico para soluções baseada em Navegadores...

 

Daniel, o pior é que a VALID se isenta totalmente, pois alegam que o certificado funciona em outras aplicações, em navegadores e em Desktop. 

Uma outra informação é: esse certificado já funcionou em nosso sistema. Provavelmente depois de alguma atualização do Windows, passou a gerar alguma incompatibilidade e aparece a mensagem de e SISTEMA PAROU, e encerra a aplicação!
 

Share this post


Link to post
Share on other sites

Até o momento não temos relato semelhante de usuários de Certificados de outras empresas...

Como está a sua configuração de ACBrDFe.SSL ?


Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
4 horas atrás, Daniel Simoes disse:

Até o momento não temos relato semelhante de usuários de Certificados de outras empresas...

Como está a sua configuração de ACBrDFe.SSL ?

Estão normais, como de todos os outros clientes. E tão provável que não seja configuração, que quando utilizo um outro certificado nessa mesma máquina, A1 ou um outro A3 ou TOKEN que não seja essa versão ATHENA da VALID, da tudo certo!

Share this post


Link to post
Share on other sites

A configuração ideal, para Windows com A3, seria algo como:

Configuracoes.Geral.SSLLib         := libWinCrypt;
Configuracoes.Geral.SSLCryptLib    := cryWinCrypt;
Configuracoes.Geral.SSLHttpLib     := httpWinHttp;
Configuracoes.Geral.SSLXmlSignLib  := xsLibXml2;
SSL.SSLType                        := LT_TLSv1_2; 

Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites
1 hora atrás, Daniel Simoes disse:

A configuração ideal, para Windows com A3, seria algo como:

Configuracoes.Geral.SSLLib         := libWinCrypt;
Configuracoes.Geral.SSLCryptLib    := cryWinCrypt;
Configuracoes.Geral.SSLHttpLib     := httpWinHttp;
Configuracoes.Geral.SSLXmlSignLib  := xsLibXml2;
SSL.SSLType                        := LT_TLSv1_2; 

Exatamente meu amigo! :(

Share this post


Link to post
Share on other sites
Em 20/12/2019 at 17:44, ROSENILDO disse:

Exatamente meu amigo! :(

Você instalou o certificado com o instalador VALID, pois os certificados da valid tem algumas coisas chatas pra instalar que so consegui resolver usando o instalador da própria valid. Mas ainda nao peguei este modelo ATHENA...

  • Like 1

Share this post


Link to post
Share on other sites
7 horas atrás, carlosinfoteen disse:

Você instalou o certificado com o instalador VALID, pois os certificados da valid tem algumas coisas chatas pra instalar que so consegui resolver usando o instalador da própria valid. Mas ainda nao peguei este modelo ATHENA...

Sim, usamos os instaladores e cadeias disponíveis no site da VALID

:(

Share this post


Link to post
Share on other sites

Bom dia

Creio que não tem nada a ver com o certificado. Tivemos um problema igual esse. Cheguei a instalar o Lazarus no cliente e debugar por la. Mas mesmo assim não deu certo, quando iria emitir uma nota, simplesmente o ACBrMonitor travava e apagava todas as configurações do arquivo ini. Revisamos todos os logs, linha a linha e não tinha nada. No momento que travava, o log travava junto, ou seja, não era gravado nada nele.

Na ocasião era um windows 7 pro original que o cliente tinha, e mesmo com todas os updates instalados não ia. Pra resolver o problema, formatamos o computador e resolveu o problema como mágica.

  • Like 2

Share this post


Link to post
Share on other sites
  • Este tópico foi criado há 141 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...