Jump to content

Assista tectoy.png

chamada diadoacbr

Campo:Modalidade de determinação da BC do ICMS - Nenhum valor informado


Go to solution Solved by Daniel Port,
  • Este tópico foi criado há 846 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Boa tarde a todos

Estou com um erro no meu projeto, e se for possível me auxiliarem aqui, ficarei muito agradecido .

Se o Regime for normal não da este erro, mas mantendo seu Regime que é o Simples Nacional da este erro:

Campo:Modalidade de determinação da BC do ICMS - Nenhum valor informado, ou seja

Ou seja, mesmo informando a modalidade,       o   campo   <modBC></modBC>      fica fazio .

    Produto.Imposto.ICMS.modBC        := dbiValorOperacao;
    Produto.Imposto.ICMS.vBC              := DM1.QITENSNOTASBC.AsFloat;
    Produto.Imposto.ICMS.pICMS         := DM1.QITENSNOTASALIQ.AsFloat;
    Produto.Imposto.ICMS.vICMS         := DM1.QITENSNOTASVRICMS.AsFloat;
    Produto.Imposto.ICMS.modBCST   := dbisMargemValorAgregado;
    Produto.Imposto.ICMS.pMVAST     := DM1.QITENSNOTASALIQST.AsFloat;;
    Produto.Imposto.ICMS.pRedBCST  := 0;
    Produto.Imposto.ICMS.vBCST         := DM1.QITENSNOTASBCSUBST.AsFloat;
    Produto.Imposto.ICMS.pICMSST    := DM1.QITENSNOTASALIQST.AsFloat;
    Produto.Imposto.ICMS.vICMSST    := DM1.QITENSNOTASICMSSUBST.AsFloat;
    Produto.Imposto.ICMS.pRedBC      := 0;

Agradeço desde já pela colaboração.

 


{

 

 

 

Link to comment
Share on other sites

1 hora atrás, MARCOS JOSE DE CARVALHO 2 disse:

Boa tarde a todos

Estou com um erro no meu projeto, e se for possível me auxiliarem aqui, ficarei muito agradecido .

Se o Regime for normal não da este erro, mas mantendo seu Regime que é o Simples Nacional da este erro:

Campo:Modalidade de determinação da BC do ICMS - Nenhum valor informado, ou seja

Ou seja, mesmo informando a modalidade,       o   campo   <modBC></modBC>      fica fazio .

 

Anexa o XML, assim fica fácil saber a possível origem do problema.

  • Like 1

_____________

Prates, Agnaldo

Link to comment
Share on other sites

  • Moderadores
19 horas atrás, MARCOS JOSE DE CARVALHO 2 disse:

Ou seja, mesmo informando a modalidade,       o   campo   <modBC></modBC>      fica fazio .

    Produto.Imposto.ICMS.modBC        := dbiValorOperacao;

Você informa desta forma mesmo na sua rotina, ou usa o método modBCToStr?

Pra mim a única explicação seria essa propriedade estar sendo informada como dbiNenhum. Assim geraria a tag em branco no XML.

  • Like 1
Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

Obrigado pelo auxilio BigWings, eu utilizo desta forma, copiei do ACBrNFe_Exemplo.dproj :

// lei da transparencia nos impostos
  Produto.Imposto.vTotTrib := 0;
  Produto.Imposto.ICMS.CST          := cst00;
  Produto.Imposto.ICMS.orig    := oeNacional;
  Produto.Imposto.ICMS.modBC   := dbiValorOperacao;
  Produto.Imposto.ICMS.vBC     := 100;
  Produto.Imposto.ICMS.pICMS   := 18;
  Produto.Imposto.ICMS.vICMS   := 18;
  Produto.Imposto.ICMS.modBCST := dbisMargemValorAgregado;
  Produto.Imposto.ICMS.pMVAST  := 0;
  Produto.Imposto.ICMS.pRedBCST:= 0;
  Produto.Imposto.ICMS.vBCST   := 0;
  Produto.Imposto.ICMS.pICMSST := 0;
  Produto.Imposto.ICMS.vICMSST := 0;
  Produto.Imposto.ICMS.pRedBC  := 0;

Link to comment
Share on other sites

22 horas atrás, MARCOS JOSE DE CARVALHO 2 disse:

Boa tarde a todos

Estou com um erro no meu projeto, e se for possível me auxiliarem aqui, ficarei muito agradecido .

Se o Regime for normal não da este erro, mas mantendo seu Regime que é o Simples Nacional da este erro:

Campo:Modalidade de determinação da BC do ICMS - Nenhum valor informado, ou seja

Ou seja, mesmo informando a modalidade,       o   campo   <modBC></modBC>      fica fazio .

    Produto.Imposto.ICMS.modBC        := dbiValorOperacao;
    Produto.Imposto.ICMS.vBC              := DM1.QITENSNOTASBC.AsFloat;
    Produto.Imposto.ICMS.pICMS         := DM1.QITENSNOTASALIQ.AsFloat;
    Produto.Imposto.ICMS.vICMS         := DM1.QITENSNOTASVRICMS.AsFloat;
    Produto.Imposto.ICMS.modBCST   := dbisMargemValorAgregado;
    Produto.Imposto.ICMS.pMVAST     := DM1.QITENSNOTASALIQST.AsFloat;;
    Produto.Imposto.ICMS.pRedBCST  := 0;
    Produto.Imposto.ICMS.vBCST         := DM1.QITENSNOTASBCSUBST.AsFloat;
    Produto.Imposto.ICMS.pICMSST    := DM1.QITENSNOTASALIQST.AsFloat;
    Produto.Imposto.ICMS.vICMSST    := DM1.QITENSNOTASICMSSUBST.AsFloat;
    Produto.Imposto.ICMS.pRedBC      := 0;

Agradeço desde já pela colaboração.

 


{

 

 

 

Você diz "Se o Regime for normal não da este erro, mas mantendo seu Regime que é o Simples Nacional da este erro:" 

No xml postado vc esta usando a ST 00 para ICMS que é de regime normal

 

 

Link to comment
Share on other sites

3 horas atrás, Antonio Carlos L disse:

Você diz "Se o Regime for normal não da este erro, mas mantendo seu Regime que é o Simples Nacional da este erro:" 

No xml postado vc esta usando a ST 00 para ICMS que é de regime normal

 

 

Obrigado por me mostrar este erro Antonio Carlos, fiz uma copia do xml gerado (estou enviando em anexo) que foi validado sem erros. O que esta ocorrendo é que quando vou enviar a  NFe ,o sistema esta alterando o xml, excluindo a tag  <ICMSSN102> , deixando como  <ICMS00>, retornando o erro.    

anterior_ao_envio_31200309148631000127550010000000061552130659-nfe.xml apos_envio_31200309148631000127550010000000061552130659-nfe.xml

Link to comment
Share on other sites

Bom dia a todos 

Tópico >>     Modalidade de determinação da BC do ICMS vazia    >>>      RESOLVIDO

Eu estava procurando o motivo da  "modalidade de determinação da BC do ICMS" estar vazia nas tag´s dos impostos e não percebi que o erro estava ao enviar o xml para a Sefaz, que tinha uma rotina alterando o regime da empresa para  >>   normal.

Agradeço a todos pela colaboração

  • Like 1
Link to comment
Share on other sites

  • Este tópico foi criado há 846 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.