Jump to content

Assista click.png tectoy.png

C6 chamada_c6.png botao.png

ACBRLIB não esta gravando o XML com Autorização


João Paulo Pires
Go to solution Solved by Rafael Dias,
  • Este tópico foi criado há 637 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Boa tarde turma, a alguns dias eu tinha postado essa duvida e achei que tinha solucionado.

mas infelizmente hj um cliente me ligou dizendo que o Danfe estava saindo com os dizeses..."NF não consta no Sefaz"

então segue os arquivos para conferencia e me ajudar, pois não consigo achar o problema. sendo que o PDF esta gerando correto. mas o XML que esta gravado na pasta DFe configurado na LIB parece nao estar com a autorização do sefaz.

31200821525083000102550010000004321430134958-procNFe.xml

 

 

ACBrLibNFE-20200824.log ACBrLib.ini

Link to comment
Share on other sites

5 minutos atrás, João Paulo Pires disse:

Boa tarde turma, a alguns dias eu tinha postado essa duvida e achei que tinha solucionado.

mas infelizmente hj um cliente me ligou dizendo que o Danfe estava saindo com os dizeses..."NF não consta no Sefaz"

então segue os arquivos para conferencia e me ajudar, pois não consigo achar o problema. sendo que o PDF esta gerando correto. mas o XML que esta gravado na pasta DFe configurado na LIB parece nao estar com a autorização do sefaz.

OBS.: tenho outros clientes que Emitem NFCe e nao deu esse erro ainda. somente para NFe, talvez seja alguma configuração.

31200821525083000102550010000004321430134958-procNFe.xml 16 kB · 0 downloads

 

 

ACBrLibNFE-20200824.log 123 kB · 0 downloads ACBrLib.ini 5 kB · 1 download

 

Link to comment
Share on other sites

  • Solution

O erro é o mesmo ainda o xml que esta utilizando não esta com a autorização nele.
Pelo log você esta enviando o ini mandando gravar o xml não esta enviando o mesmo e mandando imprimir, desta maneira sempre vai imprimir com a faixa.

Se quiser imprimir alguma NFe já enviada precisa utilizar o xml que foi retornando pelo metodo enviar.

Consultor SAC ACBr Rafael Dias
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Desenvolvedor ACBrLib.

 

Link to comment
Share on other sites

43 minutos atrás, Rafael Dias disse:

O erro é o mesmo ainda o xml que esta utilizando não esta com a autorização nele.
Pelo log você esta enviando o ini mandando gravar o xml não esta enviando o mesmo e mandando imprimir, desta maneira sempre vai imprimir com a faixa.

Se quiser imprimir alguma NFe já enviada precisa utilizar o xml que foi retornando pelo metodo enviar.

@Rafael Dias como seria o correto. pq para NFCe nao esta aparecendo. talvez seja pq na NFCe nao tem os Dizeres 

Link to comment
Share on other sites

52 minutos atrás, Rafael Dias disse:

O erro é o mesmo ainda o xml que esta utilizando não esta com a autorização nele.
Pelo log você esta enviando o ini mandando gravar o xml não esta enviando o mesmo e mandando imprimir, desta maneira sempre vai imprimir com a faixa.

Se quiser imprimir alguma NFe já enviada precisa utilizar o xml que foi retornando pelo metodo enviar.

outra duvida, para onde vai o arquivo XML com a autorização, pois eu estou enviando para impressão o arquivo xml que esta na pasta configurada no Arquivo INI da LIB

 

Link to comment
Share on other sites

@Rafael Dias olha que interessante, acabei de efetuar o teste aqui com outro Emitente, e a NF saiu sem problema.

ACBrLib.iniACBrLibNFE-20200824.log31200807995502000149550010000016031195951265-nfe.xmlJOÃO PAULO PIRES - NFe1603.pdf

será que pode ser o timeout que no meu cliente a net dele é lenta e nao esta dando tempo de salvar o XML com  a autorização?

Link to comment
Share on other sites

6 minutos atrás, antonio.carlos disse:

@João Paulo Pires verifique o time out...
E confirme o que o Rafael indicou para você...

 

acho que esta gravando o XML mesmo ainda nao processados, pois o meu ACBRLIB.ini esta com esta configuração na chave:
SalvarApenasNFeProcessadas=0
 

ou seja, ele esta gravando o XML, mas como esta com atraso no retorno devido a internet ou algo. Não da tempo de gravar a Autorização no XML.
 

Além do TimeOut o que mais posso aumentar para internet que são bem lentas?

 

Edited by João Paulo Pires
Link to comment
Share on other sites

2 horas atrás, João Paulo Pires disse:

acho que esta gravando o XML mesmo ainda nao processados, pois o meu ACBRLIB.ini esta com esta configuração na chave:
SalvarApenasNFeProcessadas=0
 

ou seja, ele esta gravando o XML, mas como esta com atraso no retorno devido a internet ou algo. Não da tempo de gravar a Autorização no XML.
 

Além do TimeOut o que mais posso aumentar para internet que são bem lentas?

 

se não salvou com a autorização devido a um timeout cabe a sua aplicação fazer o tratamento em caso de erro, fazer consulta do recibo etc...

Consultor SAC ACBr Rafael Dias
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Desenvolvedor ACBrLib.

 

Link to comment
Share on other sites

  • Este tópico foi criado há 637 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.