Jump to content

chamada diadoacbr

Assista tectoy.png

Erro desconhecido ao Enviar MDF-e no comando ACBrMDFe1.Enviar


Go to solution Solved by antonio.carlos,
  • Este tópico foi criado há 636 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Boa Tarde a Todos!

3 horas atrás, BigWings disse:

Não consegui replicar o erro apenas com os fontes, o que eu queria testar eram os binários...

Você diz que em outra máquina não tem erro, isso usando o mesmo EXE e DLLs que está usando na máquina onde o erro ocorre?

Parece que você tem DLLs demais na pasta, CAPICOM, MSXML e XmlSec não são mais necessários.

Sugiro então que faça o seguinte:

- Reinstale o ACBr marcando as opções de não usar CAPICOM e não usar XmlSec, não esquecendo de marcar a opção de copiar as DLLs para a pasta do Windows;

- Recompile a sua aplicação;

- Coloque o seu exe e apenas as DLLs da pasta ACBr\DLLs\LibxXML2\x86 e ACBr\DLLs\OpenSLL\1.1.1.7\x86.

Como você usa Delphi 2010 não vai precisar das DLLs de 64 bits.

Segui todos esses passos , mas infelizmente o erro persisti. Como meu windows 7 64 na instalação o as dll são copiadas para a pasta syswow64 ae copieo a libxml2 pra system32 mas também não resolveu.

3 horas atrás, BigWings disse:

Desconfio da diretiva USE_MINGW, ela pode estar ativada em uma das duas instalações.

Com ela ativada (não é mais recomendado) as DLLs tem que ser as da pasta MinGW.

Bom não seu ela está ativada, pois só se ativa durante a instalação ou de alguma outra forma sem querer eu eu ativei, mas se saber pois nunca usei essa diretiva  USE_MINGW pra ser sincero não sei pra que ela é usada.

Por via das dúvidas copiei as dlls da pasta MinGW, mas não resolveu.😞

Vou tentar desinstalar o ACBr e instalar novamente como última alternativa e torcer pra dar certo.

Obrigado pela Ajuda!

Link to comment
Share on other sites

Boa Tarde

Desinstalei o ACBr e instalei novamente, até com a opção não usar capicom marcada (apesar de ser ela estar me salvando, até agora pois por ela não da erro), mas mesmo assim o erro persisti.

Fui debugando e cheguei no local exato onde ocorre o erro, e na função: LibXmlNodeWasFound que fica na unit ACBrDFeXsLibXml2.

function TDFeSSLXmlSignLibXml2.LibXmlNodeWasFound(ANode: xmlNodePtr;
  const NodeName: String; const NameSpace: String): boolean;
begin
  Result := (ANode <> nil) and (ANode^.Name = NodeName) and
    ((NameSpace = '') or (ANode^.ns^.href = NameSpace));

end;

Em negrito a linha onde ocorre o erro.

Já pus todas as dlls x86 libxml2 junto com o executável e nenhuma resolveu.

Será que vou ter formatar e tentar por o windows 10 32 bits?

Estou testando com 2 certificados de empresas diferentes, mas o problema acontece em ambos.

Obrigado pela Ajuda e Atenção!

Link to comment
Share on other sites

  • Consultores
2 minutos atrás, Mauricio Elias disse:

Boa Tarde

Desinstalei o ACBr e instalei novamente, até com a opção não usar capicom marcada (apesar de ser ela estar me salvando, até agora pois por ela não da erro), mas mesmo assim o erro persisti.

Fui debugando e cheguei no local exato onde ocorre o erro, e na função: LibXmlNodeWasFound que fica na unit ACBrDFeXsLibXml2.

function TDFeSSLXmlSignLibXml2.LibXmlNodeWasFound(ANode: xmlNodePtr;
  const NodeName: String; const NameSpace: String): boolean;
begin
  Result := (ANode <> nil) and (ANode^.Name = NodeName) and
    ((NameSpace = '') or (ANode^.ns^.href = NameSpace));

end;

Em negrito a linha onde ocorre o erro.

Já pus todas as dlls x86 libxml2 junto com o executável e nenhuma resolveu.

Será que vou ter formatar e tentar por o windows 10 32 bits?

Estou testando com 2 certificados de empresas diferentes, mas o problema acontece em ambos.

Obrigado pela Ajuda e Atenção!

Uma dúvida pode ter sido respondido anterior mas houve um problema com um cliente e o mesmo estava com os schemas desatualizados

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

  • Moderadores
9 minutos atrás, Mauricio Elias disse:

function TDFeSSLXmlSignLibXml2.LibXmlNodeWasFound(ANode: xmlNodePtr;
  const NodeName: String; const NameSpace: String): boolean;
begin
  Result := (ANode <> nil) and (ANode^.Name = NodeName) and
    ((NameSpace = '') or (ANode^.ns^.href = NameSpace));

end;

Em negrito a linha onde ocorre o erro.

Veja nas opções de compilação do seu projeto se "Complete boolean evaluation" está ativada.

Se estiver desative, reinstale o ACBr e recompile a aplicação.

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

54 minutos atrás, Juliomar Marchetti disse:

Uma dúvida pode ter sido respondido anterior mas houve um problema com um cliente e o mesmo estava com os schemas desatualizados

Olá Juliomar, sim a pasta schemas está atualizada, e mesmo assim o erro persisti.

 

47 minutos atrás, BigWings disse:

Veja nas opções de compilação do seu projeto se "Complete boolean evaluation" está ativada.

Se estiver desative, reinstale o ACBr e recompile a aplicação.

BigWings a opção Complete boolean evalution já se encontra desativada.

Obrigado pela Ajuda de vocês!

Link to comment
Share on other sites

  • Consultores

Marcelo após fazer a instalação , abra o exemplo do svn e vamos tentar emitir com ele.

depois report aqui configurando igual

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

Olá Boa Tarde Juliomar

5 horas atrás, Juliomar Marchetti disse:

Marcelo após fazer a instalação , abra o exemplo do svn e vamos tentar emitir com ele.

depois report aqui configurando igual

Instalei novamente o ACBr, e fui testar novamente no exemplo de NFe do ACBr, configurei com os dados do certificado, do emitente. Gerei um xml na minha aplicação e fui tentar enviar pelo exemplo do ACBrNFe usando o botão Carregar Xml e Enviar, e desta vez enviou e autorizou, mas isso só no exemplo, pois na minha aplicação ainda persisti o erro.

Então fui olhar o exemplo novamente e o que achei de diferente em relação ao meu foram o comando ACBrNFe1.SSL.DescarregarCertificado que no exemplo e chamado quando le a configuração, não entendi o porque desse comando e não achei o CarregarCertificado nem sei tem e precisa, enfim pus esse comando na minha rotina e o erro persisti, outra coisa que notei diferença foi no procedure LoadXML, então mudei pra ficar igual o exemplo mas não resolveu o problema. Estou debugando o exemplo e não achei até agora nenhuma outra diferença, teve alguma mudança no componente que precisa alterar? Tipo excluir o componente ACBrNfe e colocar novamente? Alguma propriedade nova no ACBrNFe precisa ser setada?

No exemplo que fiz pra configurar e carregar e enviar o xml da o erro também, mas nele o lerconfiguracao e igual o que uso (segue em anexo) mudou alguma coisa que não estou conseguindo ver?

E não entendi porque agora deu certo no exemplo e nas outras vezes não.

 A opção Complete boolean evalution estava false mesmo, e o schemas atualizado.

Obrigado pela Ajuda e Atenção!

 

NFE TESTE_exe.zip

Link to comment
Share on other sites

  • Consultores
10 minutos atrás, Mauricio Elias disse:

Instalei novamente o ACBr, e fui testar novamente no exemplo de NFe do ACBr, configurei com os dados do certificado, do emitente. Gerei um xml na minha aplicação e fui tentar enviar pelo exemplo do ACBrNFe usando o botão Carregar Xml e Enviar, e desta vez enviou e autorizou, mas isso só no exemplo, pois na minha aplicação ainda persisti o erro.

Bom temos agora algo para partir. Funciona o exemplo em seu micro.

Pasta de schemas ok

Configuração de Webservice Ok

Configuração de certificado OK

o TLS 1.2 está já assinalado no componente OK

o método estão iguais para preencher os dados OK.

faltou alguma coisa?

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

Olá Boa Tarde Juliomar

2 horas atrás, Juliomar Marchetti disse:

Bom temos agora algo para partir. Funciona o exemplo em seu micro.

Pasta de schemas ok

Configuração de Webservice Ok

Configuração de certificado OK

o TLS 1.2 está já assinalado no componente OK

o método estão iguais para preencher os dados OK.

faltou alguma coisa?

Pasta de Schemas ok é a mesma usada no exemplo do ACBrNFe.

Configuração do Webservice ok

na minha versão:
ACBrNFe1.Configuracoes.WebServices.UF         := cbUF.Text;
ACBrNFe1.Configuracoes.WebServices.Ambiente   := StrToTpAmb(Ok,IntToStr(rgTipoAmb.ItemIndex+1));
ACBrNFe1.Configuracoes.WebServices.Visualizar := ckVisualizar.Checked;

ACBrNFe1.SSL.SSLType := TSSLType( cbSSLType.ItemIndex );

no exemplo:

with ACBrNFe1.Configuracoes.WebServices do
  begin
    UF         := cbUF.Text;
    Ambiente   := StrToTpAmb(Ok,IntToStr(rgTipoAmb.ItemIndex+1));
    Visualizar := cbxVisualizar.Checked;

end;

ACBrNFe1.SSL.SSLType := TSSLType(cbSSLType.ItemIndex);

Configuração do certificado ok usei o mesmo certificado no exemplo e da mesma forma informando o numero de serie.

na minha versão:

ACBrNFe1.Configuracoes.Certificados.NumeroSerie := edtNumSerie.Text;

no exemplo

ACBrNFe1.Configuracoes.Certificados.NumeroSerie := edtNumSerie.Text;

o TLS 1.2 está já assinalado no componente OK

sim ACBrNFe1.SSL.SSLType := TSSLType( cbSSLType.ItemIndex );

SSLCRYPTLIB: cryWinCrypt

SSLHttpLib: httpWinHttp

SSLLib: libWinCrypt

SSLXmlSignLib: xsLibXml2

SSLType: LT_TLSv1_2

o método estão iguais para preencher os dados você quer dizer preencher os dados da nota se sim estão ok, tanto que gero xml no sistema e envio pelo exemplo e validado e autorizado.

Na hora de Gerar enviar está da seguinte ordem:

LerConfiguracao;
 ACBrNFe1.NotasFiscais.Clear;

  GerarNFe(ME_nronota.Text);//alimenta os dados da nota

ACBrNFe1.NotasFiscais.Imprimir;// exibe o espelho da nota

if (ACBrNFe1.Enviar(0, false) = true)
then

na hora de enviar acontece o erro quando entra no metodo assinar.

Como disse antes a única função diferente que notei no exemplo foi a ACBrNFe1.SSL.DescarregarCertificado .

Coloquei ela mas o erro é o mesmo no mesmo lugar de sempre.

Desculpa senão entendi alguma pergunta sua, espero te respondido o que você perguntou.

Também exclui o componente ACBrNfe e coloquei outro já que foi atualizado mas o erro persisti.

O que mais posso conferir?

Obrigado pela Ajuda!

Link to comment
Share on other sites

  • Consultores

Tu entendeu e descreveu exatamente o que precisava pra entender.

Confere dll junto ao executável ou as propriedades mesmo se estão configuradas iguais

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

  • Consultores

Tu entendeu e descreveu exatamente o que precisava pra entender.

Mas não consegui saber o que está ocorrendo para o erro existir.

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

Olá Bom Dia Juliomar!

Estranho que usando Tls 1_2 o status do serviço funciona sem problema ou seja certificado e acho que a dll estão funcionando.

No exemplo do ACBr não fica nenhuma dll na pasta então usa as que vai na pasta do windows? No meu caso na syswon64.

9 horas atrás, Juliomar Marchetti disse:

Tu entendeu e descreveu exatamente o que precisava pra entender.

Confere dll junto ao executável ou as propriedades mesmo se estão configuradas iguais

Testei todas as dlls, todas de x86 e o erro persisti. Já coloquei as que o BigWings falou, tentei fazer o que o Daniel disse nesses tópicos:

E nada resolve o problema.

Olhei as propriedades está ta quase udo igual, a única diferença e que no componente ACBrNFe no exemplo no eventos, na opção OngerarLog está com nome ACBrNFe1GerarLog e na minha versão não consigo por esse nome da o erro Property and Method ACBrNFe1GerarLog are not compatible.

Esse evento gera arquivo de log de tudo que acontece no ACBrNFe? Se sim no meu caso poderia indicar algum possível problema?

Porque não consigo ativar esse evento no componente na minha versão? 

Acho que o problema pode estar na atualização do ACBr no meu delphi, por favor vocês poderiam me passar os passos para eu desinstalar totalmente o ACBr?

E só usar o apagarAcbr?

Pois depois de desinstalar ele vou apagar o conteúdo da pasta ACBr a baixar novamente pra só depois instalar.

Pois a única explicação desse erro e de nada solucionar só pode ser na instalação(atualização no meu caso apesar de já ter reinstalado 4x), senão for isso então e alguma coisa relacionada a versão do windows ser 64 bits ou a atualização do windows apesar estar tudo atualizado a atualização fico com algum problema.

Uso o ACBr a muito tempo e nunca passei por um problema(persistente) desse tipo, depois de uma atualização.

Desde já Muito Obrigado pela Ajuda e paciência comigo!

Link to comment
Share on other sites

  • Este tópico foi criado há 636 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.