Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

logos

Texto.png

p200

Dificuldade com Layout NFSe Pato Branco - PR


Go to solution Solved by Jefferson Damian,
  • Este tópico foi criado há 128 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

Não estou conseguindo enviar NFSe para o provedor Pronim que atende a cidade de Pato Branco.

Estava dando erro no código da lista de serviços, eles me orientaram como deveria ser
daí agora quando envio dá erro que que o arquivo não foi encontrado.
Entrei em contato com eles e disseram que é o XML que está errado. 

Quando tento enviar, e dá erro, o sistema cria um XML na pasta que está configurada
para os LOGs, não sei se esse XML é o certo mas, é o único que está sendo gerado e foi
o que eu enviei.

Haaa, estou enviando usando o método "Enviar".

Em anexo o XML que enviei e um que me enviaram como modelo e também vou colocar o INI 
de configuração do Provedor, é possível que estou errando nas configurações.

Desde já agradeço a ajuda.

Pronimv2.ini Meu-rps.xml RPS Exemplo.xml

Link to post
Share on other sites
13 minutos atrás, Italo Giurizzato Junior disse:

Bom dia Jefferson,

Você esta usando o programa exemplo para fazer os testes?

Italo, não usei o programa exemplo porque nosso sistema já está funcionando com a Betha a vários anos.
então apenas tentei acertar as configurações do provedor.

Link to post
Share on other sites
  • 2 weeks later...
Em 24/11/2020 at 10:07, Italo Giurizzato Junior disse:

Jefferson,

Então faça os testes com o programa exemplo.

Fiz o teste com o programa exemplo, o XML vai mas não retorna nada, nem erro

Depois tentei replicar em nosso sistema para ver se ficava diferente.
enviou e retornou um erro não especificado.
Enviei o XML para eles e me responderam hoje dizendo o seguinte:

"Conforme análise realizada, para o envio correto do XML será necessário corrigir os itens abaixo:

Remover informação desnecessário na TAG: <EnviarLoteRpsEnvio xmlns="http://www.abrasf.org.br/nfse.xsd">
>Remover o texto (xmlns="http://www.abrasf.org.br/nfse.xsd")

Acrescentar a TAG: <CodigoTributacaoMunicipio>2539001</CodigoTributacaoMunicipio>

Removido a TAG: <CodigoCnae>2539001</CodigoCnae>

Faltando a TAG: <Numero>1</Numero>
>No endereço do tomador informar a TAG "<Número>".

Na TAG: <RegimeEspecialTributacao>3</RegimeEspecialTributacao>
>O regime especial de tributação na não está de acordo com o informado no cadastro municipal, (item 5.2 página 22 do manual ABRASF), correto informar "6".

Obs: Em anexo os arquivos com todos os ajustes necessários, XML e PDF da nota emitida em teste (cancelada).

Qualquer duvida estou a disposição.

Atenciosamente,"

 

 

Link to post
Share on other sites

Boa tarde Jefersson,

Favor anexar o XML de envio do lote que o componente esta gerando e o que o provedor alterou para fazer funcionar.

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to post
Share on other sites
7 minutos atrás, Italo Giurizzato Junior disse:

Boa tarde Jefersson,

Favor anexar o XML de envio do lote que o componente esta gerando e o que o provedor alterou para fazer funcionar.

Desculpa esqueci.

Tem o XML em TXT comentado
o XML deles
O meu XML

Atualizei o ACBr Sexta-feira 04/12/2020, já vi que tem algumas coisas novas para acrescentar
Espero que o Erro seja apenas erro meu que é mais fácil.

Haa, vai perceber que o número no meu_XML é diferente, isso eu já adequei. 
e o "RegimeEspecialTributacao" eu não tinha todas as opções cadastradas também OK.
Mas ainda não está indo e retorna um erro não especificado. e depois diz que não encontrou o arquivo XML.

 

Desde ja muito obrigado pela ajuda.

202000000000016.txt

Meu-rps.xml 202000000000016.xml

Link to post
Share on other sites

Boa tarde Jefferson,

Você fez confusão.

Eu lhe pedi o XML de envio do lote de Rps gerado pelo componente e não o XML do RPS.

Pedi também o XML de envio do lote de como tem que ser, ou seja, com as correções feita pelo pessoal do provedor.

Em TXT consta o retorno do envio e o outro em XML é o XML da NFSe.

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to post
Share on other sites
  • Solution
Em 11/12/2020 at 15:39, Italo Giurizzato Junior disse:

Boa tarde Jefferson,

Você fez confusão.

Eu lhe pedi o XML de envio do lote de Rps gerado pelo componente e não o XML do RPS.

Pedi também o XML de envio do lote de como tem que ser, ou seja, com as correções feita pelo pessoal do provedor.

Em TXT consta o retorno do envio e o outro em XML é o XML da NFSe.

Descobri que se eu deixo a Versão do XML errada (o padrão que está no Pronimv2.ini)
Ele gera dois XML que estão em anexo mas se coloco a versão 2.03 dá erro ao assinar,
mas se configuro para não assinar, dá erro ao validar e retorna a mensagem:
"Não foi possível carregar o arquivo.
Err: -1072896763, Lin: 1, Pos: 289 - A name contained an invalid character."

Em anexo também o TXT contendo o conteúdo da estring sendo enviado no ValidarLote.

Esse é o Valida lote.
Procedure TNotasFiscais.ValidarLote(const XMLLote, NomeArqSchema: String);
 

161-env-lot.xml 161-env-lot-soap.xml Xtring sendo passada no Valida.txt

Edited by Jefferson Damian
Link to post
Share on other sites
  • 2 weeks later...
Em 15/12/2020 at 09:18, Jefferson Damian disse:

Descobri que se eu deixo a Versão do XML errada (o padrão que está no Pronimv2.ini)
Ele gera dois XML que estão em anexo mas se coloco a versão 2.03 dá erro ao assinar,
mas se configuro para não assinar, dá erro ao validar e retorna a mensagem:
"Não foi possível carregar o arquivo.
Err: -1072896763, Lin: 1, Pos: 289 - A name contained an invalid character."

Em anexo também o TXT contendo o conteúdo da estring sendo enviado no ValidarLote.

Esse é o Valida lote.
Procedure TNotasFiscais.ValidarLote(const XMLLote, NomeArqSchema: String);
 

161-env-lot.xml 5 kB · 1 download 161-env-lot-soap.xml 5 kB · 0 downloads Xtring sendo passada no Valida.txt 336 B · 0 downloads


O Erro não estava propriamente no compotente e sim o atendente da prefeitura de Pato Branco que sempre me dizia que não recebeu informação nenhuma. A última vez que liuei o atedente disse que não possuia acesso ao ambiente de testes e pe passou um link para eu ver com o Usuário e senha que o cliente usa para enviar NFSe online.
Quando acessei pude consultar o RPS e ver qual era o erro. Basicamente o erro era no código fr tributação do município (CNAE), número do telefone do Tomador que faltava o DDD e o Valor da alíquota.
Feitas as correções funcionou.

 

Link to post
Share on other sites
  • Este tópico foi criado há 128 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui
Guest
This topic is now closed to further replies.
×
×
  • Create New...