Jump to content

chamada diadoacbr

Assista tectoy.png

Após desligar impressora nao imprimi


Molusko Israelita
Go to solution Solved by José M. S. Junior,
  • Este tópico foi criado há 542 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Olá amigos, boa noite, 

Estou enfrentando um problema com a lib de etiqueta, veja se conseguem me ajudar por favor.. 
Estou utilizando C# , 
O que acontece é o seguinte, a impressora não imprimia de forma alguma, ela piscava que recebia os dados, porém nada era impresso

Resolve fazer o teste com o executavel ETQTeste e ele imprimiu, após executar o etqteste fui ao sistema novamente e tentei emitir uma etiqueta e imprimiu
imprimi várias, porém após desligar e ligar a impressora a mesma volta a não imprimir, somente quando eu entro no programa etqteste e imprimo algo após isso ela funciona normal, porém 

é só desligar que começa tudo de novo .. Alguém sabe me dizer o que pode estar acontecendo ? Obrigado , segue código para impressão: 

 

private static void Imprimir(ProdutoEan pEan, int quantidade)
        {

            acbrEtq.ConfigLer();

            acbrEtq.Ativar();

            acbrEtq.ImprimirTexto(ETQOrientacao.orNormal, 3, 2, 2, 250, 3, pEan.Produto.Prd_DescricaoReduzida);
            acbrEtq.ImprimirBarras(ETQOrientacao.orNormal, TipoCodBarra.barEAN13, 2, 2, 13, 8, pEan.Pean_Ean, 150, ETQBarraExibeCodigo.becSIM);
            acbrEtq.ImprimirCaixa(13, 32, 56, 17, 1, 1);
            acbrEtq.ImprimirTexto(ETQOrientacao.orNormal, 3, 3, 2, 18, 350, "R$");
            acbrEtq.ImprimirTexto(ETQOrientacao.orNormal, 3, 4, 4, 15, 500, pEan.Produto.Prd_Preco1.ToString("0.00").Replace(".",","));


            acbrEtq.Imprimir(aCopias: quantidade);
            acbrEtq.Desativar();
        }

Link to comment
Share on other sites

  • Consultores

Bom dia, provavelmente alguma configuração que está sendo passada em tela através do ETQTeste não está sendo passado no ACBrLib.ini da lib.  Chegou a verificar se as configurações do ACBrLib.ini  estão iguais ao ETQTeste?

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Membros Pro

Bom dia , 

 

Vou mandar as configurações do acbrlib.ini e as que coloquei no etqteste

 

[ETQ]
ArqLog=
Porta=RAW:Argox OS-214 plus series PPLA
Temperatura=10
Velocidade=0
Avanco=0
MargemEsquerda=0
LimparMemoria=1
Ativo=0
PaginaDeCodigo=2
Modelo=1
Unidade=3
BackFeed=0
Origem=0
DPI=1

[ETQ_Device]
Baud=9600
Data=8
Timeout=3
Parity=0
Stop=0
MaxBandwidth=0
SendBytesCount=0
SendBytesInterval=0
HandShake=0
SoftFlow=0
HardFlow=0

Imprimi pelo botao Etiqueta Simples .. 

Obrigado !

 

acbr.jpg.1529e3205cc95e220a5ff68095e6994c.jpg

Link to comment
Share on other sites

  • Consultores
  • Solution

O unico detalhe que notei na configuração é referente a "Unidade" por padrao deixe 1

Está utilizando o Demo ACBrLibEtq Demo em C# para testes? Pois no seu código notei que não está passando os métodos de IniciarEtiqueta e FinalizarEtiqueta após a passagem de todos os métodos. 

Veja como deveria ficar o bloco completo:

https://acbr.sourceforge.io/ACBrMonitor/ETQImprimir.html

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Membros Pro

Obrigado pela resposta José... Eu mudei essa unidade, deu um monte de erro e tive que refazer o layour , porém continua acontecendo a mesma coisa... 

Eu tinha feito inicialmente a classe com os métodos iniciarEtiqueta e FinalizarEtiqueta, porém na Demo vi que não constam esses métodos no código , ai eu retirei pq achei que poderiam ser eles que estavam causando isso ..

Como eu disse, no ETQTeste eu consigo normal imprimir, 

Porém na Demo do C# eu nao consigo imprimir, parece que ela nao consegue carregar as dll, tentei mexer no código da demo para tentar uma possível solução , porém me parece que o código não aceita edição ... 

Estou batendo mto a cabeça nisso 

Link to comment
Share on other sites

  • Membros Pro

Boa tarde,

Estou acompanhando aqui tambem, estou tendo alguns problemas com relação a impressão com a lib, estou usando a mesma sequencia que o @Molusko Israelita

Estou com um cliente que diz que só imprimir uma vez, na segunda vez que envia dar erro Unable to open file \\server-xxx\btp-l42(u)-server  na impressora em rede

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.