Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

consultoria_sticker.png

Conteúdo para desenvolvedores
 ao vivo de terça a quinta!
Saiba mais

dev.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


botao.png

beneficios.png

Caracteres estranhos no retorno da função NFE_Enviar


Go to solution Solved by Daniel Simoes,

Recommended Posts

  • Usuários SAC

Boa tarde pessoal!

Estou utilizando a ACBrLibNFe em um projeto .NET e após enviar uma NFCe utilizo o método NFE_UltimoRetorno e estou recebendo o retorno com caracteres estranhos. Segue exemplo:

[Envio]
CStat=778
CUF=31
DhRecbto=30/12/1899
Msg=Rejeição: Informado NCM inexistente [nItem: 1]
NProt=
NRec=
TMed=0
VerAplic=W-1.4.45
Versao=4.00
XMotivo=Rejeição: Informado NCM inexistente [nItem: 1]
tpAmb=2

Já estou tratando o retorno do mesmo modo que vi pelo projeto de exemplo em C# da ACBr.

image.png.8cb5182ddc7947f1508d48424627827f.png

image.png.07e9f0b27854e53417f981e8c24754b1.png

Existem mais algum tratamento que eu preciso realizar?

 

Link to post
Share on other sites

Obrigado por reportar.

Fechando. Para novas dúvidas, criar um novo tópico.

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...