Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

clube mobile


Cursos grátis para toda base ACBr
+ Promoção Clube Mobile para o ACBr Pro

Saiba mais

adriano santos

click.png

click.png

click.png

click.png

click.png

click.png

Recommended Posts

vamos lá coloca um ponto de parada no local abaixo e veja se tem mesmo algo carregado, ali ele está sugerindo que tem uma informação com o zero mas eu acho que não carregou

image.png

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil
Link to post
Share on other sites
Posted (edited)

Pelo que vi no código, ele somente adiciona uma guia na procedure AlimentarComponente, e quando chamamos o envio do e-mail, ele não chama essa procedure.

Mas no caso, deveria apenas enviar o XML selecionado no LoadFromFIle, certo?

 

image.png.75c8e74fe285ef4020b83cc90a3df2cd.png

Não está criando a guia nessa linha de carregamento do arquivo.

Edited by JonasDBicaio
Link to post
Share on other sites

Juliomar,

Já tentei utilizar todos os arquivos possíveis dentro da pasta.

A principio penso ser o correto o que anexei no primeiro post, que é o mesmo que gero o PDF.

Tem um exemplo de XML ai pra eu testar?

Link to post
Share on other sites
2 horas atrás, JonasDBicaio disse:

Juliomar,

Já tentei utilizar todos os arquivos possíveis dentro da pasta.

A principio penso ser o correto o que anexei no primeiro post, que é o mesmo que gero o PDF.

Tem um exemplo de XML ai pra eu testar?

Não. não emito GNRE. somente mantenho o componente

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil
Link to post
Share on other sites
Posted (edited)

Removi o ACBr, instalei novamente, e rodei o demo.

Realmente o envio de e-mail não está funcionando, a geração de PDF e impressão via XML funciona 100%.

 

image.png.071bc902d8a60b19b4ac99d0a8000667.png

 

Tentei enviar com base em todos esses arquivos.

Edited by JonasDBicaio
Link to post
Share on other sites

Pessoal, bom dia!

Verifiquei que ele não envia o e-mail porque procura por um arquivo diferente do que é salvo na pasta de PDFs.

Alguém sabe como corrigir, ou como retornar o caminho/nome do arquivo no ato em que o PDF é salvo?

Como salva:

image.thumb.png.51f915518853a95715cd67a634de7c64.png

 

Como envia o e-mail: 

image.png.4b2d95ed886086147c1d62f8fb30f419.png

 

Link to post
Share on other sites

Enviei ao SVN uma possível correção ao problema acima.

favor atualizar, recompilar e testar

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...