Jump to content
Notícias do ACBr

logos

Texto.png

p200

logos

Texto.png

p200

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

Erro apresentado ao assinar NFS-e Cataguases-MG


Go to solution Solved by Italo Giurizzato Junior,

Recommended Posts

  • Usuários SAC

Bom dia, estou tentando emitir NFS-e em Cataguases-MG. Meu sistema atualmente envia somente uma NFS-e por vez,
tentei usar o comando ACBrNFSe1.Gerar como sugere o exemplo e obtenho o seguinte erro:

Erro Interno: 0
Erro HTTP: 500
URL: http://homologacaocataguases.agilistecnologia.com.br/webservices/2.02/servicos

<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"><SOAP-ENV:Body><SOAP-ENV:Fault><faultcode>SOAP-ENV:Server</faultcode><faultstring>Procedure 'GerarNfse' not present</faultstring></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>


Tentei utilizar o ACBrNFSe1.Enviar, e consigo assinar a nota normalmente porém na hora de pegar os dados retornados
para salvar as informações recebidas, obtenho o retorno de uma nota aleatória(número, etc) parece que o componente está adicionando uma nota a mais, ja fiz a verificação de quantas notas tem no ACBrNFSe1 antes do envio e tem somente uma, depois que termina a rotina enviar já estou com 2 notas dentro.

alguém tem ideia do que pode ser? 

desde já agradecido.

Link to post
Share on other sites
  • Solution

Boa tarde,

Favor atualizar os fontes e faça novos testes.

Note que fiz alteração no arquivo INI do provedor também.

  • Like 1
Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to post
Share on other sites
  • Usuários SAC

Boa tarde,

O envio funcionou perfeitamente, só que continuo com o mesmo problema de retorno, estou tentando fazer o envio de teste com o número de nota 180520.

 O ACBrNFSe1.NotasFiscais.Items[0].NFSe.Numero recebe vazio '',

e na posição  ACBrNFSe1.NotasFiscais.Items[1].NFSe.Numero está me retornando o valor 100463

quando dou o add, estou adicionando somente a numeração 180520, isso já foi verificado.

obs: Consegui fazer o envio pelo .gerar 

 

Link to post
Share on other sites

Veja bem,

Você envia o Rps e o provedor retorna o XML da NFS-e.

Qual método você esta usando para enviar o Rps?

O numero do Rps deve ser sequencial e controlado pelo seu sistema.

O numero da NFS-e é sequencial e é gerado pelo webservice do provedor.

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to post
Share on other sites
  • Usuários SAC

Bom dia Ítalo!

acabei me confundindo aqui, está tudo funcionando.

Obrigado pela atenção, tenha uma boa semana.

  • Like 1
Link to post
Share on other sites

Obrigado por reportar.

Fechando. Para novas dúvidas, criar um novo tópico.

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil
Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...