Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

logos

Texto.png

p200

click.png

click.png

click.png

Adaptação do DANFE_NFCe.fr3 para FastReport 4


Go to solution Solved by andreiluis,

Recommended Posts

  • Usuários SAC

Bem, seguindo a orientação do @BigWings no tópico abaixo e pelo tempo exíguo que tenho, vou ajustar o DANFE_NFCe que tenho aqui que está abrindo.

Está quase tudo à contento, mas o maior problema é que não está aparecendo as informações de pagamento

image.png.7c3fd0f5cb603d9832d3502ccef5e671.png

 

O dataset está setado para Pagamento na banda MasterData4 e no xml a tag pag está preenchida, porque não puxa os dados para o DANFE?

image.thumb.png.75d18f7b9dcfded9a6ec97625b28344d.png

image.png.4418734418c0fe95934657075ea48741.png

 

Coloquei no rodapé do DANFE os campos ref ao pagamento, mas vem em branco / zerado. Onde os datasets do layout são alimentados?

 

image.png.9e481322b525db6342df80986a80bcb7.png

 

 

 

 

Link to post
Share on other sites
1 minuto atrás, andreiluis disse:

O dataset está setado para Pagamento na banda MasterData4 e no xml a tag pag está preenchida, porque não puxa os dados para o DANFE?

Está usando o componente para DANFe NFCe?

  • Like 1
Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to post
Share on other sites
  • Usuários SAC
2 minutos atrás, BigWings disse:

Está usando o componente para DANFe NFCe?

Claro, que tipo de "bocaberta" tu acha que sou? ..... Opa, não, tô usando o DANFE NFe.😬😖

Ahhhhhh meu coraçaummmmm, é vergonha alheia que chama né? Muito obrigado @BigWings

 

Aproveitando, quando abro o layout novo e aparece msg de erro, o layout até abre, mas não seta os datasets, a lista dos datasets está vazia, saberia me dizer onde eu ajusto isso?

image.png.36807fd3ec45f3135502ac5b20e0a44b.png

 

 

Link to post
Share on other sites
51 minutos atrás, andreiluis disse:

Aproveitando, quando abro o layout novo e aparece msg de erro, o layout até abre, mas não seta os datasets, a lista dos datasets está vazia, saberia me dizer onde eu ajusto isso?

Tenta colocar o ACBrNFeDANFCEFR e o frxReport num mesmo formulário ou data module, e abre o .fr3 por ele.

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to post
Share on other sites
  • Usuários SAC
2 horas atrás, BigWings disse:

Tenta colocar o ACBrNFeDANFCEFR e o frxReport num mesmo formulário ou data module, e abre o .fr3 por ele.

Fiz em design e execução, mesmo problema, quando abre exibe a msg abaixo e os datasets ficam do jeito que mandei no outro post.

Se eu fosse montar um layout do zero, como setaria os datasets dentro do FR3?

 

 

image.png

Link to post
Share on other sites
  • Usuários SAC
  • Solution

Então..... depois de quebrar muito a cabeça, pesquisa daqui, pesquisa dali, resolvi abrir os .fr3 (o novo o trunk, e o meu que ainda funciona) no notepad++, e eis que são arquivos xml e no .fr3 do trunk identifiquei de cara as classes datasets, formats e variables que aparecem no print do post anterior (vide prints abaixo). Excluí essas seções, e copiei o PropData do xml que funcionava para o novo e..... voilá! As definições de vírus foram atualizadas. Ahh não, .... layout atualizado! Ufa! Facinho.

Fazer mais alguns testes, mas parece que está tudo ok. Muito obrigado @BigWings  e  @Juliomar Marchetti  pelo tempo e paciência.

Citar

Esta parte da minha vida...
Esta pequena parte da minha vida...
Chama-se felicidade.
À Procura da Felicidade

 

image.png.40567a9de8dcebdc996de8af07ef019f.pngimage.png.8640280f8809b5b00ca15ab4ff00d41c.pngimage.png.3a2a33a581a0bde68f500e3996c5bcc8.png

  • Like 1
Link to post
Share on other sites
×
×
  • Create New...