Jump to content

Delphi chamada_delphi.png acbr.png

C6 chamada_c6.png botao.png

NFSe - ISSRio - Erro no Formato ItemListaServico


Go to solution Solved by Italo Giurizzato Junior,
  • Este tópico foi criado há 210 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Boa noite,

Estamos tendo retorno de erro ao enviar o RPS para ISSRio. 

O erro:
E104-Campo item da lista de serviço informado incorretamente
Correção: O campo item da lista de serviço deverá ter tamanho máximo de 4 caracteres.

Pelo que verifiquei no manual do provedor (print anexo), o serviço deve ser informado sem formatação.
Ex.: 1401
Porém, o Acbr está gerando ele assim: <ItemListaServico>14.01</ItemListaServico>  no XML de envio (em anexo).

Como proceder?

Obrigado

ISSRio_manual.png

649-env-lot-soap.xml 649UNICA-rps.xml

Valdir Dill

Rio de Janeiro - RJ

 

 

Link to comment
Share on other sites

  • Consultores

Qual componente?

Consultor SAC ACBr

Victor H Gonzales - Pandaaa
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

"Aprender é a única coisa que a mente nunca se cansa, nunca tem medo e nunca se arrepende” - Leonardo da Vinci

"Ter sucesso é falhar repetidamente, mas sem perder o entusiasmo"

Link to comment
Share on other sites

  • Consultores
  • Solution

Bom dia Valdir,

Enviei para o SVN uma possível correção para este problema.

Detalhe importante, essa correção foi aplicada somente no novo componente.

  • Like 1
Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Membros Pro
2 horas atrás, Italo Giurizzato Junior disse:

Bom dia Valdir,

Enviei para o SVN uma possível correção para este problema.

Detalhe importante, essa correção foi aplicada somente no novo componente.

Bom dia

Perfeito. Fontes atualizados e problema corrigido.

Obrigado.

  • Like 1

Valdir Dill

Rio de Janeiro - RJ

 

 

Link to comment
Share on other sites

  • Este tópico foi criado há 210 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.