Jump to content

S-2240 dando erro em mais de 1 EPI


Go to solution Solved by Marcelo Pontes Melim,
  • Este tópico foi criado há 169 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Prezados, preciso de uma ajuda para solucionar um erro com minha estrutura XML da tabela S-2240, venho fazendo o envio com sucesso, até que me deparei com um colaborador que possui mais de 1 risco e mais de 1 EPI por risco, no momento da leitura do ACBR dá erro no segundo EPI informado, alguem sabe informar o que esta de errado com a minha estrutura?

S-2240-(erro).xml

Link to comment
Share on other sites

  • Solution

Olá hastaman2! 

Me desculpe pela resposta anterior, mas, acabei de ler novamente o manual dos eventos do e-Social e existe, na realidade, um erro no XML que você disponibilizou.

A TAG <epiCompl> só pode ocorrer uma vez no XML de acordo com a página 116 do referido manual.

Veja se não é por isso.
 

Link to comment
Share on other sites

4 horas atrás, Marcelo Pontes Melim disse:

Olá hastaman2! 

Me desculpe pela resposta anterior, mas, acabei de ler novamente o manual dos eventos do e-Social e existe, na realidade, um erro no XML que você disponibilizou.

A TAG <epiCompl> só pode ocorrer uma vez no XML de acordo com a página 116 do referido manual.

Veja se não é por isso.
 

Marcelo, obrigado pelo retorno, vou ler mais uma vez essa parte do manual, pra mim não faz sentido pôr apenas 1 complemento pra mais de 1 EPI. Para a empresa os EPIs são tratados separadamente cada qual com seu complemento, sua validade, eficiência... Mas se tratando de governo né, vamos ver. Vou ler, fazer alguns teste, e dou um feedback aqui.

 

 

Link to comment
Share on other sites

  • 3 weeks later...
Em 10/02/2022 at 11:47, Marcelo Pontes Melim disse:

Olá hastaman2! 

Me desculpe pela resposta anterior, mas, acabei de ler novamente o manual dos eventos do e-Social e existe, na realidade, um erro no XML que você disponibilizou.

A TAG <epiCompl> só pode ocorrer uma vez no XML de acordo com a página 116 do referido manual.

Veja se não é por isso.
 

Prezado, Marcelo, obrigado pela ajuda, depois de muita correria vim postar o arquivo xml com a estrutura correta.

S-2240-(corrigido).xml

Link to comment
Share on other sites

  • Este tópico foi criado há 169 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.