Jump to content

Assista tectoy.png

chamada diadoacbr

NFS-e Provedor IPM


Infoel
  • Este tópico foi criado há 132 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Boa tarde,

Estou tentando emitir uma nota fiscal de serviço que utiliza o provedor IPM na cidade de Nova Erechim-SC e estou parando em algumas questões. A primeira delas foi a falta de arquivo denominado IPM.ini. Criei um arquivo manualmente e inseri na pasta da minha aplicação. Como não sabia o que informar nesse arquivo, não tenho certeza se ele está funcionando corretamente. Depois de criado, tive progresso, mas parei em outro erro informando que este provedor requer WEBUSER. Inseri no sistema as seguintes configurações: ACBrNFSe1.Configuracoes.Geral.Emitente.WebUser
ACBrNFSe1.Configuracoes.Geral.Emitente.WebSenha

Preenchi nessas tags a informação de login que o cliente utiliza para o Webservice. Porém ao gerar a nota retorna ao erro:

Lote: 000025
Erro Interno: 0
Erro HTTP: 401
URL: https://novaerechim.atende.net/atende.php?pg=rest&service=WNERestServiceNFSe&cidade=padrao

{"retorno":{"msg":"Acesso Negado!","sis":false,"code":401}}

 

Alguma ideia do que posso fazer para corrigir esse erro?

Anexado arquivo que estou utilizando ao tentar emitir.

Desde já, agradeço.

IPM.ini

Link to comment
Share on other sites

16 horas atrás, Infoel disse:

Boa tarde,

Estou tentando emitir uma nota fiscal de serviço que utiliza o provedor IPM na cidade de Nova Erechim-SC e estou parando em algumas questões. A primeira delas foi a falta de arquivo denominado IPM.ini. Criei um arquivo manualmente e inseri na pasta da minha aplicação. Como não sabia o que informar nesse arquivo, não tenho certeza se ele está funcionando corretamente. Depois de criado, tive progresso, mas parei em outro erro informando que este provedor requer WEBUSER. Inseri no sistema as seguintes configurações: ACBrNFSe1.Configuracoes.Geral.Emitente.WebUser
ACBrNFSe1.Configuracoes.Geral.Emitente.WebSenha

Preenchi nessas tags a informação de login que o cliente utiliza para o Webservice. Porém ao gerar a nota retorna ao erro:

Lote: 000025
Erro Interno: 0
Erro HTTP: 401
URL: https://novaerechim.atende.net/atende.php?pg=rest&service=WNERestServiceNFSe&cidade=padrao

{"retorno":{"msg":"Acesso Negado!","sis":false,"code":401}}

 

Alguma ideia do que posso fazer para corrigir esse erro?

Anexado arquivo que estou utilizando ao tentar emitir.

Desde já, agradeço.

IPM.ini 316 B · 0 downloads

Prezado

Em meu município também houve alteração para o atende.net. Estou utilizando o componente ACBrNFSeX. Consegui autorizar a nota ao editar o arquivo de parâmetros adicionando a versão como no exemplo abaixo:

[3107406]
Nome=Bom Despacho
UF=MG
Provedor=IPM
Versao=1.01

Link to comment
Share on other sites

O componente novo possui um único arquivo, ACBrNFSeXServicos.ini, o qual é disponibilizado como resource no próprio componente, mas também pode ser carregado do disco em runtime.
Fiz as alterações apenas nele, pois já avia feito a migração para o ACBrNFSeX.

Porém, faça o teste adicionando o parâmetro ao cidades.ini. 

  • Like 1
Link to comment
Share on other sites

  • Este tópico foi criado há 132 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.