Jump to content

JonasDBicaio

Membros
  • Posts

    9
  • Joined

  • Last visited

Posts posted by JonasDBicaio

  1. Pessoal, bom dia!

    Verifiquei que ele não envia o e-mail porque procura por um arquivo diferente do que é salvo na pasta de PDFs.

    Alguém sabe como corrigir, ou como retornar o caminho/nome do arquivo no ato em que o PDF é salvo?

    Como salva:

    image.thumb.png.51f915518853a95715cd67a634de7c64.png

     

    Como envia o e-mail: 

    image.png.4b2d95ed886086147c1d62f8fb30f419.png

     

  2. Resolvido.

    @Duesoft Sistemas, sete as configurações da seguinte forma que deve resolver:

     

      ACBrGNRE1.Configuracoes.Geral.SSLLib := libOpenSSL;
      ACBrGNRE1.Configuracoes.Geral.SSLCryptLib := cryOpenSSL;
      ACBrGNRE1.Configuracoes.Geral.SSLHttpLib := httpWinHttp;
      ACBrGNRE1.Configuracoes.Geral.SSLXmlSignLib := xsLibXml2;

     

    • Like 1
  3. Boa tarde, Pessoal

    Estou com dificuldades na configuração dos certificados.

    Meu projeto é um serviço, e quando utilizo via Capicom, diz que não encontra o certificado pelo número de série, e quando utilizo via OpenSSL, retorna outro erro. Segue:

    OpenSSL

    ERRO: 
    Inicio TGNRERetRecepcao
    ERRO: 
    Erro Interno: 10091
    Erro HTTP: 500
    URL: https://www.testegnre.pe.gov.br/gnreWS/services/GnreResultadoLote
    error:14094412:SSL routines:ssl3_read_bytes:sslv3 alert bad certificate

     

    Capicom

     Certificado Série: "NUMERO DE SÉRIE", não encontrado!

     

    Alguém pode ajudar?

  4. Removi o ACBr, instalei novamente, e rodei o demo.

    Realmente o envio de e-mail não está funcionando, a geração de PDF e impressão via XML funciona 100%.

     

    image.png.071bc902d8a60b19b4ac99d0a8000667.png

     

    Tentei enviar com base em todos esses arquivos.

  5. Juliomar,

    Já tentei utilizar todos os arquivos possíveis dentro da pasta.

    A principio penso ser o correto o que anexei no primeiro post, que é o mesmo que gero o PDF.

    Tem um exemplo de XML ai pra eu testar?

  6. Pelo que vi no código, ele somente adiciona uma guia na procedure AlimentarComponente, e quando chamamos o envio do e-mail, ele não chama essa procedure.

    Mas no caso, deveria apenas enviar o XML selecionado no LoadFromFIle, certo?

     

    image.png.75c8e74fe285ef4020b83cc90a3df2cd.png

    Não está criando a guia nessa linha de carregamento do arquivo.

  7. Boa tarde, Pessoal

    Estou testando o envio de guias por email pelo demo, e estou me deparando com o seguinte erro após selecionar o arquivo xml para envio:

    Argument out of range

    Estou selecionando o mesmo arquivo XML que imprimo o PDF (que está funcionando).

    Alguém pode ajudar por favor?

     

     

    2100128091-pro-rec.xml

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.