Jump to content

MARCOS LIVIO SACUCCI

Membros Pro
  • Posts

    30
  • Joined

  • Last visited

Posts posted by MARCOS LIVIO SACUCCI

  1. Bom dia José Jr....

    Sim, o problema não tem haver com o acbrmonitor, inclusive o problema já fora resolvido e acho importante deixar registrado para que outras pessoas, que por ventura se depare com este erro, tenha um norte. O cliente teve problema na I.E. o que ocasionou o descredenciamento da emissão de nfe no portal do governo do estado de SP. Mesmo o contador resolvendo o problema da I.E. do meu cliente junto a secretaria da fazenda o credenciamento não voltou ao status normal de emissão de nfe. Foi preciso recredenciar. Fica a dica..... e obrigado Jr

    • Like 2
  2. Boa noite...

    Eis que me deparo com um cliente que teve sua I.E. suspensa, porém, todas as consultas feitas após regularização da inscrição constam como IE habilitada, inclusive fiz teste de uma outra empresa emitindo uma nfe para a IE referida a aul obtive suceso! Ocorre que não consigo emitir nfe de forma alguma, já pulei numeração para nova tentativa e o retorno insiste no erro 203-Rejeicao: Emissor nao habilitado para emissao da NF-e. 

    Estou usando ACBRMonitorplus versão 1.3.0.333 antiga, mas tenho outros clientes usando esta mesma versão e funfa.

    Alguma Luz? Desde já agradeço aos colegas.

  3. Bom dia...

    Estou com problema na impressão da DANFE o qual não reconhece caracteres acentuados.

    Já lí inúmeros tópicos que tratam desse assunto, porém nenhum que tenha resolvido meu problema.

    Ocorre apenas na impressão da danfe e quando usado o comando NFE.ImprimirDanfe() do ACBRMonitorPlus versão 1.3.0.306.

    Já, tanto o arquivo PDF, quanto o arquivo XML gravados nas pastas estão coretos,  ambos os arquivos reconhecem os caracteres acentuados perfeitamente!

    Quando eu peço para imprimir a DANFE utilizando a API do Windows funciona!

    Em anexo segue os prints de configuração do ACBRMonitorPlus.

     

    tela2.thumb.jpg.d63485444c64a905fb8d22d83267c9ba.jpgtela1.thumb.jpg.ed4091ae3c631a5a06138c94a6cb1066.jpgtela3.thumb.jpg.78ae6149334c295229ee5a304894b8e7.jpg

     

    Abaixo segue imagem do PDF com a acentuação correta:

    tela5.jpg.992559ec3a2a38b4c4c3752b4c25190b.jpg

    Abaixo segue imagem do XML correto sem a acentuação:

    tela6.jpg.044cadd8373d07748c2e260b304405cb.jpg

     

    Abaixo foto da DANFE impressa pelo comando NFe.imprimirdanfe() com os caracteres especiais desfigurados:

    tela4.thumb.jpeg.32abd3f1eb2a1a9701f851fd005eb49d.jpeg


     

    tela4.jpeg

    tela1.jpg

    tela2.jpg

    tela3.jpg

  4. 1 hora atrás, Daniel Simoes disse:

    Não é possível usar o campo de Informações Adicionais ?

     

    ... é possível sim! Mas se puder concatenar na tag <xNome> vou preferir, pois meus clientes já estão acostumados. Vou pesquisar mais sobre essa possibilidade com relação a legislação, se é permitido ou não.

    Obrigado a todos por hora... 

    • Like 1
  5. Senhores desenvolvedores do ACBRMonitor... 

    Antes de adotarmos o uso ACBRMonitorPlus eu utilizava uma outra ferramenta para gerar e imprimir NFE a qual, no campo NOME DO CLIENTE, na impressão da DANFE, era impresso também o Código interno no ERP do cliente . Havia uma tag extra manual no layout dessa outra ferramenta denominado <xNomeCod> o qual não compõe o XML, era apenas utilizado para popularmos esta tag com o código interno do cliente para posterior impressão na DANFE. Meus clientes se acostumaram com esta informação e está tendo uma grande demanda para que esta informação continue aparecendo.

    Seria possível esta implementação no ACBRMonitor? 

    Obrigado por hora.

  6. Boa noite...

    Alguém conseguiu configurar o provedor BOL para enviou de email de NFe? Já tentei várias configurações e só da erro.

    15/07/2020 19:09:00 - Email: Iniciando processo de envio.
    15/07/2020 19:09:00 - Email: Configurando o cabeçalho do e-mail.
    15/07/2020 19:09:00 - Email: Logando no servidor de e-mail.
    15/07/2020 19:09:01 - Email: Iniciando os envios.
    15/07/2020 19:09:01 - Email: Processando lista de destinatários.
    15/07/2020 19:09:01 - SMTP Error: Unable to send MailTo.
    554 5.7.1 <unknown[191.54.60.231]:50033>: Client host rejected: Access denied

    Estas são as mensagens de retorno depois de clicar no botão <<TESTAR CONFIGURAÇÃO>> do ACBRMonitorPlus.
     

  7. 19 minutos atrás, MARCOS LIVIO SACUCCI disse:

    Preciso saber quais tags preencher quando a venda é SUFRAMA. Queria um exemplo de um XML quando trata-se de uma venda SUFRAMA.

    tenho dúvidas também com relação aos valores calculados nas tags de desconto, se devo colocar o valor do desconto referente à 1 unidade ou se *(vezes) a quantidade da NFE

  8. 14 minutos atrás, Daniel Simoes disse:

    Sim, esse tipo de modificação, é propagada.... Fique atento as notícias do ACBr

    https://www.projetoacbr.com.br/forum/forum/35-notícias-do-acbr/

     

    1 hora atrás, José M. S. Junior disse:

    Marcos, 

    Note pelo log que está conectando em versões diferentes do ACBrMonitor, quando conectou na versão: ACBr MonitorPLUS Ver.1.2.0.80, passou a retornar "chNFe". Quando conectou na ultima versão: ACBr MonitorPLUS Ver.1.3.0.259 - x64 retornou "chDFe"

    Nas últimas versões realmente houve uma padronização de algumas tags que ainda estavam desatualizadas... Todas dever retornar como "chDFe". Infelizmente ocorrerá essa divergência no retorno com versões diferentes, mas não deverá sofrer alterações estando com a versão atualizada do ACBrMonitor.

     

    14 minutos atrás, Daniel Simoes disse:

    Sim, esse tipo de modificação, é propagada.... Fique atento as notícias do ACBr

    https://www.projetoacbr.com.br/forum/forum/35-notícias-do-acbr/

     

    já estou seguindo! Obrigado pela dica....

     

    • Like 1
  9. 4 minutos atrás, mgmobile disse:

    Pessoal, estou tendo o mesmo problema, me desculpem mais vcs não podem mudar assim as variaveis de retorno... quem trabalha com o acbrmonitor via TXT usa essas tags para ler os retornos... hoje um cliente meu estava com problema na MDFE... dai fui ver e o retorno mudou denovo... já foram 3 retornos diferentes que informam a chave da NFE...

    Inicialmente era CHMDFE

    Depois mudou para CHNFE

    Agora está CHAVEDFE
     

    Entendo que vcs querem padronizar mais isso pra quem trabalha com retorno TXT é o caos... para tudo de funcionar... é igual as tags que retornam o arquivo XML... já mudaram de ARQUIVOXML para ARQUIVO...  eu até epnsava que era coisa do estado...

     

    Bom dia.... na dúvida, deixe seu código preparado para receber todos os possíveis retornos. Fiz isso no meu código! Mas se houvesse uma forma de sermos avisados com antecedência dessas trocas, evitaríamos alguns aborrecimentos com alguns clientes que até colocam nossa capacidade e confiabilidade em dúvida. Sistema bom é aquele que o cliente não lembra que existe e estes pormenores o fazem lembrar. E dar explicações em certos casos soam como desculpas, pois é complexo para quem não pertence ao meio ACBr. No mais, senhores, obrigado por existirem, vosso trabalho nos facilita a vida!

     

  10. Boa noite... 

    ACBrMonitorPlus v:1.2.0.80

    Hoje aconteceu isto, conforme demonstrado abaixo, de manhã a tag de retorno do XML com relação a informação da chave de acesso era "chDFe" e à noite esta mesma tag mudou para "chNFe'.  É normal isso? Isso pode ocorrer com outras tags? 

    [NFe13904]   **** EMITIDA 26/02/2020 11:40
    Id=
    XML=<protNFe versao="4.00"><infProt><tpAmb>2</tpAmb><verAplic>SP_NFE_PL009_V4</verAplic><chNFe>35200204410467000160550030000139041420330341</chNFe><dhRecbto>2020-02-26T11:40:48-03:00</dhRecbto><nProt>135200001750541</nProt><digVal>nZ+L3JQUHuHU0Vz5DiSknJGUYcA=</digVal><cStat>100</cStat><xMotivo>Autorizado o uso da NF-e</xMotivo></infProt></protNFe>
    cStat=100
    chDFe=35200204410467000160550030000139041420330341
    dhRecbto=26/02/2020 11:40:48
    digVal=nZ+L3JQUHuHU0Vz5DiSknJGUYcA=
    nProt=135200001750541
    tpAmb=2
    verAplic=SP_NFE_PL009_V4
    xMotivo=Autorizado o uso da NF-e

     

    [NFe13907]   **** EMITIDA 26/02/2020 21:10
    Id=
    XML=<protNFe versao="4.00"><infProt><tpAmb>2</tpAmb><verAplic>SP_NFE_PL009_V4</verAplic><chNFe>35200204410467000160550030000139071762365892</chNFe><dhRecbto>2020-02-26T21:10:52-03:00</dhRecbto><nProt>135200001756051</nProt><digVal>p2rMPH0rtU5pwl/corr1uUq2CN8=</digVal><cStat>100</cStat><xMotivo>Autorizado o uso da NF-e</xMotivo></infProt></protNFe>
    cStat=100
    chNFe=35200204410467000160550030000139071762365892
    dhRecbto=26/02/2020 21:10:52
    digVal=p2rMPH0rtU5pwl/corr1uUq2CN8=
    nProt=135200001756051
    tpAmb=2
    verAplic=SP_NFE_PL009_V4
    xMotivo=Autorizado o uso da NF-e

  11. Olá...

    ACBRMonitorPlus ver 1.3.0.259 64x

    Ocorre que em meu arquivo .ini envio somente as tags
    [Pag001]
    tPag=90
    vPag=0.00

    e o comando NFe.CriarNFe( "") retorna o XML com uma tag a mais "<indPag>0</indPag>", sendo que esta tag refere-se se o pgto foi a vista ou a prazo, sendo que não houve pagamento algum nesta operação.

    -<pag>

    -<detPag>

    <indPag>0</indPag>

    <tPag>99</tPag>

    <vPag>0.00</vPag>

    </detPag>

    </pag>
     

    Consultei o XML de um componente que eu utilizava antigamente para gerar XML de NFe e percebi que é possível validar sem esta tag "indPag' em operações que não haja pagamento.
    -<pag>

    -<detPag>

    <tPag>90</tPag>

    <vPag>0.00</vPag>

    </detPag>

    </pag>

    ...entendo que é apenas um detalhe, porém, talvez, entretanto, entendo também que pode ser um motivo para gerar multa com a alegação de "informação errada no documento fiscal"?

    Obrigado por hora.

  12. Boa noite... 

    Estou tendo outra dificuldade...

    O comando CTe.DistribuicaoDFePorUltNSU("35", "99999999999999", 4000), independentemente do último NSU que eu informar, ele sempre traz o mesmo retorno e com numeração antiga, datada do mes 04/2019 e não sai disso. Estou usando a versão 1.2.0.68 do acbrmonitor.

    LOG.TXT

  13. Em 11/07/2019 at 08:34, José M. S. Junior disse:

    Bom dia Marcos, as tags de retornos são geradas de forma automatizada, realmente pode haver diferenciação de maiúsculas e minúsculas, nos campos e chaves, mas o nome em si é idêntico... o que não deve causar problemas.  O ideal ao realizar a leitura é converter tudo para minusculo por exemplo, se a sua linguagem for case sensitive.

    boa dica!! Obrigado...

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.