Jump to content

jamil

Usuários SAC
  • Content Count

    178
  • Joined

  • Last visited

  • Days Won

    2

jamil last won the day on May 4 2018

jamil had the most liked content!

Community Reputation

48 Excellent

1 Follower

About jamil

  • Rank
    Membro
  • Birthday 08/07/1972

Profile Information

  • Sexo
    Masculino
  • Localização
    Rio de Janeiro / RJ

Recent Profile Visitors

735 profile views
  1. Boa Noite, usando xvfb-run ... o resultado sai conforme (xvfb-run.pdf), na impressora, pdf e html..... (imagino que com a NF-e/NFC-e será a mesma coisa) se não usar xvfb-run consigo fazer uns 2 (dois) boletos conforme em anexo (root_bol3110224802.pdf), na impressora, pdf e html mais depois, apresentanda a seguinte mensagem Gtk-WARNING **; ai para de funcionar. já entendi que em windows está funcionado, como só uso linux, acho que terei que continuar com o meu Bom e Funcional Monitor, agradeço o empenho na tentativa de resolver a questão. xvfb-run.pdf root_bol3110224802.pdf
  2. Boa tarde, @José M. S. Junior o erro estava na formatação do VALOR e da DATA que em linux tem outro formato, não há nenhum erro no componente. obrigado pela atenção....
  3. Boa Tarde, @José M. S. Junior como pode observar no LOG e no resultado em PDF. no meu código foi passado os valores em aspas duplas, porém somente e tão somente o vencimento e o valor não foram acatados pelo componente. veja o arquivo de LOG, que la consta um vencimento e um valor e no PDF gerado consta outro.... obrigado pela ajuda.
  4. Criei um boleto usando LibACBr, porém o vencimento não é o que Eu informo e ela só sai com o valor 0,00 estou enviando o log e o pdf gerando, para me ajudarem onde estou errando. acbrlib.ini ACBrLibBoleto-20191031.log root_bol31-10-2019.pdf
  5. Bom Dia, Fiz as mudanças no meu código para CDECL que não funcionava e agora está funcionando bem, emitindo os boletos SHOW... (com alguns probleminhas fáceis de resolver que é assunto para outro tópico), agradeço a todos pela ajuda, porém a LibNFE continua apresentando a seguinte mensagem Gtk-WARNING **; canot open display: ..... e para de funcionar.... quando tento simplesmente usar NFE_ StatusServico() NFE_ Nome() me retorna o nome , NFE_Versao() me retorna a verão corretamente
  6. realmente, isso me escapou, peço desculpas, vou reescrever o código usando CDECL para linux e testar, já que não uso windows e retorno com o resultado.... mais uma vez obrigado a Equipe ACBr pelo Apoio.
  7. Linux 64 OpenSuse Leap 15.1 me desculpa na ansiedade de resolver logo o problema, entendi que queria que eu verificasse as dependencias DLL que estão na pasta utilizei os exemplos do demo ....
  8. libeay32.dll libexslt.dll libiconv.dll libxml2.dll libxslt.dll msvcr120.dll ssleay32.dll estão na mesma arquitetura.... testei todas elas e retorna a mesma mensagem PE32+ executable (DLL) (GUI) x86-64, for MS Windows
  9. file simm simm: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/l , for GNU/Linux 3.2.0, BuildID[sha1]=a459706fc1b4095ca8dacb103be456e3d776db02, with debug_info, not stripped como pode ver é 64 bit, então estou usando a LIb correta...
  10. Antes de qualquer assunto, obrigado pele apoio da equipe em ajudar. bem, usei o xvfb-run , como usuário e como ROOT, e apresentou falha de segmentação (imagem do núcleo gravada)
  11. Bom Dia @Rafael Dias Obrigado mais não deu certo.... o problema continua......
  12. Boa tarde @Daniel Simoes me desculpa, talves não tenha me explicado bem, minha aplicação roda no Modo Console ( Harbour 64 Linux ) , com o a Plataforma KDE, por isso consigo usar o ACBrMonitor Linux. Porém assim mesmo a Libacbrnfe64.so informa Gtk-WARNING **; canot open display: agradeço outra vez o empenho da equipe em tentar uma solução.
  13. Show, @Daniel Simoes, existe alguma opção para desativa o uso do Servidor X, pois só utilizo a aplicação em Modo Console, fica bem mais rápido e segura a comunicação entre as filias da empresa dos meus colaboradores, com isso não utilizo o Preview de impressão, desde já agradeço a ajuda e a atenção....
  14. Bom Dia @José M. S. Junior Obrigado pela ajuda, agora com isso avancei mais uma etapa e a resposta que a Lib apresenta agora é: Gtk-WARNING **; canot open display: ..... e para de funcionar.... estou executando como ROOT
  15. Bom Dia, desculpa pela demora em responder, porém precisava fazer uns teste antes de postar qualquer coisas. respondendo a pergunta: as Lib's estão com permição de leitura e execução e usei como root, também usei OpenSSl 1.0.x.... !º fiz conforme o @Daniel Simoes orientou e infelizmente não funcionou.... 2º testei no Leap 43 funcionou perfeitamente bem ...... (porém o Leap 43 está descontinuado pela OpenSuse) - ficando ai minha teoria que é preciso uma versão das LIB's geradas em Leap 15 desde já agradeço pelo espaço, onde pude demonstrar meus testes.... mais uma vez parabéns a equipe pelo trabalho espetacular ......
×
×
  • Create New...