Jump to content

logo_acbr_paygo.png

Chegou o TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


botao_saibamais.png

beneficios.png

Curso Dominando o ACBrMonitor
Novo Módulo Soluções de Varejo
Assine o SAC ACBr em qualquer plano e tenha acesso

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

jamil

Usuários SAC
  • Content Count

    359
  • Joined

  • Last visited

  • Days Won

    2

Everything posted by jamil

  1. file libacbrmdfe64.so libacbrmdfe64.so: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, not stripped acho que deva ser esse o problema ela foi compilada para 32-bit e não para 64
  2. Boa tarde, hoje me deparei com um problema ao desenvolver usando a libacbrmdfe64.so erro ao carregar DLL ....
  3. Boa Noite, problema resolvido.... tudo funcionando bem em vários logins
  4. desculpa esqueci de retirar as aspas da UF, agora esta funcionando perfeitamente bem obrigado pela ajuda,
  5. Nao deu Certo ACBrLibNFE-20191227.log
  6. estou usando a classe em harbour
  7. como o disse eu estou passando DistribuicaoDFePorUltNSU("33","00127817000125","0") esse resultado aparece no log
  8. segue..... 20191227150309-dist-dfe.xml 20191227150309-con-dist-dfe.xml
  9. não deu certo.... criei o grupo, sei que isso não é da libacbr e sim do Linux, deve haver mais algum comando que deva ser dado na .so para ela se tornar " multi login "
  10. segue conforme solicitado para avaliação, acho que problema esta na UF, eu passo uma valor ( 33 ) ele montra outro no log.... acbrlib.ini ACBrLibNFE-20191227.log
  11. Bom dia, estou gostando das facilidades que o ACBr vem me proporcionado, obrigado. estou com o seguinte problema e peço a orientação da Equipe em Linux usando a libacbrboleto64.so no meu usuário, ela funciona perfeitamente bem, porém se faço um login com um usuário diferente ai nada mais funciona nesse usuário a lib esta na pasta /usr/lib64 fiz o chmod +x fiz chown root:root uso o leap 15.1 me orientem o que foi que eu esqueci de fazer para que vários usuários (login diferentes) usem o meu sistema com Boleto
  12. Boa Noite, uma funcionalidade que Havia no ACBrMonitorPlus e seria muito útil tanto na libNFe quanto na LIbMDFe NFe.GerarIniNFe Obrigado por poder participar.
  13. jamil

    ANSWERED layout NFCe

    com a atualização da libnfe resolveu ..... obrigado a equipe pela ajuda e resultado rápido
  14. jamil

    ANSWERED layout NFCe

    Bom dia, @Rafael Dias sim isso mesmo, mais desse layout, ok
  15. Bom dia @Rafael Dias estou passando apenas números no CNPJ
  16. Boa noite, estou tentado fazer o download usando a LIb DistribuicaoDFePorUltNSU("33"_,__cpfCnpjEmpresa,alltrim(_DANF)) já tentei com DistribuicaoDFePorUltNSU("RJ"_,__cpfCnpjEmpresa,alltrim(_DANF)) obrigado....
  17. Boa Tarde, tentei usar mais não encontrei seria possível colocar na lib ACBrNFe o layout criado por último da NFC-e em A4 tanto impresso quanto para gerar PDF para enviar por e-mail ele é perfeito na dúvida coloquei o modelo em anexo.... ele existe no ACBrMonitorPlus. desde já obrigado... 33191100127817000125650080000000971000000474-nfe.pdf
  18. Boa Tarde, Gostaria de agradecer a equipe que se envolveu na solução do meu problema..... pois o resultado final foi perfeito.... tudo funcionando perfeitamente bem.... Um Feliz Natal para todos.....
  19. @Daniel Simoes Bom Dia, atualizei meu componente, com a ajuda do amigo Eric.Developer , achei o problema no libacbrboleto64.so junto ao Harbour em Linux, agora está funcionando bem. voltei então para libnfe e apos inúmeros testes observei que o problema ocorre quando informo SSLCryptLib=1... falha no nucleo porem, se deixo ele como SSLCryptLib=0 passa e apresenta um erro dizendo que o certificado esta vencido conforme o log em anexo ... acho que agora já estamos chegando perto de resolver ... obrigado pela paciência e empenho em ajudar.... ACBrLibNFE-20191224.log acbrlib.ini
  20. Obrigado mais uma vez pelo empenho , segue o número da linha que me aparece conforme solicitado na LIbNFe: 9447 estou usando a última atualização desta Lib
  21. Boa Tarde @Daniel Simoes.... Fiz conforme me orientou, e o problema continua ....
  22. Bom Dia, @José M. S. Junior Obrigado pela ajuda, segue conforme solicitado: _usu_:=_pastas+"acbrlib.ini" nfe:=ACBrNFe():New(_usu_, "") nfe:ConfigGravarValor("Principal", "LogPath", (_pastas) ) nfe:ConfigGravarValor("Principal", "LogNivel", "4") // logParanoico /2- normal //if(_inf_==.T.) //preenchimento completo nfe:ConfigGravarValor("NFe", "Visualizar", "0") nfe:ConfigGravarValor("NFe", "FormaEmissao", "0") nfe:ConfigGravarValor("NFe", "SalvarGer", "1") nfe:ConfigGravarValor("NFe", "ExibirErroSchema", "1") nfe:ConfigGravarValor("NFe", "RetirarEspacos", "0") nfe:ConfigGravarValor("NFe", "ValidarDigest", "0") nfe:ConfigGravarValor("NFe", "IdCSC", cad_emp->(alltrim(ep_nfctkn))) nfe:ConfigGravarValor("NFe", "CSC", cad_emp->(alltrim(ep_nfccsc)) ) nfe:ConfigGravarValor("NFe", "VersaoDF", cad_emp->(ep_nfever)) nfe:ConfigGravarValor("NFe", "VersaoQRCode",cad_emp->ep___qrvs) nfe:ConfigGravarValor("NFe", "CamposFatObrigatorios", "1") nfe:ConfigGravarValor("NFe", "TagNT2018005", "3") nfe:ConfigGravarValor("NFe", "Ambiente", if(cad_ecf->im_ambt=="1","0","1")) nfe:ConfigGravarValor("NFe", "SSLType", "5") nfe:ConfigGravarValor("NFe", "PathSalvar", _pastas+"danfe") // analizar novo armazenamento nfe:ConfigGravarValor("NFe", "PathSchemas", "/mnt/simm/config/schemas/NFe") nfe:ConfigGravarValor("NFe", "IniServicos", "/mnt/simm/config/cfg/ACBrNFeServicos.ini") nfe:ConfigGravarValor("NFe", "SalvarArq", "1") nfe:ConfigGravarValor("NFe", "AdicionarLiteral", "1") nfe:ConfigGravarValor("NFe", "SepararPorCNPJ", "0") nfe:ConfigGravarValor("NFe", "SepararPorMes", "1") nfe:ConfigGravarValor("NFe", "SalvarEvento", "1") nfe:ConfigGravarValor("NFe", "SalvarApenasNFeProcessadas", "1") nfe:ConfigGravarValor("NFe", "PathNFe",_pastas+"danfe") nfe:ConfigGravarValor("NFe", "PathInu",_pastas+"inutil") nfe:ConfigGravarValor("NFe", "Download.PathDownload", _pastas+"dfe") nfe:ConfigGravarValor("NFe", "PathEvento", _pastas+"arqs") //nfe:ConfigGravarValor("NFe", "IdCSRT", "") //Define o id do responsável técnico. //nfe:ConfigGravarValor("NFe", "CSRT", "") //Define o CSRT do responsável técnico. nfe:ConfigGravarValor("DFe", "SSLCryptLib", "1") nfe:ConfigGravarValor("DFe", "SSLHttpLib", "3") nfe:ConfigGravarValor("DFe", "SSLXmlSignLib", "4") nfe:ConfigGravarValor("DANFE", "MostraSetup", "0") nfe:ConfigGravarValor("DANFE", "MostraPreview", "0") nfe:ConfigGravarValor("DANFE", "MostraStatus", "0") nfe:ConfigGravarValor("DANFE", "PathPDF",_pastas+"pdf") //" _lgc_:="/mnt/simm/config/logos/empresas/"+alltrim(cad_emp->ep___logo) nfe:ConfigGravarValor("DANFE", "PathLogo", if(cad_emp->ep___sist=="S",_lgc_,"") ) nfe:ConfigGravarValor("DANFE", "MargemInferior", "0.70") nfe:ConfigGravarValor("DANFE", "MargemSuperior", "0.70") nfe:ConfigGravarValor("DANFE", "MargemEsquerda", "0.70") nfe:ConfigGravarValor("DANFE", "MargemDireita", "0.70") nfe:ConfigGravarValor("DANFE", "CasasDecimais.qCom", "2") nfe:ConfigGravarValor("DANFE", "TipoDANFE", "1") nfe:ConfigGravarValor("DANFE", "ExibeInforAdicProduto", "1") nfe:ConfigGravarValor("DANFE", "QuebraLinhaEmDetalhamentos", "1") nfe:ConfigGravarValor("DANFENFe", "FormularioContinuo", "0") nfe:ConfigGravarValor("DANFENFe", "ImprimeValor", "1") nfe:ConfigGravarValor("DANFENFe", "ImprimeDescPorPercentual", "1") nfe:ConfigGravarValor("DANFENFe", "PosCanhoto", "0") nfe:ConfigGravarValor("DANFENFe", "ExibeCampoFatura", "1") nfe:ConfigGravarValor("DANFENFe", "ExibeDadosISSQN", "0") nfe:ConfigGravarValor("DANFENFe", "LarguraCodProd", "60") nfe:ConfigGravarValor("DANFENFe", "ExibeEAN", "0") nfe:ConfigGravarValor("DANFENFe", "Fonte.Nome", "1") nfe:ConfigGravarValor("DANFENFe", "Fonte.Negrito", "0") nfe:ConfigGravarValor("DANFENFe", "Fonte.TamanhoFonteRazaoSocial", "10") nfe:ConfigGravarValor("DANFENFe", "Fonte.TamanhoFonteEndereco", "8") nfe:ConfigGravarValor("DANFENFe", "Fonte.TamanhoFonteDemaisCampos", "8") nfe:ConfigGravarValor("DANFENFCe", "TipoRelatorioBobina", "1") //Define o tipo de impressão da NFCe. nfe:ConfigGravarValor("DANFENFCe", "ImprimeDescAcrescItem", "0") nfe:ConfigGravarValor("DANFENFCe", "ImprimeItens", "0") nfe:ConfigGravarValor("DANFENFCe", "vTroco", "1") nfe:ConfigGravarValor("DANFENFCe", "ImprimeQRCodeLateral", cad_ecf->im_qrlc) nfe:ConfigGravarValor("DANFENFCe", "ImprimeLogoLateral", "1") nfe:ConfigGravarValor("DANFENFCe", "EspacoFinal", "4") // nfe:ConfigGravarValor("DANFENFCe", "TamanhoLogoHeight", "") // nfe:ConfigGravarValor("DANFENFCe", "TamanhoLogoWidth", "") //elseif(_inf_==.F.) nfe:ConfigGravarValor("NFe", "ModeloDF", if(__tip==1,0,1)) nfe:ConfigGravarValor("DANFE", "Impressora", VrfImprFiscal(cad_ecf->im_nfci,1,.F.,val(cad_ecf->im_base)) ) nfe:ConfigGravarValor("DANFE", "CasasDecimais.vUnCom", if(empty(cad_ecf->im_decm),"2",cad_ecf->im_decm) ) nfe:ConfigGravarValor("DANFENFCe", "TipoRelatorioEvento", "1") //0-A4 / 1-Bobina _cmh_:="/mnt/simm/config/certificado/"+alltrim(cad_emp->ep___mode) _snh_:=alltrim(cad_emp->ep___senh) nfe:ConfigGravarValor("DFe", "ArquivoPFX", _cmh_) nfe:ConfigGravarValor("DFe", "Senha", _snh_) nfe:ConfigGravarValor("DFe", "UF", cad_emp->(ep_estado)) _x_:=cad_par->pr_ecftra _x__:=if(_x_=="S","-02:00",if(_x_=="X","","")) nfe:ConfigGravarValor("DFe", "TimeZone.Modo", if(_x__=="","0","2")) nfe:ConfigGravarValor("DFe", "TimeZone.Str", _x__) //endif nfe:ConfigGravar(_usu_) nfe:LimparLista() //ate aqui sem apresentar erros nfe:StatusServico() nfe:=nil o Metodo, StatusServico(), é executado com sucesso, acho que o problema está no retorno que ele tras esse retorno da função deve esta causando conflito com C++ (ou seja, ao invéz de retornar um texto com a mensagem da WEB esta retornado uma tela Gráfica com a mensagem....), me desculpem se não soube me explicar bem, porem foi o que pude observar utilizando alguns Metodo que apresentam a Falha. mais uma vez obrigado pela ajuda. acbrlib.ini ACBrLibNFE-20191123.log 20191123080849-ped-sta.xml
  23. Boa Tarde, Espero está fazendo corretamente: vou relatar as etapas na sequência que usei nessa sequência - inicializei a lib - NFE_ ConfigGravarValor(xxx,yyy) - funcionou perfeitamente, configurei toda a lib sem apresentar nenhum problema -NFE_ LimparLista - funcionou -NFE_ StatusServico() - quando usei esse comado apresentou o problema de falha na segmentação obs: testeis quase todos os métodos da LibNFe e Boleto, e alguns apresentaram falha na segmentação, mais na resposta preferi apresentar um para ver se estou no caminho certo. desde já obrigado a equipe.
×
×
  • Create New...