Jump to content

SUPORTE SIG 2000

Membros Pro
  • Posts

    72
  • Joined

  • Last visited

Posts posted by SUPORTE SIG 2000

  1. 15 horas atrás, José M. S. Junior disse:

    Parece ser algum problema de autenticação mesmo... Os dados estão corretos, conforme disponibilizado no Cadastro de Aplicativo do BB?

    bom dia, 

    sim, segui as instruções de autenticação, dá essa msg aí quando tento autorizar a api no sandbox :

    image.thumb.png.c0632cd506494d4d125837c10c2b9bda.png

    13 horas atrás, Victor H. Gonzales - Panda disse:

    Está utilizando tls1.2 ?

     

     

    sim

  2. boa tarde

    3 horas atrás, José M. S. Junior disse:

    Bom dia,

    Certifique-se de que todos os fontes estão atualizados, e se o tipo cobrança não está sendo alterado em algum momento...
    Chegou a realizar testes com o aplicativo ACBrBoleto Demo?

    boa tarde

    então, pelo demo, deu essa msg ai de autenticação quando clico em registrar online, e onde pude depurar é na chamada desse metodo :

    function TOAuth.GerarToken: Boolean;
    begin

      if ( Token <> '' ) and ( CompareDateTime( Expire, Now ) = 1 ) then                                        //Token ja gerado e ainda válido
        Result := True
      else                                                                                                      //Converte Basic da Autenticação em Base64
        Result := Executar( 'Basic ' + String(EncodeBase64(AnsiString(FClientID + ':' + FClientSecret))) );

    end;

    image.png.b712637a87beab4335c3bdc3e96aab3c.png

     

  3. Bom dia pessoal,

    quando chamo o metodo enviarboleto, apresenta a msg, cai nessa function e diz que método não está implementado, isso acontece tanto com o tipoCobranca : cobBancodoBrasilWS e 

    tipoCobranca : cobBancodoBrasilAPI. Fiz tudo conforme explicado no link https://www.projetoacbr.com.br/forum/topic/62937-boleto-híbrido-acbrboleto-via-api-com-pix/

     

    cai nesse metodo

    function TBoletoWSClass.GerarRemessa: String;
    begin
      Result := '';
      raise EACBrBoletoWSException.Create(ClassName + Format( S_METODO_NAO_IMPLEMENTADO, [C_GERAR_REMESSA] ));
    end;

     

  4. 17 horas atrás, SUPORTE SIG 2000 disse:

    Boa noite a todos.

    Pessoal tentei recepcionar um retorno( .ret anexo) porém apresenta a mensagem abaixo, percebi que o erro aparece no método LerRegistro0 do componente, antes de ler o registro0, o arquivo é passado FArquivoTXT.Text := ArquivoTXT, no LerRegistro0 notei que a StringList FArquivoTXT.Strings[0] não estava preenchida, por isso causando o erro.

    image.png.ecb10a5d387c193c3b631e6a74d76956.png

    SB10051A.RET 2 kB · 0 downloads

    bom dia

    não sei se isto é um  bug, mas só passou a ler o arquivo, depois que passei assim

    ACBrPagFor.LerTXT( sPathRetorno, True );

    estava passando assim ACBrPagFor.LerTXT( sPathRetorno, False );

    Giovani

  5. Boa noite a todos.

    Pessoal tentei recepcionar um retorno( .ret anexo) porém apresenta a mensagem abaixo, percebi que o erro aparece no método LerRegistro0 do componente, antes de ler o registro0, o arquivo é passado FArquivoTXT.Text := ArquivoTXT, no LerRegistro0 notei que a StringList FArquivoTXT.Strings[0] não estava preenchida, por isso causando o erro.

    image.png.ecb10a5d387c193c3b631e6a74d76956.png

    SB10051A.RET

  6. 20 horas atrás, Juliana Tamizou disse:

    Boa tarde.

    Quando tiver retorno do banco, queira por favor nos contar oque foi necessário ajustar...

    Att.

    bom dia

    ao enviar a remessa me reportaram este erro :

    Linha: 5                                                                              

    Posição 009 - Campo: Nº Sequencial Registro no Lote - Número sequencial não confere. (00002)

    Só que esta linha refere-se ao segmento J-52, e que, segundo o manual do banco o contador do sequencial do J52 deve ser o mesmo do J, no arquivo ( anexo) está assim, não sei o motivo desta inconsistência.

    unknown.png

     

    Cpg1050537.seq

  7. Em 07/05/2021 at 10:46, José M. S. Junior disse:

    Aparentemente não tem nada errado nessa posição, precisa ver com o banco do que se trata essa divergência e se qual layout eles estão se baseando.

    Boa tarde.

    Na verdade o arquivo com alguns outros erros nada naquela posição, liguei pro banco.

    obrigado

  8. 15 horas atrás, Italo Giurizzato Junior disse:

    Boa tarde,

    Notei que no seu arquivo de envio a palavra INFORMATICA esta com a vogal acentuada, ou seja, INFORMÁTICA LTDA.

    Experimenta tirar o acento e faça um novo teste.

    Existem outras palavras com vogais acentuadas e cedilha.

    bom dia Italo, 

    vou remover caracteres pra ver se é isto, obrigado

    Giovani Reis

  9. Boa tarde,

    enviei o arquivo remessa a pagar para o banco itau, afim de homologar, e foi retornado esse erro abaixo. Eu realmente não localizei esse erro, uma vez que esta posição 73, em qualquer registro, refere-se a nome.

    alguém já teve este problema? em anexo também o arquivo. Obrigado.

    Caracter inválido na posição 73 do registro 2.

    image.thumb.png.badf88cf6ff081a2c9624cccad294892.png

    Cpg3040422.seq

  10. 17 horas atrás, José M. S. Junior disse:

    Boa tarde,

    O conceito é o mesmo do Boleto, ou seja, após ler o arquivo a classe PagFor será alimentada com todos os dados do arquivo Retorno, então precisa percorrer a estrutura de cada Classe para obter os dados lidos.

    Por exemplo

    dtCredito:= ACBrPagFor1.Arquivos.Items[i].PagFor.Lote.Items[j].Registro1.DataCredito; 

    Bom dia amigo,

    obrigado vou tentar, acredito que vai dar certo.

    Giovani Reis

     

    • Like 1
  11. Italo,

    implementei sim a remessa e retorno pelo cnab 240, vou tentar aqui no retorno do PagFor, só queria uma dica, após chamar o método LERTXT, passando o path do arquivo como parametro, qual seria o próximo passo, eu devo instanciar a classe pagfor após isto ?

    Giovani Reis

  12. Boa tarde,

    quais seriam os passos para leitura do arquivo retorno, além da chamada do método LERTXT? Alguem já implementou e teria como, por gentileza, nos dar um exemplo?

    Obrigado

    Giovani Reis

  13. Em 13/03/2019 at 11:45, Daniel Simoes disse:

    O problema é no site do SEFAZ, que está com eternos problemas de funcionamento...

    Existem vários tópicos sobre isso aqui no fórum....

    Bom dia!

    Após retirar https: e inserir apenas http:, voltou a funcionar a consulta

    bom dia através do protocolo HTTPS não está funcionando, apenas em HTTP:

    • Like 2
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.