Jump to content

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png click.png click.png

IgorBhSoft

Membros
  • Posts

    12
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

IgorBhSoft's Achievements

Rookie

Rookie (2/14)

  • Collaborator Rare
  • Conversation Starter
  • First Post
  • Week One Done
  • One Month Later

Recent Badges

2

Reputation

  1. Pessoal, estava com o seguinte problema: No evento S2220 versão simplificada, eu notei que o campo indicação de resultado (indResult) sempre é mandado como normal quando eu não mando nenhum outro valor, então a tag no xml sempre aparece, e a mesma não é obrigatória, portanto, precisava que a mesma não aparecesse no xml. Para resolver meu problema eu fiz a seguinte alteração ao gerar o xml: if (self.exMedOcup.Aso.Exame.Items[i].indResult = irNormal) or (self.exMedOcup.Aso.Exame.Items[i].indResult = irAlterado) or (self.exMedOcup.Aso.Exame.Items[i].indResult = irEstavel) or (self.exMedOcup.Aso.Exame.Items[i].indResult = irAgravamento) then Gerador.wCampo(tcInt, '', 'indResult', 1, 1, 0, eSIndResultToStr(self.exMedOcup.Aso.Exame.Items[i].indResult)); Assim a tag deixa de aparecer no xml quando a mesma está com um valor diferente. Vocês teriam alguma outra solução?
  2. Pessoal estou com o seguinte problema: Na documentação o campo indResult não é obrigatório, no sistema estamos passando zero quando não queremos que o campo apareça no xml, mas, ainda sim o campo aparece no xml com o valor 1, como devemos fazer par não deixar esse campo aparecer no xml gerado? XML abaixo: <?xml version="1.0" encoding="UTF-8"?><eSocial xmlns="http://www.esocial.gov.br/schema/evt/evtMonit/vS01_00_00"><evtMonit Id="ID1652071770000002021100514461246116"><ideEvento><indRetif>2</indRetif><tpAmb>2</tpAmb><procEmi>2</procEmi><verProc>1.0</verProc></ideEvento><ideEmpregador><tpInsc>1</tpInsc><nrInsc>65207177</nrInsc></ideEmpregador><ideVinculo><cpfTrab>07426212602</cpfTrab><matricula>839</matricula></ideVinculo><exMedOcup><tpExameOcup/><aso><dtAso>2021-09-03</dtAso><resAso>1</resAso><exame><dtExm>2021-09-03</dtExm><procRealizado>295</procRealizado><ordExame>1</ordExame><indResult>1</indResult></exame><medico><nmMed>DRA. RUBIA SOUSA MACEDO</nmMed><nrCRM>86462</nrCRM><ufCRM>MG</ufCRM></medico></aso><respMonit><nmResp>DR. RICARDO AUGUSTO AFONSO RIOS</nmResp><nrCRM>50271</nrCRM><ufCRM>MG</ufCRM></respMonit></exMedOcup></evtMonit></eSocial>
  3. Conseguir resolver meu problema pessoal, obrigado pelas dicas.
  4. No caso do campo cNF eu preciso do código extraído da chave de acesso com a função ExtrairCodigoChaveAcesso?
  5. De fato retorna o cNF, mas a chave de acesso do xml ainda esta diferente, estou esperando uma chave com os dados (dados-numero da nota-1-cNF-1) e me retorna (dados-numero da nota-2-cNF-3), tem como eu conseguir gerar a nota exatamente com a chave de chave de acesso original?
  6. Eu vou utilizar essa função em quais atributos do componente para me retornar o xml correto?
  7. Tentei gerar o xml e estou com problemas no campo Ide.cNF (acredito que seja a chave de acesso), o tipo dele é inteiro no componente, quando tento converter o que está salvo no meu banco de dados dá o erro "is not a valid integer value", dai não consigo gerar um xml com a chave de acesso original.
  8. Pessoal, atualmente estou precisando conseguir o xml de envio do cupom fiscal através da chave de acesso do mesmo. Eu utilizei a função consulta do ACBR e não identifiquei nenhum atributo que pode ter o xml original (o xml que foi enviado para a receita, completo), tem alguma outra forma de conseguir o xml através da consulta?
  9. Bom dia pessoal, o svn do acbr já foi atualizado com a versão simplificada?
  10. Estou usando o código acima, preciso gerar no padrão 1.0.0.
  11. Pessoal estou com o seguinte problema ao tentar enviar o evento S2220 em ambiente de Homologação: 'Houve erro na validação do Lote: 1824 - Element ''{http://www.esocial.gov.br/schema/lote/eventos/envio/v1_1_1}nrInsc'': '''' is not a valid value of the local atomic type.' O campo nrInsc não está vazio, os Schemas também estão atualizados e mesmo assim não consigo sair desse erro, o que pode está faltando para funcionar?
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.