Jump to content

gilbertoximenes

Membros
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

0 Neutral

About gilbertoximenes

  • Rank
    Novato
  1. Italo, antes de tudo, obrigado pela atenção. Para funcionar fiz algumas alterações na ValidaModalLibXML : schema_filename : String;// antes era PChar; Nas várias linhas onde tinha um cast para pchar eu tive que comentar senão dá 'invalid typecast' (D2007): schema_filename := {pchar}(DFeUtil.SeSenao(DFeUtil.EstaVazio(APathSchemas), Parece que assim está validando, pois está apresentando aqueles velhos erros na IE rejeitando ISENTO. Mas acho que é só alterar os schemas. Obrigado mais uma vez.
  2. Colegas, notei que no componente já existe validação do schema modal para quem usa CAPICOM. Como eu posso fazer essa mesma validação com OpenSSL? Grato pela atenção
  3. Chega até a ser vergonhoso alguém como eu, que em nada contribuiu, receber agradecimentos logo de você que fez tanto pelo projeto. Eu e os demais utilizadores é que te devemos eterna gratidão.
  4. Consegui fazer a assinatura funcionar alterando umas poucas linhas do arquivo ACBrCTeUtil.pas: - na linha 72 altere infCTe para infCte - reative as linha 1446 e 1447 Com isso o XML é assinado normalmente. Espero que essas alterações não crie outros problemas posteriormente.
  5. Estou com o mesmo problema do @lrpc. Não consigo assinar com o ACBrCTeOpenSSL. Olhei os fontes e notei que a chamada que faz a assinatura em CTeUtil.sign_file está comentada. Fiz algumas alterações me baseando na NFe mas sempre dá erro na função xmlSecDSigCtxSign() pois sempre retorna -1. Existe alguma dica para que eu possa fazer funcionar com a ACBrCTeOpenSSL? a ACBrCTeCAPICOM não é uma opção viável para mim. Muito grato.
×
×
  • Create New...