Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

consultoria_sticker.png

Conteúdo para desenvolvedores
 ao vivo de terça a quinta!
Saiba mais

dev.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


Saiba mais

beneficios.png

Murilo Hobold

Membros
  • Content Count

    12
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Murilo Hobold

  • Rank
    Novato

Recent Profile Visitors

417 profile views
  1. Bom dia estou com um problema para instalar a versão atual do ACBr de forma "manual" no Delphi 2005. segue imagem do erro em anexo. Já tentei atualizar as DLL e não resolveu. Obs: Quando eu pego uma versão mais antiga do ACBr que tenho na minha máquina, consigo instalar normalmente.
  2. Olá, bom dia, procurei aqui e não encontrei, existe algum emulador para essa impressora de NFC-e?
  3. Certo, o problema é o seguinte, quando gero um cupom, passo o código do produto no VendeItem(12345678901234). na impressora esta saindo o codigo correto com 14 caracteres, mas no TWebBrowser e TMemo, que estão saindo com 13 caracteres(conforme imagem acima).
  4. Pelo que vi.. ele esta lendo com 14 caracteres, mas na tela, quando passo para o componente TWebBrowser, só esta mandando 13. a Programação no componente ficou assim: procedure TFLnCupFis2.ACBrECFBobinaAdicionaLinhas(const Linhas, Operacao: string); begin ACBrECF.MemoLeParams; WB_LoadHTML(wbBobina, mBobina.Text); Application.ProcessMessages; WB_ScrollToBottom(wbBobina); end; sendo que mBobina é um memo e wbBobina o TWebBrowser. Como ficou o Cupom: Log Abaixo:
  5. Olá, estou usando a função abaixo para gerar meu cupom fiscal, cujo parametro cCodigo só aceita 13 caracteres e preciso de 14 caracteres, se eu passo um campo com 14 caracteres ele elimina o ultimo código, ficando assim: Valor original : 12345678901234 Valor cupom : 1234567890123 Estou usando uma impressora da Bematech, modelo MP-4000 TH FI
  6. Não Estava sabendo, obrigado pela informação.
  7. Olá Cleber, não estou sabendo de nada, tens essa informação de onde?
  8. hmm não conferi, vou dar um olhada aqui, mas o engraçado é que ele executa o erro, mas se for la e ignorar o erro, ou seja forçar o valor a passar 1 ao invés de -1, funciona normalmente do jeito que era para funcionar.
  9. o Modelo é MP-4000 TH FI, e atualizei todas as dlls ontem com o svn.
  10. Bom Dia, estou com um Projeto novo de Cupom Fiscal, e estou fazendo a tela de Esp MFD, só que estou com um probleminha, ao gerar o Espelho, retornou o erro -1, neste código abaixo, que fica na unit ACBrECFBematech: procedure TACBrECFBematech.EspelhoMFD_DLL(COOInicial, COOFinal: Integer; NomeArquivo: AnsiString; Documentos: TACBrECFTipoDocumentoSet); Begin . . . Resp := xBematech_FI_EspelhoMFD( NomeArquivo, CooIni, CooFim, 'C', Prop, cChavePublica, cChavePrivada ); . . . end; Estou usando o Delphi 2010, este erro está ocorrendo tanto no meu softwa
×
×
  • Create New...