Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

consultoria_sticker.png

Conteúdo para desenvolvedores
 ao vivo de terça a quinta!
Saiba mais

dev.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


botao.png

beneficios.png

benefreitas

Usuários SAC
  • Content Count

    35
  • Joined

  • Last visited

Community Reputation

13 Good

About benefreitas

  • Rank
    Membro

Profile Information

  • Sexo
    Masculino
  • Location
    Osasco-SP

Recent Profile Visitors

235 profile views
  1. Juliomar, Funcionou perfeitamente desta vez. Eu já havia baixado esse pacote mas por algum motivo não consegui sucesso na instalação. Dessa vez passou fácil. Obrigado mais uma vez.
  2. Obrigado Juliomar, Você me ajudando mais uma vez! Seguirei sua sugestão. Obrigado.
  3. Srs, Instalei o Fortes Report no Delphi 10.3.3 através do GetIt Package Manager. Assim que é instalado funciona direitinho. Porém, depois de fechar o Delphi (ou depois de passados alguns dias) os componentes desaparecem. No GetIt aparece como instalado, mas não aparece nada na paleta de componentes. Se fizer a desinstalação, fechar e reabrir o Delphi e depois reinstalar via GetIt novamente, volta a funcionar. O inconveniente é se eu abrir algum projeto que já use algum componente do pacote Fortes Report, perco tudo e tenho que refazer. Agradeço antecipadamen
  4. Juliomar, Muitíssimo obrigado. Baixei conforme sua orientação. Vou tentar instalar essa versão. Nas versões mais recentes do Delphi a coisa está mais fácil com o GetIt... Abraço!
  5. Olá Juliomar, obrigado por sua atenção. Fui até o endereço que você indicou, porém não consegui achar algo específico para o Delphi 6. Acredito que eu não esteja sabendo como procurar. Não estou familiarizado com buscas no github. Ficarei imensamente grato se você me auxiliar com um pouco mais de detalhe para direcionar minha busca. Obrigado1
  6. Srs, Tenho um aplicativo antigo desenvolvido em Delphi 6. Estou migrando para Delphi Rio, porém minha estação de trabalho onde tenho o Delphi 6 instalado deu problema e estou tendo que reinstalar as ferramentas. Não estou encontrando o pacote de instalação do Fortes Report para Delphi 6. É possível obter com o pessoal que mantém esse excelente componente? Freitas
  7. Agora passou!!! Tudo funcionando. Obrigado pela ajuda Daniel e EMBarbosa. Um dia ainda dominarei esses detalhes e passarei a ajudar vocês voluntariamente...
  8. Olá EMBarbosa, Realmente existe uma divergência no arquivo ACBrSATExtratoFortesFr.pas na linha 340. Como faço para atualizar isso? Lembrando que baixei ontem tudo via SVN. Anexo o arquivo do meu HD. ACBrSATExtratoFortesFr.pas
  9. Daniel, Apaguei a pasta do ACBr, baixei novamente, e rodei o instalador com a opção de remover as instalações anteriores 3 vezes só hoje. Entre uma e outra, reinstalei outros componentes, tipo Fortes Report, por exemplo. Mesmo assim, em nenhuma das vezes a instalação chegou até o final. P.S.-Estou assistindo agora a live de ontem que não pude assistir...
  10. Essa instalação foi feita há pouco. Fiz zerando toda a instalação anterior conforme roteiro do Regys e baixando tudo de novo via SVN. Não sei onde mexer localmente na minha máquina. Você pode dar uma dica?
  11. Olá EMBarbosa, Obrigado pela atenção e ajuda... Arquivo de log anexo. log_Delphi_10.3_Rio_Win32.txt
  12. Daniel, Desculpe, mas não consegui achar o arquivo ACBr.inc que vc referiu. Peguei um post do Regys para desinstalar tudo e começar do zero. Baixei de novo pelo SVN e tentei nova instalação. Continua dando erro. Porém, o erro agora faz referência ao Fortes Report. Meu Delphi é o 10.3.3-Rio. Fiz a desinstalação/reinstalação do Fortes Report pelo Getit Package. Desinstalei o ACBr de novo pelo roteiro do Regys. Tentei nova instalação do zero. Ainda assim recebo erro e não consigo concluir a instalação. Abaixo o final do Log da instalação. Observe que a
  13. Olá Daniel, Tentei a reinstalação dos componentes com a opção de remover as anteriores mas aparece erro também na instalação... Abaixo o trecho final do Log de instalação. Tentei outra instalação a partir de uma nova pasta mas também dá erro. C:\Componentes_Delphi\ACBr\Fontes\ACBrSerial\ACBrDeviceRaw.pas(90) Error: E2003 Undeclared identifier: 'TPrinter' C:\Componentes_Delphi\ACBr\Fontes\ACBrSerial\ACBrDeviceRaw.pas(93) Error: E2003 Undeclared identifier: 'Printer' C:\Componentes_Delphi\ACBr\Fontes\ACBrSerial\ACBrDeviceRaw.pas(94) Error: E2008 Incompatible types C:\Compone
  14. Bom dia Juliomar, Vou fazer uma revisão atentando esse detalhe... VCL ou FMX. Estranho esse problema ter se iniciado após um teste num projeto Firemonkey. Parece ter causado uma mudança de comportamento em relação aos projetos VCL.
  15. Daniel, Atualizei o pacote de componentes há pouco para tirar a dúvida. Abri o Exemplo da pasta C:\Componentes_Delphi\ACBr\Exemplos\ACBrSerial\ACBrPosPrinter\Delphi Não mudei nada e tentei compilar. [dcc32 Error] ACBrDeviceRaw.pas(90): E2003 Undeclared identifier: 'TPrinter' É o mesmo erro que dá na compilação do meu projeto.
×
×
  • Create New...