Jump to content

Rodrigo Guelf

Membros
  • Content Count

    233
  • Joined

  • Last visited

Community Reputation

14 Good

About Rodrigo Guelf

  • Rank
    Membro

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Estou desenvolvendo um sistema para funcionar em um monitor Touch Screen, sendo assim , preciso tomar uma série de cuidados com as telas montadas no sistema, uma vez que a ponta do dedo do usuário é enorme em relação ao ponteiro do mouse. Enfim, tenho uma tela com um DBGrid, quero saber se há possibilidades de aumentar a largura da barra de rolagem?
  2. Daniel não é isso, essa mesma DLL que estou carregando ela emite cupom, depois de alguns cupons ele começa a dar o erro de porta. Isso esta acontecendo em 3 clientes com modelos de SATs diferente, começou em dezembro, antes funciona normal.
  3. Estou com um problema, o meu sistema apos alguns envios de cupons para o SAT, da o erro: Erro na abertura da porta de comunicação com o [email protected], neste mesmo momento se abro outro copia do sistema(deixando a copia com erro em aberto), ele envia o cupom para o SAT normalmente, porem aquela copia do programa que esta aberta não se comunica mais com o SAT. Já fiz os testes usando o componente do ACBrSAT no datamodulo e no formulário de enviou do SAT e criando ele no momento que vou enviar a venda para o SAT, ambos apresentam o mesmo problema. Este problema esta acontecendo com os SATs da Bematech, Elgin e Epson, no windows 7 32 e 64 e no windows 10. O erro acontece no comando :ACBrSAT.EnviarDadosVenda; Basta eu fechar o executável e abrir ele novamente, volta a funcionar, me parece que fica alguma coisa presa no executável, que mesmo criando novamente o componente em tempo de execução ou criando um formulário novo com o componente dentro dele, da o erro na abertura da porta. Alguém tem alguma ideia do que possa ser!
  4. Pessoa, Mudei a alíquota do ICMS para 12% (alíquota de venda do produto) Mudei a alíquota do fundo de combate para 0% Mantive a alíquota de origem 18% Mantive a alíquota Interestadual 12% Assim passou, eu só tenho esse cliente fora do estado de SP, aqui quando o cliente vende para um estado que a alíquota é 7, 12 ou 18 nos respeitamos a alíquota do estada para o qual estamos vendendo, pelo vista do PA para outro estado, deve respeitar a alíquota do PA que é 12% A duvida maior seria o ICMS partilha com essa configurações, não sei se isso esta certo ou não, vou pastar o XML aqui que passou e se alguém souber se esta certo ou errado e puder me apontar, eu agraço. 15190126727742000107550010000009781000009782-nfe.xml
  5. Olá pessoal, estou com um cliente do PA emitindo uma nota fiscal para SP, porem esta dando o erro "693-Rejeicao: Alíquota de ICMS superior a definida para operação interestadual", a mesma rotina esta funcionando normalmente de SP para outros estados. Pesquisei na internet em vários e vários sites sobre qual alíquota seria as interestadual, e os exemplo que vi são: Alíquota de origem 18% Alíquota Interestadual 12% Fundo de combate 2% Seguindo este simulador: https://www.freenfe.com.br/calculadora-online-de-difal Mais usei outros também, e todos o calculo final bate com o meu calculo, porem a nota fiscal não passa. <ICMSUFDest> <vBCUFDest>30.00</vBCUFDest> <pFCPUFDest>2.0000</pFCPUFDest> <pICMSUFDest>18.0000</pICMSUFDest> <pICMSInter>12.00</pICMSInter> <pICMSInterPart>100.0000</pICMSInterPart> <vFCPUFDest>0.60</vFCPUFDest> <vICMSUFDest>1.80</vICMSUFDest> <vICMSUFRemet>0.00</vICMSUFRemet> </ICMSUFDest> Em anexo vou deixar o meu XML, se alguém souber o que estou fazendo de errado, eu agradeço deste já. 15190126727742000107550010000009781000009782-nfe.XML
  6. Olá amigos, estou desenvolvendo uma solução para usar micro terminais com o componente ACBrMTer, porem apos o evento OnRecebeDados ser executado algumas vezes, o cursos volta para o inicio da linha na qual ele esta focado. Mesmo se eu mandar focar na linha e coluna que eu quero, quando o evento onRecebeDados termina, o cursor volta para a coluna 1 da linha que ele esta setado. Alguem sabe como resolver?
  7. Gostaria de agradecer a todos que me ajudaram, conseguir resolver os meus dois problemas, a vocês o meu muito obrigado!
  8. Fernando, estou fazendo assim: vCodigoBarra := FACBrBoleto.Banco.MontarCodigoBarras(FACBrBoleto.ListadeBoletos[0]); CodigoBarraBoleto := FACBrBoleto.Banco.MontarLinhaDigitavel(vCodigoBarra, FACBrBoleto.ListadeBoletos[0]); E fica dando esse erro: E2003 Undeclared identifier: ' ' Certeza que é assim mesmo?
  9. Duas perguntas: 1) Após usar o comando "ACBrBoleto.GerarPDF", como eu faço para capturar o código de barras que foi gerado? 2) Em qual propriedade eu mudo o nome do arquivo PDF? Desde já obrigado a quem responder!
  10. Felipe, já fiz este teste, salvo o XML antes de enviar, enquanto não tiver retorno, mando sempre o mesmo XML, não deixo alterar nada no XML, só se eu tiver um retorno de erro. Porem ao enviar o XML, da erro que a I.M não esta vinculada no CNPJ informado, já debuguei e a I.M, esta informada corretamento no XML.
  11. Amigos, estou tendo problemas com notas fiscais duplicatas no provedor Ginfes, quando o cliente clica para enviar a nota fiscal, as vezes a conexão esta lenta e volta o seguinte erro: Ocorreu o seguinte erro: erro interno: 12002 erro http: 0 url: https://producao.ginfes.com.br/serviceginfesimpl erro: requisição não enviada. erro: 12002 - timeout de requisição Então, neste momento o provedor recebeu esta NFSe e autorizou, porem eu não recebi nada de volta, então o meu cliente manda enviar novamente a nota, ai o provedor recebe e autoriza outra NFSe. Como eu faço para não dar este problema de duplicidade, pois resolver a lentidão do cliente é impossível. Agradeço a quem me ajudar!
  12. Sim, eu tenho o Dephi 2010, que esta tudo funcionando, JEDI e ACBr, e agora estou instalando o Dephi Tokyo, estou com duas pastas do ACBr, uma para o Dephi 2010 e outra para o Tokyo, o que eu devo fazer para resolver isso?
  13. Pessoal, boa tarde! Estou com um problema no delphi Tokyo 10.2.2, quando instalo o JEDI da erro no ACBr, não da erro nenhum na instalação do JEDI, mesmo a manual ou pelo GitIt. Porem quando fecho o delphi e vou abrir ele novamente vem esta janela de erro: Quando abro o meu projeto da erro em todos os componentes do ACBr. Então eu reinstalo o ACBr e para de funcionar o JEDI, estou nesta vida já faz 4 dias hoje
×
×
  • Create New...