Jump to content

AlexSilva

Usuários SAC
  • Content Count

    58
  • Joined

  • Last visited

Community Reputation

7 Neutral

About AlexSilva

  • Rank
    Membro

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Caro Ítalo, só para esclarecer, a outra postagem eu tinha feito anteriormente... Acontece que eu estava com o SAC expirado e me confundi. Então renovei e esqueci de fechar o outro post. Peço desculpas por qualquer inconveniente, mas as vezes a correria nos deixa meio 'aluados'. Grato novamente Alex
  2. Caro Ítalo! teria como você me informar que dia sai a atualização semanal para que eu possa dar uma previsão para nosso cliente? Pelo que ele disse, que a contabilidade orientou, ele tinha um prazo final ainda essa semana... Assim ao menos poderei informá-lo sobre um prazo concreto. Grato Alex
  3. Bom dia Ítalo! desculpe-me a demora para responder, mas estávamos aguardando nosso cliente. Você acertou na mosca em relação ao problema da geração. Porém ao usar: [infCteSub] chCte= 31190604002794000183570010000002591000005218 refNFe= 17190525086034000171550020000175491184232405 indAlteraToma = 1 notamos que a tag indAlteraToma não foi gerada. Ao tentar o envio para a SEFAZ recebemos a seguinte rejeição: XMotivo=Rejeicao: O CNPJ do tomador do CT-e substituto deve ser igual ao informado no CT-esubstituido Como devemos proceder? Grato, Alex
  4. Caros tenho um cliente de MG, que gerou um Cte com tomador errado. Este ao perceber o erro, gerou uma NFe anulando o serviço e orientou ao meu cliente para gerar um CTe substituto. Como o manual do AcbrMonitor parece estar com os exemplos desatualizados ou com omissão de algumas tags/valores, pesquisei bastante aquí no forum a forma correta de fazer isso, mas apenas achei tópicos referentes ao controle AcbrCte. Na maioria das vezes os nomes dos comandos são consistentes, e assim tentei arriscar usando os mesmos comandos usados no controle, mas seja por divergência na palavra-chave ou erro da minha parte o xml gerado não gera refNFe; ele aplica refCTe em branco no lugar, o que gera o erro de validação: erro: 1824 - Element '{http://www.portalfiscal.inf.br/cte}refCte': '' is not a valid value of the atomic type '{http://www.portalfiscal.inf.br/cte}TChNFe'. a parte do txt referente à substituição eu estou fazendo da seguinte forma: [infCteSub] chCte= 31190604002794000183570010000002591000005218 [tomaICMS] refNFe= 17190525086034000171550020000175491184232405 indAlteraToma= 1 O xml gerado segue em anexo. Aguardo ajuda pois meu cliente tem urgência. Agradeço desde já a boa vontade e atenção! Alex 31190604002794000183570010000002591000005218-cte.xml
  5. Caros colegas, tenho um cliente de MG, que gerou um Cte com tomador errado. Este ao perceber o erro, gerou uma NFe anulando o serviço e orientou ao meu cliente para gerar um CTe substituto. Como o manual do AcbrMonitor parece estar com os exemplos desatualizados e com omissão dos possiveis comandos para esse caso, pesquisamos bastante aquí no forum a forma correta de fazer isso, mas apenas achei tópicos referentes ao controle AcbrCte. Na maioria das vezes os nomes dos comandos são consistentes, e assim tentei arriscar usando os mesmos comandos usados no controle, mas seja por divergência na palavra-chave ou erro da minha parte o xml gerado não apresenta as tags de sustituição e, provavelmente por esse motivo, retorna o erro: 1824 - Element '{http://www.portalfiscal.inf.br/cte}refCte': '' is not a valid value of the atomic type '{http://www.portalfiscal.inf.br/cte}TChNFe'. a parte do txt referente à substituição eu estou fazendo da seguinte forma: [infCteSub] chCte= 31190604002794000183570010000002591000005218 [tomaICMS] refNFe= 17190525086034000171550020000175491184232405 indAlteraToma= 1 e o xml resultante está em anexo. Agradeço qualquer ajuda desde já. Alex 31190604002794000183570010000002591000005218-cte.xml
  6. Boa tarde José Junior! Procedemos como você nos indicou e a situação do MDFe foi resolvida. Usando a mesma comparação que você fez, encontramos uma pequena divergencia na geração do NFe. Estamos realizando testes finais mas parece que foi resolvido também. Agradecemos muito sua assistência e paciência conosco. Apenas por curiosidade, nos enganou bastante o tipo de mensagem de erro devido ao problema no campo RNTRC (Rejeição assinatura difere do calculado). E ainda pior que, em algumas circunstâncias era aprovado (CriarEnviar - mesmo sem ter corrigido o campo é aprovado) e versões anteriores. Ficaremos mais atentos na busca de problemas no futuro. Muito obrigado!!
  7. Feita a correcao do campo indicado, e novo teste. Segue a mesma rejeicao - log anexado abaixo LOG - correcao RNTRC - Rejeicao.txt
  8. Prezado José Junior, vou fazer como indicado. Irei realizar a correção deste campo e procederei com os testes. Todavia gostaria de apontar que estamos testando com o MDFe para simplificar, porém a mesma rejeição acontece com a NFe. Imagino que uma vez descoberto o problema o que passou a gerar rejeição no MDFe, a correção será similar para NFe. Lembrando: com NFe: Se rodo nosso sistema com o monitor versão 1.1.0.55 - aprova Se rodo nosso sistema com o monitor versão 1.2.0.11 - aprova Se rodo nosso sistema com o monitor versão 1.2.0.16 - não aprova Grato mais uma vez.
  9. Em complemento ao post anterior, gostaria de apontar o seguinte: a) Como aprova com versões anteriores, certamente teve aguma alteracao no monitor b) como você mesmo comprovou, não existe manipulação do arquivo da nossa parte (eles são identicos) c) Embora o método 'CriarEnviar' tenha funcionado e pode ser usado, nunca antes usamos o metodo MDFe.CriarEnviarMDFe (mesma coisa com NFe) pois os clientes mostraram preferir mais controle nos estágios. Portanto gostaríamos de resolver o problema usando os métodos separados para evitar impacto na forma como os clientes interagem com nosso sistema, até porque muitas funcionalidades ficariam perdidas caso fossemos obrigados a abandonar esses métodos. d) Agradecemos sua indicação referente ao campo RNTRC , e vamos acertar de acordo, mas certamente não é isso que está implicando problema, visto que aprova tanto na versão anterior, quanto usando o 'CriarEnviar'. Agradecemos e contamos com sua ajuda para resolver esse problema.
  10. Boa tarde José Junior! Segue os arquivos solicitados: 1 - LOG-Aprovado.TXT - com o método = MDFe.CriarEnviarMDFe(.ini) - Com este método foi Aprovado. 2 - LOG-Não_Aprovado.TXT - Feito como sempre foi feito pelo nosso sistema. Usando separadamente: Gerar, validar e Assinar e depois Enviar. 10/09/2018 12:34:33 - OK: C:\Program Files\VSEmissFiscal_Sys\vsnfe\entr_sai\31180965235434000116580010000000801000000805-mdfe.xml 10/09/2018 12:34:40 - MDFE.ImprimirDAMDFE( "C:\Program Files\VSEmissFiscal_Sys\vsnfe\entr_sai\NFe\31180965235434000116580010000000801000000805-mdfe.xml" , , , ,1) 10/09/2018 12:34:43 - OK: DAMDFe Impresso com sucesso 10/09/2018 12:34:49 - MDFE.EnviarMDFE( "C:\Program Files\VSEmissFiscal_Sys\vsnfe\entr_sai\MDFe\31180965235434000116580010000000801000000805-mdfe.xml",80, 1 ) LOG-Aprovado.TXT LOG-Não_Aprovado.TXT
  11. adendo ao post anterior: só por via das dúvidas acabei de testar sem passar argumento nenhum de assinatura, e não alterou nada. Persiste a mesma rejeicao. Segue o log em anexo. log - teste sem argumento de assinatura.txt
  12. Boa noite José Junior! Acabei de fazer o teste forçando 0 no argumento da assinatura. Nada feito: continua o mesmo erro. Acabei não testando omitir o argumento, mas pela lógica (e pelas instrucoes dos Helps) passar 0 ali no argumento seria ate mais indicado. De qualquer forma, ainda testarei por via das dúvidas. Segue anexo o log completo. Muito obrigado pela atenção e paciência. Contamos com sua ajuda porque a semana toda dando erro, estamos apertados com os clientes no nosso pé (e com razão). Bom feriado e fim de semana! Log do teste forcando argumento 0 (assinatura).txt
  13. Boa tarde José Junior! Segue em anexo o log completo: Geração, Envio e retorno. Att, LOG.TXTLOG.TXT
  14. Bom dia José Junior! Segue os arquivos solicitados: Versão usada 1.2.0.16 1 - LOG.TXT 2 - 31180965235434000116580010000000791000000790-mdfe(Pasta_log).xml Apenas para maiores esclarecimentos: - Quando dizemos enviar pelo sistema - MDFE.ENVIARMDFE("caminho_do_xml",1) estamos querendo dizer que usamos o sistema pra mandar o comando pro monitor- NÃO APROVA. - E quando dizemos enviar direto pelo monitor, é usando o monitor em testes (enviar XML MDFe) e apontando o arquivo xml - APROVA. - Como dito em posts anteriores: com a versão 1.1.0.55 foi aprovado fazendo o envio pelo nosso sistema - SEM PROBLEMAS LOG.TXT 31180965235434000116580010000000791000000790-mdfe(Pasta_log).xml
×
×
  • Create New...