Jump to content

Curso Dominando o ACBrMonitor
Novo Módulo Soluções de Varejo
Assine o SAC ACBr em qualquer plano e tenha acesso

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Daniel De Paula Romanini

Membros
  • Content Count

    67
  • Joined

  • Last visited

Everything posted by Daniel De Paula Romanini

  1. sim tentei compilar mas dava erro mas acho que era por causa do patch não tinha colocado no delphi rio mas agora que vc falou vou testar novamente pensei que nao iria funcionar se der certo dou um retorno muito obrigado pela ajuda.
  2. usamos esse aqui https://github.com/fabriciocolombo/delphi-rest-client-api
  3. Bom dia estou fazendo uma migração de um erp e tenho uma tela onde usa rest client api no delphi 7 e precisava que migrasse para o delphi rio, alguem já passou por essa situação? Como faria para poder mudar o código para funcionar o restclient na versão do delphi rio, tem alguma diga muito obrigado. segue um exemplo: ret := TRetornoCotacaoItem( RestClient.Resource('https://api.intelipost.com.br/api/v1/quote_by_product') .Accept(RestUtils.MediaType_Json) .Header('api_key', Api_key) .Header('platform', '1') .ContentType(RestUtils.MediaType_Json) .Post(Cotacao, Ret.ClassType, Retorno, vJson));
  4. então o clear funciona o problema que tenho muitas tabelas assim e aqui no sistema tenho um componente que herda do ClientDataset so precisava sobreescrever o metodo certo antes de gravar para todos os clientdataset do sistema mas nao achei ainda o metodo que da certo
  5. Olá boa tarde utilizando dbexpress e migrando do delphi7 para o delphi Rio onde tenho o campo "Operator" que é chave estrangeira que aceita valor nulo no delphi 7 quando salva no banco de dados salva nulo já no delphi rio ele salva vazio .. o problema que isso se repete em todo o aplicativo .. teria alguma maneira de ser configurado para ter o mesmo comportamento que no delphi 7?
  6. Olá boa tarde estou tentando compilar o fonte do reinf aqui da empresa e como foi feito na versão mais antiga do acbr ao atualizar a versao do acbr nao esta contrando essa propriedade IdeEvento.TpAmb, qual seria a nova propriedade para setar o tipo do ambiente Obrigado.
  7. Obrigado a todos pela dica consegui aqui o que precisava usando o ConsultaCadastro.
  8. Ola bom dia gostaria de saber se tem algum componente do Acbr que seja possível consultar a inscrição estadual e retorne a situação dessa inscrição estadual. Obrigado
  9. Ola bom dia essa unit de consulta do integra esta funcionando, onde que consigo a ultima versão dela Obrigado.
  10. Boa tarde setei essa propriedade do componente Configuracoes.WebServices.AguardarConsultaRet e resolveu o problema do retorno Obrigado.
  11. Bom dia vou ver aqui no meu sistema de colocar um tempo para pegar o retorno obrigado.
  12. Italo boa tarde fazendo vários teste em algumas vezes deu um erro e a mensagem fica em branco e da um erro de valor numérico invalido quando o sistema aqui tenta gravar no banco o id_guia que vem do retorno. Isso acontece as vezes, e quando envia a 2 ou 3 vezes dai não da erro e o sistema consegue gravar o id da guia. Será que o retorno da receita demora algum tempo pra retornar o xml ?
  13. Ítalo deu tudo certo agora obrigado pela atenção e ajuda .
  14. Italo bom dia fiz os testes aqui deu certo tanto o envio como o retorno porem fazendo uma outra usando uma receita que exige periodo de referencia ao informar que é mensal o valor do campo é 0 no xml não gera a tag dando a mensagem de processado com pendencias. Estou anexando o xml de envio e de retorno. Obrigado 1900635606-pro-rec.xml 4025-gnre.xml
  15. Boa tarde segue os arquivos em anexo obrigado. 1900630225-pro-rec.xml 4024-gnre.xml
  16. Outro detalhe o retorno teve mudanças tb no layout pq nao ta conseguindo pegar o status da guia .
  17. Olá boa tarde precisei fazer 2 mudanças para emitir a gnre na unit pgnreGNRE.pas coloquei Fc04_docOrigem := '0'; e na unit pgnreGNREW.pas if GNRE.c06_valorPrincipal > 0 then Gerador.wCampo(tcDe2, '', 'valorGNRE ', 01, 15, 1, GNRE.c06_valorPrincipal, ''); if GNRE.c10_valorTotal > 0 then Gerador.wCampo(tcDe2, '', 'valorGNRE ', 01, 15, 1, GNRE.c10_valorTotal, ''); Pois como estava informando o valor no campo do valor principal no xml o valor da gnre ficava 0. Mandei as units alteradas. testado com as alterações deu certo a emissão. Obrigado. pgnreGNRE.pas pgnreGNREW.pas
  18. Bom dia Italo vou atualizar e fazer novos testes e mando um retorno muito Obrigado.
  19. Boa tarde segue e versão nova do manual. Manual de Integração_Contribuintes_GNRE_v2.01.pdf
×
×
  • Create New...