Jump to content

logo_acbr_paygo.png

Chegou o TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


botao_saibamais.png

beneficios.png

Curso Dominando o ACBrMonitor
Novo Módulo Soluções de Varejo
Assine o SAC ACBr em qualquer plano e tenha acesso

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

ruikoga

Membros
  • Content Count

    26
  • Joined

  • Last visited

Everything posted by ruikoga

  1. Bom dia Daniel Sim, eu alterei a path no ACBR, conforme disse: C:\SISTEMA\XMLS\ Mas quando fiz a venda o ACBR criou a pasta assim: C:\SISTEMA\XMLS\vendas\202001 ele criou a pasta \vendas antes do ano + mes eu gostaria que ficasse assim : C:\SISTEMA\XMLS\202001, é possivel ou não
  2. Boa Tarde Gostaria de saber se o ACBR deixa mudar o nome da pasta \VENDAS, na venda pelo SAT Eu uso assim: C:\acbrmonitorplus\vendas\202001 --> janeiro de 2020 gostaria de saber se posso mudar para C:\SISTEMA\XMLS\202001 ---> sem a pasta VENDAS, ou a pasta Vendas e Enviados, são os nomes das pastas, fixas, dentro do fonte do ACBR ?? PS... Na Nota eletronica (NFe), eu consigo manipular os nomes das pastas que eu quizer. Obrigado sem alguem puder ajudar
  3. Bom dia Juliomar, Ele não retorna erro, ele reimprime o ultimo cupom que esta carregado em memoria. Se eu encerrar o ACBR, e inicializar ele novamente, aí sim ele me retorna o erro que não tem nenhum CFE carregado na memoria. O que eu vejo, é que, se já tiver sido impresso algum cupom, e quando envio a reimpressão de outro cupom que não existe o xml, ele acaba reimprimindo o ultimo que esta carregado em memoria. Como faço para carregar um CFE toda vez que faço a reimpressão.
  4. Oi Juliomar, Não utilizo os fontes do acbr, uso o acbr compilado, utilizo na troca de arquivos txt. (ent.txt, sai.txt)
  5. Bom dia, Estou com um problema na reimpressão do extrato do SAT. Quando não existe o xml, ele pega sempre a ultima venda. Se encerro o ACBR, e inicializo ele de novo, me retorna a mensagem que nenhum CFE esta carregado na memoria. Como faço no comando SAT.ImprimirExtratoVenda(caminho,xml) para quando não encontrar o xml, me retornar erro. Ou então como faço para carregar o CFe em memoria. Grato.
  6. Boa Tarde, RESOLVIDO Obrigado Jairo, resolvido o problema. Tinha 2 inconsistências na geração do xml. 1o. Estava colocando "N" na TAG <indRatISSQN>N</indRatISSQN> 2o. Estava colocando a TAG <DescAcrEntr> <vDescSubtot>0.00</vDescSubtot> </DescAcrEntr> por isso dava a mensagem de erro. Agora mesmo com estas 2 inconsistências os SATs da TANCA, ELGIN E DIMEP, não dão o erro que o da BEMATECH ACUSOU. Por isso não estava encontrando o problema. Como o Jairo disse, que o valor não poderia ser zeros, fui no manual, e vi esta inconsistência, e o problema foi resolvido. Obrigado pela ajuda Jairo e Sérgio. Abraços
  7. Bom dia Sérgio Não é sobre o T - truncamento ou A- arredondamento Fiz este teste mudando para arredondamento, e continua com o mesmo problema, segue em anexo. Será que não pode ser onde fica a DLL da bematech (BEMASAT32.DLL) ou o BEMASAT.XML ??? Também testei isso em vários lugares. Coloquei na pasta Windows\system32, na pasta do Acbrmonitorplus, na pasta onde estão os programas executáveis e numa pasta chamada C:\SAT, sempre somente com 1 arquivo destes na CPU, nunca tendo em dois lugares. Tive esta cautela, pois já tinha observado em outros posts, falando sobre isso. Não sei como resolver. Pego a mesma aplicação e funciona normal nos sats, tanca, elgin, dimep. ACBrSAT.log AD20170812093745-214518-env.xml LOG.TXT
  8. Bom dia Sérgio, Desculpe, anexei os arquivos errados. de tanto teste que acabei fazendo, escolhi os arquivos da pasta errada Segue agora o correto AD20170811080909-372819-env.xmlLOG.TXTACBrSAT.log enviando de novo ACBrSAT.log AD20170811080909-372819-env.xml LOG.TXT
  9. Boa Tarde. Estou utilizando o monitor (acbrmonitorplus) com o SAT RB-2000, da bematech. Consigo Inicializar, Ativar, e consultar o Status operacional, tudo pelo meu aplicativo. Até aí tudo bem, mas quando faço uma venda (em modo produção), ele me retorna este erro. Esta mesma venda, efetuo em modo produção, nos SATs, da tanca, elgin, dimep, e não ocorre nenhum erro. Verifiquei o arquivo xml que gero, mas não encontrei o problema. Segue em anexo os logs, do ACBRSAT, e o LOG.TXT do monitor e tambem o xml que gerei a venda. Por favor veja se tem alguma coisa que muda para o SAT da Bematech. Fiz o contato no suporte hoje, e me deram uma nova DLL, mas mesmo assim continua com o mesmo erro. ACBrSAT.log AD20170810154709-872634-env.xml LOG.TXT
  10. resolvido parcialmente, fiz como falaram acima (siscon), e funcionou, mas acho que a versão compilada esta com este BUG, pois no manual diz que só se preenche o RNTRC, quando é feito por transportadora. segue o ENT.TXT e o xml gerado pelo acbr, em anexo com a mudança. gostaria que o pessoal do suporte analisasse se esta com este BUG mesmo. Obrigado ENT.TXT 35170700470952000179580010000000011000000010-mdfe.xml
  11. juliomar, eu não uso delphi, uso a versao compilada do acbr, que esta disponivel no site, por isso não consigo mudar. teria alguma versão que já esta com este problema corrigido fico no aguardo obrigado
  12. tenho um post com este problema, e tambem não consigo validar o TXT, que dá o mesmo erro. se o erro esta na compilacao do abrmonitorplus, gostariamos que o pessoal do suporte, esclarecessem, se é isso mesmo.
  13. bom dia juliomar, mas o RNTRC, é para quem faz o frete, este MDFe, é entrega propria com o veiculo da empresa. ele não tem o cadastro na ANTT, para exercer a atividade de transportador. não deve ser isso o erro. ainda não consegui validar o MDFe
  14. oi italo, como tinha dito para o juliomar, fiz de todos os tipos, veja a ultima que fiz. postei o ent.txt, com o mesmo erro. ENT.TXT
  15. oi juliomar, já fiz sem os espaços, tudo grudado, e continua com o mesmo erro. este ENT.TXT que enviei foi a ultima tentativa que fiz. continua com o mesmo erro
  16. estou iniciando no MDFe, e gerei um arquivo .ini do acbrmonitorplus, e me retorna com erro de placa invalida. estou usando a versao 1.0.0.16 ENT.txt
  17. Bom Dia, Crio o campo CEST, no arquivo txt da SEFAZ-SP, mas o acbrmonitorplus, não cria a TAG do CEST. Alguem tem alguma solução ???
  18. BOA TARDE Gostaria de saber onde encontro a documentação completa dos comandos para o SAT, igual ao ACBRNFEMONITOR, para quem usa enviar as trocas de arquivos TXT. Rui Koga
  19. Desculpe, esqueci de dizer que as datas são no mesmo dia mes e ano.
  20. Estou usando AcbrNfeMonitor, e esta dando este erro quando crio o XML, achei o problema, coloquei 2 datas de vencimento nas duplicatas. Não repetindo estas datas, não acontece o erro, será que o AcbrNfe, não esta verificando isso ? Este erro é do DELPHI. Fico no aguardo de uma solução.
  21. Bom dia, estou usando a versao 0.8.1a, e esta gravando a hora errada, tanto na emissao da NFe, como nos testes de carta de correcao, esta gravando 1 hora a menos (horario de verao). Quando tentei cancelar a nota deu o erro: A dado evento nao pode ser maior que a data do processamento Alterei a hora, para menos 1 hora, e funcionou, como fica esta correção do ACBR, alguem tem ela disponivel ? A que baixei em todos os topicos não dá certo, uso o ACBR somente o executavel CAPICOM Fico no aguardo de uma ajuda.
  22. Bom dia, estou usando a versao 0.8.1a, e esta gravando a hora errada, tanto na emissao da NFe, como nos testes de carta de correcao, esta gravando 1 hora a menos (horario de verao). Quando tentei cancelar a nota deu o erro: A dado evento nao pode ser maior que a data do processamento Alterei a hora, para menos 1 hora, e funcionou, como fica esta correção do ACBR, alguem tem ela disponivel ? A que baixei em todos os topicos não dá certo, uso o ACBR somente o executavel CAPICOM Fico no aguardo de uma ajuda.
  23. kiko e regys utilizo windows XP, o log.txt que mostrei, é a nota fiscal No. 7091, onde crio ela como NFE0007091.TXT peguei o XML da nota numero 7090 para mostrar que o ACBR imprime a DANFE, mostrando que esta funcionando normalmente. Fiz via programa, a chamada de algumas rotinas, exemplo: verificar se o SEFAZ esta em operacao, se o ACBR esta ativo, tudo criando arquivo TXT (ENTNFE.TXT) para estes comandos, e tudo funciona. Somente quando peço para criar o arquivo Nfe.CriarEnviarNfeSefaz que ele diz que não encontra o arquivo NFE0007091.TXT, já até coloquei na mesma pasta, para ver se era o problema, mas não funciona. Tenho em outros clientes o ACBR instalado e funcionando normalmente, e a configuracao é identica em todos eles, já até formatei a CPU do meu cliente para ver se não era algum erro de windows, cpu, etc....
  24. Caro Kiko Fernandes no exemplo que coloquei, esta sem a path, porque o arquivo TXT esta junto na mesma pasta, mas já coloquei com a path igual ao modelo da impressao da DANFE, que voce pode notar no log. que coloquei Simplesmesnte neste teste tirei para ver se era problema de caminho(path), mas não. Tenho em outros clientes instalados e somente neste cliente que nao funciona.
×
×
  • Create New...