Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

clube mobile


Cursos grátis para toda base ACBr
+ Promoção Clube Mobile para o ACBr Pro

Saiba mais

adriano santos

click.png

click.png

click.png

click.png

click.png

click.png

alexpseletr

Membros
  • Content Count

    36
  • Joined

  • Last visited

Community Reputation

1 Neutral

About alexpseletr

  • Rank
    Membro

Profile Information

  • Sexo
    Masculino
  • Location
    casa

Recent Profile Visitors

724 profile views
  1. ja existe alguma solução para assinar com certificado A3 no linux ?
  2. uma ultima duvida... para inutilizar o xml esta validando porem quando envio pra https://nfe-homologacao.svrs.rs.gov.br/ws/recepcaoevento/recepcaoevento4.asmx?WSDL ele retorna erro 225 Falha no Schema XML do lote de NFe , os demais eventos funcionaram 100% obs: no xml onde esta escrito cnpj eu coloquei para enviar ao grupo , aqui esta o numero certo... desde ja agradeço inutilizacao-assinado.xml inutilizacao-soap.xml
  3. ok muito obrigado pelas repostas ... entao para baixar o xml seria esse procedimento enviado para o NFeAutorizacao ?
  4. Estou ajudando um amigo com uma implementação em C e ficamos em duvida sobre a função das URLs do webservice Se puderem ajudar , estou verificando nos fontes mas como é muito grande a implementação que ja fizeram vai levar um tempo dai ja adiantava o meu lado ...a duvida é somente na função para a NFe4.00 (por exemplo nao achei a NFeDownload que tem no manual) NfeInutilizacao 4.00 https://nfe-homologacao.svrs.rs.gov.br/ws/nfeinutilizacao/nfeinutilizacao4.asmx é aqui que eu inutilizo de uma ou uma sequencia de NFe ? NfeConsultaProtocolo 4.00 https://nfe-homolog
  5. ok , vou ver o que da pra fazer aqui (nao uso windows) , futuramente voces buscarão tornar compativel ?
  6. foi passado nas respostas anteriores do tópico , foi só clicar no botao de ver a validade apresentou o erro , ao clicar no status do servviço seja antes ou depois de verificar a data acontece o mesmo erro , se eu mandar assinar a nota pelo meu sistema , mesmo erro (no caso do meu sistema sem alterações nos fontes o erro começou com a atualização do openssl... as informações de debug e telas foram citadas nas respostas anteriores
  7. nao sei dizer ao certo fiz a atualização do sistema final de ano e o problema apareceu sei que na 0.98 funcionava , nao lembro se no openssl 1.0 se cheguei a usar...
  8. baixei novamente pelo svn , nao teve diferença , poderia informar a versao do openssl que voce usa(OpenSSL 1.1.0g 2 Nov 2017) ? ou um caminho para que eu possa seguir aqui ? é que aparentemente o problema começou com a nova versao , pelo que andei lendo mudou bastante em relação as anteriores , nao sei se influenciou no componente
  9. fiz o debug pelo gdb acho que mostrou um pouco mais , nao sei se ajuda para verificação da data de vencimento (gdb) run Starting program: /home/alex/acbr/nfe3/ACBrNFE_Demo [Thread debugging using libthread_db enabled] Using host libthread_db library "/usr/lib/libthread_db.so.1". Program received signal SIGSEGV, Segmentation fault. 0x0000000000a49c66 in GETNOTAFTER (CERT=0x1773800) at ./componentes/acbr/trunk2/ACBrTrunk2/Fontes/ACBrDFe/ACBrDFeOpenSSL.pas:142 142 Validade := {$IFDEF DELPHIXE4_UP}AnsiStrings.{$ENDIF}StrPas( PAnsiChar(notAfter^.d
  10. não acredito que seja esse o problema , uso o acbr a uns 5 anos , os aplicativos funcionavam bem na mesma pasta (uso lazarus) , a uns 3 meses quando fui atualizar os fontes para o inicio da nfe4.0 (mesmo sem ter alterado 1 linha se quer ainda ) os problemas apareceram...
  11. deu o mesmo erro , nao sei se é as opçoes que usei nao informou muita coisa... OpenSSL 1.1.0g 2 Nov 2017 (só pra informar mesmo) TApplication.HandleException Access violation Stack trace: $0000000000785403 $0000000000774B0A $0000000000769E99 $0000000000566AAA $000000000056728F $0000000000566992 $00000000004226AF $00000000005117EC $000000000063546C $00000000006427CB $00007F86790576F5
  12. peguei o exemplo do git , compilei preenchi dados do usuario ,certificado (A1) etc e cliquei em validade apresentou o erro da foto , em seguida coloquei em verificar status do serviço , erro de demais fotos... no console(terminal) apresentou o debug enquanto em rodava... $ACBrNFE_Demo' TApplication.HandleException Access violation Stack trace: $0000000000A49C66 line 142 of ../../../../../../../../../../../Documentos/BKP/Codigo_fonte_aplicativos/componentes/acbr/trunk2/ACBrTrunk2/Fontes/ACBrDFe/ACBrDFeOpenSSL.pas $0000000000A4AA50 line 406 of ../../../../../../../../.
×
×
  • Create New...