Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

clube mobile


Cursos grátis para toda base ACBr
+ Promoção Clube Mobile para o ACBr Pro

Saiba mais

adriano santos

click.png

click.png

click.png

click.png

click.png

click.png

Gumercino

Membros
  • Content Count

    54
  • Joined

  • Last visited

Community Reputation

9 Neutral

About Gumercino

  • Rank
    Membro

Profile Information

  • Sexo
    Masculino
  • Location
    Colatina-ES

Recent Profile Visitors

571 profile views
  1. Tá ótimo EMBarbosa. Agradeço pela atenção e ajuda. Vou fazer as tentativas que me sugeriu e caso eu consiga solucionar retorno aqui para compartilhar. Abraços
  2. Obrigado pelos pontos que você levantou EMBarbosa, vou verificar todos e tentar adaptar em todas as minhas threads. Referente a essa em específico, eu utilizo ela da mesma maneira que as outras e não tenho problema com as demais. Vou anexar a thread que utilizo para NFe para que você possa verificar que as duas tem o mesmo padrão. UThreadNFe.pas
  3. Boa tarde. Então, eu utilizo o mesmo padrão para os demais componentes de DFe, como NFE, CTe e MDFe, e não tenho esse problema que estou tendo com a NFSe. Revisei todo meu código e não consegui encontrar nada que estivesse causando esse erro. Trabalho com thread para diversas outras coisas. Vou dar uma olhada no link que você mencionou acima, e ver se encontro alguma coisa. O passo a passo é o seguinte: - Tenho um form para a tela de NFSe; - Chamo um form de animação para cada rotina da NFSe (Enviar, Consultar por Lote, Consultar por RPS e Cancelar); - Dentro desse for
  4. Só para deixar registrado, já utilizei o método "Synchronize" e não resolveu.
  5. Bom dia. Estou tendo um problema com o componente ACBrNFSe, e acredito que necessite de alguma ajuste, pois utilizo o mesmo método para os demais componentes de DFe. Segue resumo abaixo: - Eu tenho um form para a tela de NFSe, e para enviar o Lote RPS eu chamo uma Thread, o envio é feito normal mas quando eu vou fechar o form da NFSe, ele acusa o erro "System error, code 1400. O identificador da janela é inválido". Já tive esse erro em outras ocasiões, pois trabalho muito com Thread, mas revisei tudo na minha rotina e não identifiquei nenhum problema referente a esse assunto, en
  6. Boa tarde Italo. Consegui identificar o que esta ocasionando o erro. Na unit pnfsNFSeR na linha 4112, esta sendo filtrado os serviços pela tag "Servicos" aonde desse filtrar a tag "Servico". Fazendo esse único ajuste eu efetuei vários testes e não tive nenhum problema, funcionou tudo normalmente como tem que ser. pnfsNFSeR.pas
  7. Italo. Acabei de observar no site da prefeitura, o serviço esta indo duplicado. Eu informo 1 serviço na nota e envia 2, quando eu informo 2 ele envia 4.
  8. Boa tarde Italo. Desculpe a demora mas estava resolvendo uma demanda com um cliente. Então, após a atualização dos fontes e realização de novos testes, o erro ainda permanece ocorrendo na seguinte situação: 1° - Faço o envio da NFSe pelo método ACBrNFSe1.Enviar; 2º - Faço a consulta da NFSe pelo método ACBrNFSe1.ConsultarLoteRps logo após o envio para verificar a situação da mesma; 3º - Executo o método ACBrNFSe1.NotasFiscais.Clear. O erro esta ocorrendo na unit pnfsNFSe na linha 962.
  9. Boa tarde Italo. Farei a atualização dos fontes, novos testes e ao finalizar irei te posicionar.
  10. Bom dia Italo. Segue unit em anexo. pnfsNFSe.pas
  11. Boa noite Italo. Acredito que eu encontrei aonde esta o erro. Na unit pnfsNFSe a function TItemServicoCollection.New entrou no lugar da function TItemServicoCollection.Add, o que estava ocorre ndo é que dentro da function TItemServicoCollection.New tem a chamada da function TItemServicoCollection.Add. Eu comentei a linha 1204, que se refere ao que citei acima e rodei o programa sem erro. Segue imagem para melhor entendimento.
  12. Boa tarde Italo. Sim, reinstalei todos novamente. Eu utilizo o seguinte método para adicionar os serviços, "Servico.ItemServico.Insert(Index, AObject)" e antes não tinha esse parâmetro AObject. Mas eu estou passando ele de acordo com o que esta na função LerRps_EL, "Servico.ItemServico.Insert(Index, Servico.ItemServico.New)". Não sei se pode estar vinculado.
  13. Boa tarde. Após a atualização do ACBr, comecei os testes e identifiquei que estou tendo retorno do erro "invalid pointer operation" na linha 962 da unit pnfsNFSe. O erro sempre ocorre após eu carregar o componente com o arquivo .xml pelo método "LoadFromString" e efetuar qualquer operação com o webservice ou até mesmo após a impressão. Segue imagem do erro e da unit com a linha especificada.
  14. Boa tarde. Eu utilizo o ACBrNFSe para emissão de NFSe da cidade de Colatina-ES, aonde se utiliza o provedor EL para comunicação. Os parâmetros do arquivo .ini foram alterados e quero saber quem pode atualizar o mesmo dentro do ACBr? EL.ini
×
×
  • Create New...