Jump to content

icones_brancos.png

dia-do-acbr-online.png botao

botao.pngbotao.png

botao.pngbotao.png

Ofertas Embarcadero
Descontos de até 35%

Saiba Mais

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


botao.png

beneficios.png

jGuto

Membros
  • Content Count

    91
  • Joined

  • Last visited

Community Reputation

8 Neutral

About jGuto

  • Rank
    Membro

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Boa tarde, obtive retorno do provedor, realmente se encontra com erro. O mesmo já está providenciando a correção. Obrigado.
  2. 159097333-env-lot.xml159097333-rec.xml Bom dia, estou implementando a cidade de Itapeva/SP ao provedor CONAM, Estou obtendo um retorno meio estranho, vem identificado na tag retorno o valor false, "Estrutura não foi enviada corretamente e não é gerado protocolo" segundo o manual, porém a descrição do erro, que vem no mesmo arquivo é de aceite, "Arquivo Aceito. Protocolo em processamento. Consulte o protocolo para conferir o processamento. (Protocolo:51758A47A4D0B3716211)" Será que alguém já passou por isso? Seria realmente alguma informação invalida que o pr
  3. Bom dia Italo, a cidade de Itapeva/SP se utiliza do provedor CONAM [3522406] Nome=Itapeva UF=SP Provedor=CONAM NomeURL_H=sp.itapeva NomeURL_P=sp.itapeva
  4. Boa tarde, até onde eu sei, a SigCorp atende apenas a cidade de Avaré usando o padrão da Abrasf. As outras cidades que ela atende aqui da região é um padrão próprio da SigCorp.
  5. Bom dia, só mais uma alteração, adicionei a leitura do Campo LinkNFSe ao pnfsNFSeR pnfsNFSeR.pas case FProvedor of proTecnos, proSigCorp: NFSe.Link := Leitor.rCampo(tcStr, 'LinkNota'); proPublica: NFSe.Link := Leitor.rCampo(tcStr, 'LinkVisualizacaoNfse'); end;
  6. Bom dia, o erro realmente estava relacionado ao cadastro no provedor com caracteres especiais. Agora o mesmo está retornando as tags string com o CDATA, conforme o xml em anexo 149678321-lista-nfse-soap.xml acredito não ser o uso correto, mas decidiram que vai ser assim. Verifiquei que já existe um tratamento para este caso com o provedor proNFSeBrasil, dentro do pnfsConversao/RetirarPrefixos, então add o provedor SigCorp a mesma validação pnfsConversao.pas Obrigado.
  7. Bom dia, Estou obtendo erro 0, http 500 no Retorno de um xml de Envio para o provedor SigCorp. A NFSe chega a ser emitida na prefeitura, porém dá erro no retorno. O erro em questão acontece para um tomador em especifico. Para o envio com caracteres especiais, também dava erro, consultando o provedor eles aconselharam a usar o CDATA, e para o envio funcionou. O provedor ignora os dados cadastrais enviados, e retorna conforme cadastrado em sua base de dados baseado no CNPJ do mesmo, portanto não retorna o mesmo nome enviado. Como o Tomador em questão possui o "&" em seu nome
  8. Dando uma analisada nos fontes, percebi que outros provedores tem a seguinte parametro no arquivo ini, adicionei ela no meu ini e a assinatura deu certo.. SigCorp.ini
  9. Bom dia Daniel, ocorre o mesmo erro com a sua unit. 146-ped-can.xml
  10. Boa tarde @Italo Jurisato Junior, duas coisas, 1º - Fiz um ajuste na unit ACBrNFSeDANFSeFR na rotina CarregaParametros, o municipio de Incidencia está pegando o CodigoMunicipio, e não o MunicipioIncidencia, segue anexo ACBrNFSeDANFSeFR.pas; 2º - Com o componente configurado com "ACBrNFSe.Configuracoes.Geral.SSLXmlSignLib := xsLibXml2", não consigo utilizar a função CancelarNFSe, me retorna erro de assinatura e usando "ACBrNFSe.Configuracoes.Geral.SSLXmlSignLib := xsMsXML;" aceita o cancelamento normal. Também testei no site https://www.receita.fazenda.gov.br/Aplic
  11. Foi alterado o formato das datas no retorno do xml, e serviço CancelarNFSe está funcionado.. pnfsNFSeR.pas SigCorp.ini
  12. Segundo informações do provedor, hoje a tarde será realizada uma manutenção no servidor para o funcionamento dos outros serviços..
  13. Boa tarde, segue anexo fontes e ini. A função AcbrNFSe.Gerar já está funcionando,. AcbrNFSe.rar
  14. Bom dia Italo, ainda está acontecendo alguns erros no envio em relação ao provedor, assim que estiver ok eu posto.
  15. Boa tarde, consegui resolver a questão acima, estava faltando uma linha no cabeçalho.
×
×
  • Create New...