Jump to content

icones_brancos.png

dia-do-acbr-online.png botao

botao.pngbotao.png

botao.pngbotao.png

Ofertas Embarcadero
Descontos de até 35%

Saiba Mais

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


botao.png

beneficios.png

Paulo242

Membros
  • Content Count

    36
  • Joined

  • Last visited

Community Reputation

2 Neutral

About Paulo242

  • Rank
    Membro
  • Birthday 09/28/1973

Contact Methods

  • Website URL
    http://www.rt1.com.br

Profile Information

  • Sexo
    Masculino
  • Location
    São Paulo
  • Interesses
    Delphi, Lazarus, Firebird, Python

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. OpenSuse como sugerido pelo gestor do projeto. Tivemos de deixar no gelo por ora então não posso dizer que funcionou totalmente. Ainda vamos voltar nesta tarefa.
  2. Segue link do layout: http://download.itau.com.br/bankline/SISPAG_CNAB.pdf&ved=2ahUKEwicwv_A-PPbAhWBg5AKHVjoAFQQFjAAegQIABAB&usg=AOvVaw2kZxtm6FTfqCHSR_QUY-CC
  3. Caros, O ACBr já suporta geração de remessa de pagamento pelo layout do SISPAG?
  4. Troquei pro LibXml2 e foi, mas cabe verificar o erro para que outros não tenham o mesmo problema.
  5. Instalei o OpenSuse, achei os pacotes e instalei o monitor. COnsulta o serviço de primeira mas ao gerar a NFe: *** Error in `./ACBrMonitor': munmap_chunk(): invalid pointer: 0x00007f16dfdc1be8 *** ======= Backtrace: ========= /lib64/libc.so.6(+0x721af)[0x7f16e8c5f1af] /lib64/libc.so.6(+0x77706)[0x7f16e8c64706] ./ACBrMonitor[0x9b41f0]
  6. Daniel, você pode por favor informar quais os nomes do pacotes a serem instalados no OpenSuse? Com eles instalados e o script que você compartilhou, creio que consigamos finalizar a questão. O OpenSuse que vocês usam é o LTS ou o rolling release?
  7. Access Violation do mesmo jeito. Vou criar uma VM aqui com o OpenSuse e seguir o que vocês já testaram. Com o Ubuntu está bem difícil.
  8. Daniel, grato pelo script. Com ele achei um link simbólico faltando. O que ocorre agora ao gerar a nota é o seguinte erro: ./ACBrMonitor: symbol lookup error: ./ACBrMonitor: undefined symbol: xmlSecCryptoDLLoadLibrary
  9. Daniel, essa distribuição Linux está disponível para download? No caso de utilizá-la ao instalar o ACBr a DFe já funciona de pronto?
  10. Daniel, realmente um único instalador não atenderia todas as distribuições, assim como o atual não atende nenhum, no caso da DFe. Ao se criar um .deb para uma distribuição e versão, vocês poderiam atender essa plataforma por 5 anos, que é o tempo de suporte para versões LTS, no caso do Ubuntu. Um usuário mediano que for utilizar a plataforma, poderia escolher entre usar o Ubuntu ou OpenSuse sugerido por vocês e que já possui o .deb testado e estável para ambiente de produção sem ter de criar links simbólicos, achar versão certa, instalar e compilar pacotes. Eu entendo perfeitamente que não haj
  11. Já dei direito total nas pastas, mas segue dando Access Violation ao gerar a NFe. José, você acredita que seja importante gerar .deb e talvez ,rpm para Linux? Cada distribuição e versão está funcionando de um jeito e ter de criar links simbólicos, instalar pacotes não é pra qualquer usuário, mesmo programador. Se estiverem dispostos a fazer e eu puder contribuir, me prontifico.
  12. O Status funciona, mas qdo mando o comando de gerar a NFe já dá o erro.
  13. Existe algum esforço para disponibilizar o monitor em formato .deb, testados de acordo com as últimas versões do Ubuntu? Eu não tenho conhecimento (ainda) sobre como criar .deb, mas poderia pesquisar e contribuir. Segui os passos de instalação no Ubuntu 18.04 mas não tive sucesso, portanto a sugestão é que seja criada um .deb com todas as dependências, links simbólicos e códigos necessários para a aplicação funcionar. Seriam mantidos pacotes para as versões recentes do ubuntu, sendo apenas necessário baixar e instalar o .deb.
  14. Ótimos vídeos e PDF. Segui a documentação, criei todos os links simbólicos mas ao gerar a NFe o monitor fecha com Access Violation. Alguma ideia?
  15. Por tentativa e erro consegui resolver por aqui. Para o Ubuntu 18.04 são estes os pacotes: sudo apt install libgcrypt11-dev libxml2 libxslt1-dev libltdl-dev libxmlsec1 libssl1.0-dev Sigo sugerindo que a página mantenha uma documentação centralizada de instalação e configuração das várias plataformas suportadas pelo monitor.
×
×
  • Create New...