Jump to content

Promoção 25 Anos de Delphi
25% de desconto em todas as versões

Saiba mais

Ganhe o curso Tributação NF-e para Desenvolvedores

Assinando o SAC Anual este mês
botao.png

 

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

pradilsoncarlos

Membros
  • Content Count

    405
  • Joined

  • Last visited

Community Reputation

116 Excellent

2 Followers

About pradilsoncarlos

  • Rank
    Membro Ativo
  • Birthday 07/31/1970

Profile Information

  • Sexo
    Masculino
  • Localização
    Catanduva
  • Interesses
    ACBR

Recent Profile Visitors

693 profile views
  1. Isso mesmo, toda vez que deixo True para anexar arquivo ele dá um erro. Quando deixo False e pego o xml conforme código da imagem erro gnre1 ele enviar o xml. Vou anexar aqui a parte do código e o erro.
  2. Bom Dia Italo. Não costumamos usar o opendialog para buscar documentos fiscais. Fazemos a busca pela nome que o componente gera. No caso da GNRE, para que eu possa enviar o email preciso de um desses 2 xmls postados anteriormete, o nome deles é a data e hora que eles foram gerados. Quando acabo de enviar a GNRE e já envio o email dá certo, mas para enviar o email futuramente preciso desse arquivo. Como faço para pegar esse arquivo sem o opendialog ? Outra coisa o pdf está sendo gerado dentro da pasta que eu indico, mas ele não é anexado no envio do email. O envio de email da GNRE é diferente da NFE, NFSE, MDFE, documentos que eu uso e não tenho problemas para o envio de email. Seguindo o mesmo padrão desses documentos não estou obtendo exito.
  3. Quando envio email utilizando os xmls anexos aqui dá certo o envio. Como faço para armazenar essa nomenclatura na momento que ela é gerada ? 20200220160703-env-lot.xml 20200220160703-env-lot-soap.xml
  4. Estou anexando o xml. É o mesmo que uso no Imprimir. 2000369552-pro-rec.xml
  5. estou em homologação e não gera nenhum arquivo com essa extensão. Notei que quando eu acabo de enviar a guia eu consigo enviar o email, "4-gnre.xml", mas quando eu entro depois para enviar dá o erro de argument out of range. Se eu fizer assim: ACBrGNRE1.GuiasRetorno.Clear; ACBrGNRE1.Guias.Clear; AlimentarComponente; ele não dá o erro argument out of range, mas o xml vem com nome: "0-gnre.xml" Notei também que não consigo gerar o pdf: ACBrGNRE1.GuiasRetorno.Clear; ACBrGNRE1.GuiasRetorno.LoadFromFile(wDiretorioXml+NfeRECIBO.AsString+'-pro-rec.xml'); ACBrGNRE1.GuiasRetorno.ImprimirPDF; 0-gnre.xml 4-gnre.xml
  6. Bom dia. Estou tentando enviar uma GNRE por email e não consigo. Argument out of range no momento em que executa o camando: ACBrGNRE1.Guias.Items[0].EnviarEmail(TxtEmailNovo.Text, // e-mail do destinatário SeleEmpresas.Empresa.FieldByName('EMAILASSUNTO').AsString,// Assunto mmEmailMsg.Lines, // Mensagem True, // Enviar em PDF nil, // sCC nil) // Anexos
  7. Envie sem a IE e deu certo. Muito Obrigado. Estou trocando emails com a "GNRE - Guia Nacional de Recolhimento de Tributos Estaduais <[email protected]>", para verificar motivo do erro "197 - Erro ao recepcionar o lote". Assim que eu obter a resposta posto aqui para concluir este post. Agradeço a contribuição de todos.
  8. Acredito eu que devia haver alguma instabilidade no servidor de testes. Não fiz nada além de procurar artigos e informações para resolver, a partir de agora consegui enviar. Retornou a seguinte mensagem: Inicio TGNRERecepcao Ambiente: 2 Status Código: 100 Status Descrição: Lote recebido com sucesso! Recibo: 2000318373 Recebimento: 14/02/2020 11:18:56 Tempo Médio: 2000 Inicio TGNRERetRecepcao Ambiente: 2 Status Código: 403 Status Descrição: Lote Processado com pendencias ERRO: Lote Processado com pendencias Inscricao estadual do emitente nao cadastrada. Inicio TGNRERetRecepcao Ambiente: 2 Status Código: 403 Status Descrição: Lote Processado com pendencias Alguém pode me ajudar ?
  9. É por isso que estou aqui no fórum, de repente alguém já passou pelo problema e pode me ajudar
  10. código 197 - erro ao recepcionar lote. não tem mais nada além disso
  11. Tranquilo Italo, mas não é esse o problema, pode ver nos anexos que estou gerando os xmls na versão 1 e 2, no entanto não estão sendo validados.
  12. Quanto a aba geral está ali a opção para mudar de versão, mas mesmo mudando opção ali não muda no envio porque no código não tem a instrução "ACBrGNRE1.Configuracoes.Geral.VersaoDF := ve200 ou ve100". Agradeço pela sua prestatividade e vamos aguardar. Obrigado.
×
×
  • Create New...