Jump to content

marcosbaixista

Membros
  • Posts

    48
  • Joined

  • Last visited

Recent Profile Visitors

741 profile views

marcosbaixista's Achievements

Contributor

Contributor (5/14)

  • First Post
  • Collaborator Rare
  • Conversation Starter
  • Week One Done
  • One Month Later

Recent Badges

1

Reputation

1

Community Answers

  1. Boa tarde pessoal. Estou tentando gerar NFS_e para a cidade de Sarandi/PR, essa cidade utiliza o SigIss. Quando chamo o metodo ACBrNFSe.Gerar ele retorna -> "TNFSeWClass.GerarXml não implementado". Ainda não existe integração com o servidor de Sarandi/PR?
  2. Boa tarde pessoal. Tenho a necessidade de copiar as informações contidas em um arquivo .MFD de uma impressora fiscal para um banco de dados. Informações como CCF, Data da venda, Código do item, código de barras, descrição do produto, quantidade vendida, valor total do produto e valor total do cupom. A finalidade é levantar os cupons e produtos que foram vendidos na impressora em determinado período para fins de auditoria fiscal(Correção de declarações de impostos pagos). Existe algum componente no ACBR que eu consiga carregar o arquivo .MFD e copiar essa informações? Atualmente estou transformando esses arquivos em .TXT e copiando via programação delphi, mas tenho muitos problemas com isso com informações incorretas devido as particularidades desse arquivo gerado. Alguém tem uma ideia de como resolver esse problema? Procurei aqui no Forum algo relacionado a isso mas não encontrei nada. Desde já, grato a todos.
  3. Valeu pela dica pessoal. Diminui o tamanho da imagem até enquadrar e mostrar corretamente. Mas curioso que mesmo a propriedade STRETCH marcada como true no relatório ele não ajusta a imagem. Teria algo via programação pra ativar essa propriedade ou ajustar a imagem? Porque na versão 3.10 a DANFE não tinha esse problema mesmo usando imagens gigantes. Mas de qualquer forma o problema foi resolvido, só estou questionando outras possibilidades. Obrigado pela colaboração de todos.
  4. Boa noite pessoal. Estou com problemas na logo DANFE da NFC_e. Não aparece a logo completa como se a propriedade STRETCH estivesse setada como false. Conforme imagem abaixo. Já tentei abrir o relatorio da DANFE e alterar as propriedades mas mesmo assim continua da mesma forma. Alguém tem alguma idéia para resolver isso?
  5. Blz, deu certo aqui. Verifiquei e realmente ele forma o XML nessa sequencia. Obrigado pela ajuda amigo.
  6. Boa tarde amigo. Obrigado por responder. Os arquivos de eventos sempre obedecem essa lógica? 110110 + Chave acesso da nota + Sequencia + -procEventoNFe.xml É isso mesmo? Nesse caso nem precisaria salvar no banco de dados essas informações, aplicaria essa lógica para buscar o arquivo direto na pasta.
  7. Boa tarde pessoal. Estou tentando capturar o nome do arquivo XML gerado no cancelamento e na carta de correção da nota para poder imprimir os eventos futuramente caso o usuário necessite. Estou usando as seguintes propriedades. //esse retorna em branco. ACBrNFe1.WebServices.EnvEvento.EventoRetorno.retEvento.Items[0].RetInfEvento.Id; //esse retorna todo o xml. ACBrNFe1.WebServices.EnvEvento.EventoRetorno.retEvento.Items[0].RetInfEvento.XML; //esses tbm retornam em branco ACBrNFe1.EventoNFe.Evento.Items[0].RetInfEvento.Id Copy(ACBrNFe1.NotasFiscais.Items[0].NFe.infNFe.ID, 4, 44) + '-nfe.xml'; O cancelamento e a carta de correção estão sendo homologadas normalmente, mas não consigo pegar o retorno com o nome do XML gerado. Alguém pode me dar uma luz?
  8. Boa tarde. Obrigado pelas respostas de todos vocês. Consegui resolver o problema. O que ocorre é que a instalação antiga do Fortes Report espalhou arquivos por toda a máquina, e como estava procurando um arquivo em específico não conseguia encontrar o problema. Vou listar aqui quais os arquivos é necessário procurar e excluir da máquina caso alguém enfrente o mesmo problema. - frce.bpl - frce.dcu - frce.exe - FRCEINSTALL.EXE-0EE076C0.pf - FRCEINSTALL.EXE-1DC73629.pf - FRCEINSTALL.EXE-DD6508E9.pf Também é necessário excluir as seguintes pastas criadas pela instalação do Fortes Report. - NonCritical_frceInstall.exe_7c7a3b1d6a6a58afae8cc5a77457d9e7fa3d0_cab_1413aab2 - NonCritical_frceInstall.exe_1936c9b4dc3ccc88ca8d334e987f3ff361ea_cab_1b6db2ec - NonCritical_frceInstall.exe_a5d0668bed68239fd9b77d29fc6742e53a04fc0_cab_191358ba Após encontrar e excluir essas pastas e arquivos consegui instalar o componente com sucesso. Obrigado a todos pelas respostas e ajuda. Vlw.
  9. Sim, já baixei o .ZIP e instalalei ele. Vou fazer uma varredura aqui pra ver o que encontro sobre o Fortes.
  10. Olá Juliomar. Então, estou baixando o Fortes deste link https://github.com/fortesinformatica/fortesreport-ce O mesmo que está neste post, se eu baixar pelo .ZIP ele traz uma estrutura de pasta, já se baixar pelo SVN ele cria duas pastas a Trunk e a Brunches, estou instalando o conteúdo da pasta Trunk. Só não entendi o porque as pastas estão diferentes entre .Zip e SVN. Já limpei no delphi todos os links que apontam para as instalações do Fortes antigos e tentei reinstalar novamente, mas o problema persiste. Também não entendi o porque só da erro no componente de danfe da NFe. Os relatórios de boleto, NFSe e MDFe instalam o danfe fortes normalmente. Mais alguma idéia pra tentar resolver isso?
  11. Sim, tentando compilar pelo Delphi ele mostra o erro exatamente nessa linha: RLLayout.UnlimitedHeight := True; Coloquei a pasta do Fortes Report em C:/FortesReport. Sabe me dizer onde mais ele coloca arquivos e quais arquivos devo excluir da instalação antiga? Procurei somente o frce.bpl em documentos publico e o excluir, tem mais alguma coisa que preciso excluir da instalação antiga?
  12. Obrigado pela resposta Juliomar. Fiz os procedimentos que falou, inclusive exista o arquivo frce.bpl na pasta Documentos Publicos. Exclui ele e reinstalei normalmente o Fortes Report. Agora na instalaçao do ACBR consigo instalar normalmente os componentes DANFE do Fortes como: - ACBr_NFSeDanfseRL.DPK - ACBr_BoletoRL.dpk - ACBr_MDFeDamdfeRL.dpk - ACBr_GNREGuiaRL.dpk. Esses componentes instalam sem erro algum. Mas continuo com o mesmo erro no componente ACBr_NFeDanfeRL.dpk. Pesquisei antes da instalação do Fortes no HD todo e não encontrei nada relacionado a instalação antiga do Fortes. Existe algum outro arquivo referente ao Fortes(instalação antiga) que possa estar perdido na maquina?
  13. Olá Juliomar. Obrigado por responder. Em anexo os resultados dos instaladores Instalação da nova versão do Fortes Report. Aqui o retorno do instalador do ACBR. E aqui a tentativa de compilar o pacote pelo Delphi. Aqui o Log do instalador do ACBR. log_Delphi_XE3.txt
  14. Olá, boa tarde Regis. Estou tentando atualizar o componente no Delphi XE3 e não consigo compilar o pacote ACBR_NFeDanfeRL.dpk usando o instalador do ACBR e nem manualmente. Segui alguns tópicos que encontrei aqui no forum mas sem resultados, sempre cai na questão de atualizar o Fortes Report. Já exclui o Fortes antigo do Delphi, baixei o novo Fortes do link mencionado a cima, fiz a reinstalação do componente atualizado mas continua no mesmo erro. Alguma idéia pra resolver isso?
  15. Bom dia amigo. Vou dar uma opinião aqui que enfrento muito no Windows 7 nesse caso. Mas não posso afirmar que isso resolverá seu problema no Server 2012 ok. Mas tenta ai. Entra com o usuário que está dando o problema e faz o seguinte. - Abre Opções da Internet logado com o usuário que está dando problemas. - Vá até a aba "Avançadas". - Em configurações deixe marcado somente as opções: Usar SSL 2.0 e Usar TLS 1.0. - Desmarque as outras opções de SSL e TLS se estiverem setadas ok. Faz um teste ai, esse erro acontece muito com Windows 7, pode ser que resolva seu problema. Da um FEEDBACK aqui depois pra sabermos e ficar registrado no fórum ok. VLW.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.