Jump to content

click.png

click.png

click.png

click.png

click.png

click.png

click.png click.png click.png

click.png

click.png

click.png

Seja-Profissional-Saiba-mais.png Beneficios_banner.png

 

asamos

Membros
  • Posts

    51
  • Joined

  • Last visited

Everything posted by asamos

  1. Olá Baixei a última versão do ACBr e quando utilizo o programa exemplo para testar o evento S2210 ele entra em loop. Verifiquei que isto ocorre quando o Sistema entra na rotina pcsGerador -XMLAss. Testei também com o evento S1000 e também ficou em loop. Possuo um pen drive com o certificado digital A3 e faz 3 anos que utilizo a seguinte configuração: SSLib = libWinCrypt CryptLib = cryWinCrypt HttpLib = httpWinHttp XMLSignLib = xsLibXML2 e nunca tive problema com esta CONFIGURAÇÃO. Anexo tela. Havia testado com uma das primeiras versões do S1.0, antes da alteração do leiaute. Com aquela versão consegui fazer todos os procedimentos dos eventos Saúde. Gravei e enviei sem problema. Tendo em vista os prazos dados pelo eSocial para os eventos Saúde, toda ajuda é bem vinda. Abraço, Aristarco LoopNaGeracaoEvdentoS2210Config.pdf
  2. Prezado José Junior Não, o código de paisNac está correto, já identifiquei o problema. Inicialmente testei a versão S1.0 sem fazer qualquer alteração no aplicativo que estava rodando na versão 2.5 e ocorreu o erro apresentado na mensagem. Depois alterei o aplicativo seguindo a nova estrutura do XSD indicada na versão S1.0 agora o erro era de compilação o termo dadosTrabalhador da nova estrutura não era reconhecido. Então resolvi manter a estrutura XSD da versão 2.5 e subir o elemento paisNac do subgrupo Nascimento para o grupo Trabalhador como estava indicado no XSD da versão S1.0. Desta vez deu certo, o Sistema compilou e gerou corretamente o XML. De qualquer forma, obrigado pela atenção. Aristarco
  3. Olá Baixei a nova versão do ACBr e os problemas pela falta de reconhecimento dos XSDs cessaram, mas o problema que reportei referente ao evtAltCadastral (S2205) permaneceu. Como o exemploACBreSocial continua na versão anterior a S.10 não serve para teste. A estrutura do XSD da versão S1.0 apresenta o elemento <alteracao> mas o componente ACBreSocial não está reconhecendo. <xs:element name="evtAltCadastral"> <xs:element name="ideTrabalhador"> <xs:element name="cpfTrab" type="TS_cpfTrab" /> <xs:element name="alteracao"> <xs:element name="dtAlteracao" type="TS_dtAlteracao" /> <xs:element name="dadosTrabalhador"> <xs:element name="nmTrab" type="TS_nmTrab" /> <xs:element name="sexo" type="TS_sexoTrab" /> <xs:element name="racaCor" type="TS_racaCorTrab" /> <xs:element minOccurs="0" name="estCiv" type="TS_estCivilTrab" /> <xs:element name="grauInstr" type="TS_grauInstr" /> <xs:element minOccurs="0" name="nmSoc" type="TS_nmSoc" /> <xs:element name="paisNac" type="TS_paisNac" /> Estou utilizando o seguinte código para gerar o evento: with EvtAltCadastral do begin Sequencial := 0; with IdeEvento do begin indRetif := tpIndRetificacao(TabevtAltCadastral.indRetif); NrRecibo := TabevtAltCadastral.nrRecibo; //TpAmb := TpTpAmb(TabevtAltCadastral.tpAmb); ProcEmi := TpProcEmi(TabevtAltCadastral.procEmi); VerProc := TabevtAltCadastral.verProc; end; IdeEmpregador.TpInsc := tpTpInsc(TabevtAltCadastral.tpInsc); IdeEmpregador.NrInsc := TabevtAltCadastral.nrInsc; ideTrabalhador.CpfTrab := TabevtAltCadastral.cpfTrab ; with alteracao do begin dtAlteracao := TabevtAltCadastral.dtAlteracao; with dadosTrabalhador do begin NisTrab := TabevtAltCadastral.nisTrab; NmTrab := TabevtAltCadastral.nmTrab; Sexo : = TabevtAltCadastral.sexo; RacaCor := TabevtAltCadastral.racaCor; EstCiv := TabevtAltCadastral.estCiv; GrauInstr := FormatFloat('00', TabevtAltCadastral.grauInstr); nmSoc := TabevtAltCadastral.nmSoc; PaisNac := TabevtAltCadastral.paisNac; end; end; end; O programa não compila com erro na linha with alteracao e todos os itens abaixo dele. Que estrutura devo utilizar? Se utilizo a estrutura da versão anterior a S.10 ocorre o erro mostrado abaixo. Pelas mensagens postadas, não encontrei quem relatasse este problema. Agradeço a ajuda. Aristarco
  4. Prezado José junior Obrigado pelo retorno. Eu testei com meu programa e depois com o programa de teste da própria ACBr fornecido com o componente e ocorreu o mesmo erro. Basta executar o programa de exemplo, escolher a versão XSD (veS1.0..) e o evento S2205 - Não periódico - Alteração e GERAR. Irá aparecer a tela mostrada nesta consulta. Abraço, Aristarco
  5. Olá Italo Complementado o que apresentei acima. A Rotina GerarTrabalhador considera que o Grupo Trabalhador da estrutura XSD das versões ve 02_05 e veS01 são iguais, mas não são. Veja as imagens abaixo Agradeço a Ajuda
  6. Olá Quando faço uma alteração dos dados cadastrais de um funcionário (evento S2205) , o Programa de Teste do eSocial volta com um erro para o campo PaisNac, informando que está em branco apesar de estar preenchido, ver a mensagem em anexo. Identifiquei que na Alteração, a rotina GerarTrabalhador (em pcsTrabalhador) , acessa o campo PaisNac pelo grupo 'dadosTrabalhador ' mas na inclusão o acesso é feito pelo grupo 'trabalhador' dentro deste, o campo PaisNac é acessado pelo sub-grupo 'Nascimento'. Neste caso o campo PaisNac vem com valor. Agradeço a ajuda, Aristarco
  7. Obrigado Marcelo, foi uma boa notícia. estava com medo de ter ficado órfão. Assim que for publicado irei baixar. Abraço, Aristarco
  8. Obrigado Daniel, já peguei o script indicado no vídeo que você informou. Vou testa-lo. Abraço, Aristarco
  9. Prezado Daniel Verifiquei o vídeo que você me indicou e segui os procedimentos indicado. Segui a hierarquia de dependência dos pacotes, depois de Instalar Synapse, compilei com sucesso o ACBrComum, mas quando cliquei em instalar, o Lazarus informou que ele não possuia um Register e por isto não seria instalado na IDE. Ao compilar o próximo pacote: ACRrDiversos, o compilador apontou um erro, não foi encontrou o arquivo ACBr.inc. Este arquivo está na pasta C:\ACbr\Fontes\ACBrComum, há necessidade de incluir este caminho em Opções IDE - Arquivos ? No vídeo o Daniel não fala dessa necessidade. Em anexo as telas com as mensagens do Lazarus. Agradeço a sua ajuda Aristarco
  10. Obrigado Daniel. Vou verificar e tentar instalar utilizando este script. Um grande abraço. Aristarco
  11. Olá Tenho os Componentes do ACBr instalado no Delphi e tentei instala-los no Lazarus utilizando o AcbrInstall_trunk2 mas ele não funcionou da mesma forma indicando o Lazarus como sendo uma opção disponível. Qual a forma de instalar? Abraço, Aristarco
  12. Testei com o novo exemplo e deu certo. Vou verificar agora quais as divergências entre o exemplo e a minha rotina. Obrigado.
  13. Ok ! obrigado Vou baixar o novo exemplo. Obrigado Aristarco
  14. Prezado José Reinstalei o componente ACBr com a última versão. Testei o meu Sistema com os Schemas atualizados e consegui gerar e enviar como teste (Produção Restrita) todos os tipos de eventos. Para mim está sendo difícil fazer os testes com o programa de exemplo da ACBr devido as informações contidas em cada evento. Analisando o erro apresentado, verifiquei que não foram gravados os arquivos de cabeçalho do soap pesar de ter carregado no componente ACBreSocial os arquivos XML gerados anteriormente e depois executado a rotina de enviar. O comando enviar não deveria gerar estes cabeçalhos? Por que não gerou? Ver mensagem de erro abaixo. Agradeço
  15. Ok ! Irei fazer isto. Obrigado por enquanto. Aristarco
  16. Em anexo os arquivos que Gerei e depois carreguei no componente ACBreSocial pelo meu programa. 1022443280000002020102217544538942-S-1030-0.xml 1022443280000002020102217544543087-S-1030-1.xml
  17. Não testei, vou verificar, Obrigado Aristarco
  18. Olá Quando Gero e Envio um lote ao eSocial, o Sistema envia normalmente sem erro. Mas se por um problema no certificado não consigo enviar no momento da Geração, se depois, carrego os arquivos XMLs gerados no componente ACBreSocial, quando executo a rotina enviar aparece o erro 1871. Devo carregar mais algum arquivo além dos XMLs? Agradeço a Ajuda. Anexo o erro apresentado. Obrigado Aristarco
  19. Obrigado Juliana Peguei a rotina atualizada. Aristarco
  20. Olá Alguém pode me informar se já existe uma nova atualização da Tabela tpMptivoAfastamento para a rotina pcesConversaoeSocial para o novo código de afastamento 37 (Suspensão de Contrato de Trabalho) criado pelo governo ? Aristarco
  21. Prezado Italo Na verdade tem mais a ver com o Delphi. Eu tenho uma licença do Delphi 2006. Recentemente a placa mãe do computador onde o software estava instalado pifou. Adquiri um novo computador e quando tento fazer o Registro online do Delphi 2006, sou informado que a minha licença excedeu a quantidade de instalações e que eu preciso fazer este Registro via telefone. Como a ACBr é revendedora do Delphi, qual seria o telefone da Embarcadero aqui no Brasil mais indicado para falar sobre este assunto? Agradeço sua atenção. Aristarco [email protected]
  22. Olá Sergio Funcionou, obrigado pela dica. Um grande abraço e bom fim de semana. Aristarco
  23. Olá Obrigado pela resposta. Mas no meu computador não aparece essa tela. A que aparece é a mostrada abaixo. Verifiquei as opções em Settings, desmarquei todas, pois indicava que as desmarcadas apareciam no menu de contexto mas a opção cleanup não apareceu. A versão que estou utilizando do TortoiseSVN é : Aristarco
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.