Jump to content

DIOGO FERNANDES

Membros
  • Posts

    43
  • Joined

  • Last visited

Everything posted by DIOGO FERNANDES

  1. Pessoal bom dia. Como funciona essa configuração do timezone? Vira e mexe do nada fica dando essa rejeição... Já olhamos a hora do pc do cliente é tá tudo certo.. Obrigado
  2. Ok. Juliomar... Vou pensar em algo pra contornar aqui já que a mesma deverá ser contabilizada no mes 05. Muito obrigado.
  3. Bom dia Pessoal... Estou com uma dúvida. Os contadores reclamaram que os arquivos daquela pasta separadas por mes e ano que o componente cria pra salvar as notas estão misturando notas de um mes com outro.... Pois bem, ao fazer os testes o que notei foi o seguinte: A nota foi emitida off-line no dia 31/05: <dhEmi>2022-05-31T08:02:13-03:00</dhEmi> porem esta nota nao subiu pra sefaz no dia 31/05( aqui em MG as leva até uma semana pra voltar a funcionar certinho) e sim dia 01/06 <dhRecbto>2022-06-01T07:02:22-04:00</dhRecbto> e ele salvou a nota na pasta 202206 ao inves de salvar na 202205... Ele leva em consideração a data do recebimento. Ficando na pasta trocada... É isso mesmo? ou tem alguma configuração a mais que precisa fazer. Obrigado.
  4. Massa... Perfeito... Era isso mesmo que eu precisava. Muito Obrigado...
  5. Boa tarde pessoal. Como funciona estes arquivos temporários que o componente vai criando e salvando nas pastas. É por configuração? Neste exemplo foi uma consulta de status. Obrigado.
  6. Dá uma conferida nas librarys paths pra ver se não tá apontando pra algum outro que possa ter algo que tenha haver com o acbr... De repente em alguma pasta da library path pode ter alguma como algum arquivo acrb.inc ... Aqui aconteceu isso... Porem na pesquisa que fiz pelo explorer do windows não apareceu pq os componentes ficam em outro disco...
  7. Bom dia... No meu caso aqui aconteceu o seguinte... Era um arquivo ACBr.inc que estava perdido numa pasta aqui usado em outro componente que criaram aqui. Dái estava confundindo as diretivas. Fomos isolando os componentes que temos aqui um a um. Foi trampo pra entender, mas conseguimos resolver.
  8. Obrigado pelo feedback Juliomar; Rapaz... Criei uma nova pasta, baixei tudo de novo, deu clean na instalacao anterior e não foi... deu o mesmo... Mas alguma idéia?
  9. Bom dia pessoal. Estou tendo esse erro pra instalar depois de atualizar os fontes. Alguém já passou por isso ? Compiling package C:\XE7\XE7\ACBR\Pacotes\Delphi\ACBrTCP\ACBr_TCP.dpk "C:\Program Files (x86)\Embarcadero\Studio\20.0\bin\dcc32.exe" "C:\XE7\XE7\ACBR\Pacotes\Delphi\ACBrTCP\ACBr_TCP.dpk" Embarcadero Delphi for Win32 compiler version 33.0 Copyright (c) 1983,2018 Embarcadero Technologies, Inc. C:\XE7\XE7\ACBR\Fontes\ACBrTCP\ACBrIBGE.pas(386) Error: E2010 Incompatible types: 'System.Generics.Defaults.IComparer<System.TObject>' and 'Pointer' C:\XE7\XE7\ACBR\Fontes\ACBrTCP\ACBrIBGE.pas(429) Error: E2010 Incompatible types: 'System.Generics.Defaults.IComparer<System.TObject>' and 'Pointer' C:\XE7\XE7\ACBR\Fontes\ACBrTCP\ACBrIBGE.pas(443) Error: E2010 Incompatible types: 'System.Generics.Defaults.IComparer<System.TObject>' and 'Pointer' C:\XE7\XE7\ACBR\Fontes\ACBrTCP\ACBrIBGE.pas(742) Error: E2010 Incompatible types: 'System.Generics.Defaults.IComparer<System.TObject>' and 'Pointer' C:\XE7\XE7\ACBR\Fontes\ACBrTCP\ACBrIBGE.pas(767) Error: E2010 Incompatible types: 'System.Generics.Defaults.IComparer<System.TObject>' and 'Pointer' C:\XE7\XE7\ACBR\Fontes\ACBrTCP\ACBrIBGE.pas(782) Error: E2010 Incompatible types: 'System.Generics.Defaults.IComparer<System.TObject>' and 'Pointer' C:\XE7\XE7\ACBR\Fontes\ACBrTCP\ACBrIBGE.pas(796) Error: E2010 Incompatible types: 'System.Generics.Defaults.IComparer<System.TObject>' and 'Pointer' C:\XE7\XE7\ACBR\Fontes\ACBrTCP\ACBrCEP.pas(2148) Fatal: F2063 Could not compile used
  10. Bom dia pessoal. Estou tendo esse erro pra instalar depois de atualizar os fontes. Alguém já passou por isso ? Compiling package C:\XE7\XE7\ACBR\Pacotes\Delphi\ACBrTCP\ACBr_TCP.dpk "C:\Program Files (x86)\Embarcadero\Studio\20.0\bin\dcc32.exe" "C:\XE7\XE7\ACBR\Pacotes\Delphi\ACBrTCP\ACBr_TCP.dpk" Embarcadero Delphi for Win32 compiler version 33.0 Copyright (c) 1983,2018 Embarcadero Technologies, Inc. C:\XE7\XE7\ACBR\Fontes\ACBrTCP\ACBrIBGE.pas(386) Error: E2010 Incompatible types: 'System.Generics.Defaults.IComparer<System.TObject>' and 'Pointer' C:\XE7\XE7\ACBR\Fontes\ACBrTCP\ACBrIBGE.pas(429) Error: E2010 Incompatible types: 'System.Generics.Defaults.IComparer<System.TObject>' and 'Pointer' C:\XE7\XE7\ACBR\Fontes\ACBrTCP\ACBrIBGE.pas(443) Error: E2010 Incompatible types: 'System.Generics.Defaults.IComparer<System.TObject>' and 'Pointer' C:\XE7\XE7\ACBR\Fontes\ACBrTCP\ACBrIBGE.pas(742) Error: E2010 Incompatible types: 'System.Generics.Defaults.IComparer<System.TObject>' and 'Pointer' C:\XE7\XE7\ACBR\Fontes\ACBrTCP\ACBrIBGE.pas(767) Error: E2010 Incompatible types: 'System.Generics.Defaults.IComparer<System.TObject>' and 'Pointer' C:\XE7\XE7\ACBR\Fontes\ACBrTCP\ACBrIBGE.pas(782) Error: E2010 Incompatible types: 'System.Generics.Defaults.IComparer<System.TObject>' and 'Pointer' C:\XE7\XE7\ACBR\Fontes\ACBrTCP\ACBrIBGE.pas(796) Error: E2010 Incompatible types: 'System.Generics.Defaults.IComparer<System.TObject>' and 'Pointer' C:\XE7\XE7\ACBR\Fontes\ACBrTCP\ACBrCEP.pas(2148) Fatal: F2063 Could not compile used
  11. Boa tarde; Um cliente me questionou que o valor do ipi devolvido numa nota de devolucao nao sai no DANFE. Verifiquei que o xml esta correto, o total da nota esta correto... E pra piorar ela me mandou um danfe de uma nota de outro sistema e que consta o referido. Tem que configurar alguma coisa pra sair? O Acbr já esta atualizado.
  12. Bom dia pessoal; Alguém conseguiu usar a sefaz do Amazonas pra testar homologação de NFCe aqui de MG? Se sim, tem alguma configuração diferente pra fazer? Eu não estou conseguindo. Obrigado.
  13. Bom dia Cleber; Obrigado pela resposta... Esse consultar o serviço, por incrivel que pareça é o endpoint que melhor responde, mas não adianta, mesmo a resposta sendo positiva, não é garantia que o envio/consulta ou cancelamento vai dar certo.. Tipo assim, nos testes que fiz, vc consulta o status pra decidir o proximo passo, o status responde ok, vc manda a consulta é a mesma não responde, daí o sistema fica parado pq não consegue ir adiante e vai enfileirando as notas... Dái desisti de confiar no status...
  14. Bom dia; Estou implementando um serviço pra envio dos cupons off-line aqui em MG. Notei q as vezes qdo o cliente tem muita nota pra subir, do nada começa receber muito erro de 12030, 12002...Será que tem alguma coisa haver com essa qtde de requisições? Será que precisa esperar algum tempo de envio entre uma nota e outra? Quem tem esse tipo de serviço como vcs fazem? Obrigado
  15. Bom dia.. Já existe alguma propriedade pra evitar que assine / valide um xml caso o certificado esteja vencido.? Aconteceu isso no NFCe em modo off-line... Mas, rejeitou somente na hora de tentar enviar. Obrigado.
  16. Certo... Sou novo por aqui, então certas coisas ainda não sei como estão, vou checar isso. Mas teria alguma forma de contornar isso depois da kaka feita? ou uma forma de orientar o contador qto a isso? Obrigado.
  17. Bom dia pessoal; Essa é cabulosa, nunca tinha visto, mas aconteceu... O contador nos relatou que umas notas o sistema dele não estava conseguindo importar, após verificarmos, notamos que algumas notas estão sem a tag <Signature>... Mas ao consultar, elas constam na sefaz como autorizada normal e tem o protocolo. Como isso é possível e como solucionar isso? Pela data da pra ver que foi naquele dias que a sefaz tava com problemas aqui em MG, não sei se pode ter sido isso. Obrigado por enquanto.
  18. Realmente a configuração no arquivo .ini estava errada... Atualizei o acbr e veio com a config correta. Resolvido. Muito obrigado.
  19. Tomei como base este post.... O pessoal do suporte me relatou q meses anteriores dava certo... Dai fui olhar um antigo aqui e realmente, está sem o 'h'... exatamente conforme o link... Estou tentando entender o que pode ter acontecido... Já q os componentes estão em dia...
  20. Bom dia; Primeiramente me desculpem se essa dúvida não está postada no local correto. (Não vi a opção CTe ao criar o novo topico).. Como resolvo isso: <qrCodCTe> - <![CDATA[ https://hcte.fazenda.mg.gov.br/portalcte/sistema/qrcode.xhtml?chCTe=31211010409792000106570010000196741020458159&tpAmb=2 ]]> </qrCodCTe> Estou tentando enviar um cte em homologação, mas pelo que entendi, esse "hcte" deveria pegar como "cte".... Como resolvo isso? Obrigado.
  21. Bom dia Pessoal; Qual o caminho das pedras pra mim resolver essa rejeição? O contador insiste que esse codigo de barras esta igual ao da nota de entrada dele... Já tentamos enviar e não passa. Como proceder neste caso?
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.