Ir para conteúdo
  • Cadastre-se
Notícias do ACBr

impactus

Membros
  • Total de ítens

    70
  • Registro em

  • Última visita

Reputação

0 Neutro

Sobre impactus

  • Rank
    Membro

Últimos Visitantes

O bloco dos últimos visitantes está desativado e não está sendo visualizado por outros usuários.

  1. impactus

    Erros usando libWinCrypt

    Bom tarde, mudei recentemente as configurações do componente e estou com alguns problemas ao emitir um CT-e com as configurações Esta com a opção SSLXmlSignLib = xsLibXml2 pois foi passado pelo pessoal aqui no fórum por causa que em alguns clientes estava dando erro de Time Out usando a opção xsLibXML. Alguns dos erros que começaram 1824 - Element '{http://www.portalfiscal.inf.br/cte}nro': 'SN' is not a valid value of the local atomic type. 1824 - Element '{http://www.portalfiscal.inf.br/cte}IE': 'ISENTO' is not a valid value of the local atomic type. Sei que o erro do nro se eu colocar 3 digitos vai passar e no Isento se eu não passar a palavra ISENTO pro componente também passa, mas fiz um teste voltando como estava as configurações anteriormente e o problema não acontece emiti normalmente o ct-e Alguém sabe me dizer o que o porque com libCapicon funciona e passado libWinCrypt da esse problema?
  2. Bom dia, mudei recentemente as configurações do componente e estou com esse mesmo problema ao emitir um CT-e com as configurações Esta com a opção SSLXmlSignLib = xsLibXml2 pois foi passado pelo pessoal aqui no fórum por causa que em alguns clientes estava dando erro de Time Out usando a opção xsLibXML. Fiz um teste voltando como estava as configurações anteriormente e o problema não acontece emiti normalmente o ct-e Alguém sabe me dizer o que o que posso estar fazendo de errado?
  3. Boa tarde, a principio esta tudo atualizado só testei com opção SSLXMLSingLib = xsMsXML, vou fazer um teste com SSLXMLSingLib = xsLibXML2 assim que tiver resultados já informo aqui obrigado
  4. impactus

    TimeOut usando libWinCrypt

    Boa tarde, Efetuei uma alteração no componente do ACBRCTe alterando o SSLLIB de libCapicom para libWinCrypt fiz alguns testes internos e liberei para alguns clientes e funcionou perfeitamente, mas ao liberar para um cliente em todas as maquinas desse cliente o é retornado a seguinte mensagem : TimeOut de Requisição cheguei ate aumentar o tempo em webservise mas o problema continua, mas já se eu voltar para a SSLLIB de libCapicom não da o erro de TimeOut o que poderia ser?
  5. Boa Dia! Estou precisando fazer CTe de complemento de valores para 5 CTe's então gostaria de fazer apenas um Cte de complemento informando todos esses que preciso complentar, no manual consta InfCteComp 1 - 10 mas ao informar mais de um aprensenta a seguinte mensagem. <infCteComp> <chave>42130979888319000155570010000019781000019780</chave> <vPresComp> <vTPrest>30.00</vTPrest> <compComp> <xNome>VALOR PEDAGIO</xNome> <vComp>27.35</vComp> </compComp> </vPresComp> <impComp> <ICMSComp> <ICMS00> <CST>00</CST> <vBC>0.00</vBC> <pICMS>0.00</pICMS> <vICMS>0.00</vICMS> </ICMS00> </ICMSComp> </impComp> </infCteComp> <infCteComp> <chave>42130979888319000155570010000019771000019774</chave> <vPresComp> <vTPrest>40.00</vTPrest> <compComp> <xNome>VALOR PEDAGIO</xNome> <vComp>27.35</vComp> </compComp> </vPresComp> <impComp> <ICMSComp> <ICMS00> <CST>00</CST> <vBC>0.00</vBC> <pICMS>0.00</pICMS> <vICMS>0.00</vICMS> </ICMS00> </ICMSComp> </impComp> </infCteComp>
  6. Olá luizhenrique_vt, estou analisando tambem essa situação de controlar o valor pago, pois senão como voce mencionou, ele identifica o pagamento total com uma forma e bloqueia as demais.
  7. Agradeço desde já aos que tentaram me ajudar pacientemente, verificamos junto ao homologador a questão do teste acima citado, e eles nos informaram que o resultado esperado pode ser de erro de impresão ou se AC conferir o status da impressora a cada CRT enviado, retornando a ECF off e sair do processo tambem será validado. Uma vez que o resultado obtido for o resultado desejado.
  8. Olá EMBarbosa, eu entendi a sua colocação, e sim, posso estar complicando algo que é simples, mas infelizmente não estou conseguindo chegar lá com seu raciocinio no momento de testar. Conforme a descrição do teste onde cita: "Realizar uma transação de Crédito no valor de R$ 800,00, utilizando dois Cartões. Durante o fluxo de preenchimento dos dados do PRIMEIRO cartão desligar a impressora e esperar a transação ser aprovada", nesse momento eu desligo a ECF, e ainda não informei o valor e a forma do segundo cartão. E quando irei informar, gera o erro. Pela forma que você colocou eu teria que desligar a ECF na digitação do Segundo cartão, daí sim o procedimento é concluido com exito.
  9. Desculpe EMBarbosa, foi mal. Eu bufferizo os pagamentos, mas veja o meu fluxo se ele está incorreto: Valor Venda: 200,00 Primeiro Cartão passo com 100,00 e no momento das informações do cartão desligo a ECF, ao processar esse, a aplicação fica aguardando o novo valor e forma de pagto, que escolho Cartao e os 100,00 pendentes, novamente aciono o CRT com o valor restante, mas ele entra no evento InfoECF na opção ineEstadoECF para verificar o estado, e nesse momento ele retorna que a ECF não está em linha. Voces acham que o meu fluxo está incorreto? Ou ainda, está faltando algum controle mais? No Demo há uma maneira de simular essa situação?
  10. Nova dúvida: no procedimento a seguir, Realizar uma transação de Crédito no valor de R$ 800,00, utilizando dois Cartões. Durante o fluxo de preenchimento dos dados do PRIMEIRO cartão desligar a impressora e esperar a transação ser aprovada (mensagem “APROVADA 123456 ”), após exibir a mensagem “Erro na impressão. Deseja tentar novamente? <SIM> <NÃO>. ” Desligar o Computador. Após o retorno da energia, Ligar a ECF e iniciar a Automação Resultado esperado: A automação deve enviar o desfazimento das Transações TEF e exibir a seguinte mensagem “Transação TEF Não efetuada. Favor Reter o Cupom.” Tanto no DEMO e na minha aplicação ocorrem erro de ECF pois não está em linha, como posso fazer para dar erro de impressão se ainda tenho que passar o segundo cartão?
  11. Consegui encontrar a solução de um dos problemas, era no info_ecf, problema de desenvolvimento. Vamos para os outros.
  12. Eles me passaram o seguinte teste: Procedimento: "Realizar uma transação de Crédito no valor de R$ 900,00, utilizando um cartão. Durante o fluxo de preenchimento dos dados do cartão desligar a ECF e esperar a transação ser aprovada (mensagem “APROVADA 123456 ”), após exibir a mensagem “Erro na impressão. Deseja tentar novamente? <SIM> <NÃO>. ” Desligar o Computador. Após o retorno da energia, manter a ECF Desligada e iniciar a Automação.", Resultado Esperado: "A automação deve enviar o desfazimento da Transação TEF e exibir a seguinte mensagem “Transação TEF Não Efetuada. Favor Reter o Cupom.” O procedimento até o desligamento, o erro de impressão deu certo, mas o problema está no resultado esperado, tanto no DEMO como na minha aplicação ele confirma a transação. Será que tenho que mudar algo? Estou meio no desespero, na quarta tenho minha homologação!
×