Jump to content

betomunhoz

Membros Pro
  • Posts

    166
  • Joined

  • Last visited

  • Days Won

    3

Posts posted by betomunhoz

  1. Boa tarde.

    É somente instalar a nova cadeia do ICP ou tem que fazer alguma atualização de certificado no cartão?

    Alguém ai já fez esta atualização e deu certo?

    Eu vi também que o windows xp tem que estar com o service pack 3 e um hotfix especifico.

    Onde vc viu isso (sobre o service pack 3 e o hotfix) ?

  2. Agora surgiu uma dúvida:

    no manual, na página 122, nas observações do campo 113a (vUnTrib), está escrito:

    ".... Para efeitos de cálculo, o valor unitario será obtido ´pela divisão do valor do produto pela quantidade tributavel".

    Pois bem, o "valor do produto" é o valor total do produto certo ? Esse campo deve ser preenchido JÁ COM O DESCONTO ?

    Exemplo:

    QTDE.....PR.UNITARIO.....TOTAL BRUTO....DESCONTO....TOTAL LIQUIDO

    2 R$ 10,00 R$ 20,00 R$ 5,00 R$ 15,00

    O campo "vProd" deve ser preenchido com R$ 20,00 ou com R$ 15,00 ???

    No meu entender ele deve ser preenchido com R$ 20,00, pois se dividirmos 20 por 2, vai dar o valor unitário de 10,00.

    Mas se for preenchido com 15,00 vamos ter um valor unitario de 15/2 = R$ 7,50 , portanto diferente do informado no xml, nesse caso r$ 10,00.

    Alguma sugestão , pois no meu XML as tags qTrib e vUnTrib estão informadas corretamente e continuo recebendo o erro.

  3. Nunca tive um problema parecido, que me lembre.

    Acho que você esbarrou naqueles tipos de problemas que são os mais difíceis por que ninguém nunca teve ou quando teve, resolveu até sem perceber.

    Obrigado por ter postado como você conseguiu resolver.

    Só uma pergunta: Esse DEMO que você diz não é o do ACBrETQ? Acho que esse post está na parte errada do fórum... Se for, deveria estar na área do pacote ACBrSerial.

    Eu estava usando o DEMO do ACBrETQ para facilitar a conversa. Quanto a ter postado na área errada do fórum eu acho que me perdi aqui. Como eu não achava uma área correta, acabei optando pelo DIVERSOS mesmos.

    Se for o caso acho que o Moderador pode mover este tópico.

  4. Pessoal, o programa DEMO que acompanha o pacote ACbr, quando imprime numa argox OS214 Plus está ejetando uma página após imprimir uma carreira de 3 etiquetas, ou seja, imprime 3 etiquetas (uma linha) e ejeta a folha.

    O pessoal que vendeu a impresora para este cliente, instalou no painel de controle a impressora Argox. Eu acho que possa ser alguma coisa relacionada a driver.

    Pergunto: é mesmo necessário ter esses drivers instalados no Windows ou o componente AcbrEtiq imprime mesmo sem os drivers ?

  5. Como estou tendo problemas com notas conjugadas, achei prudente retornar a iinformação mais básica para quem sabe entender o que acontece.

    Se numa nota hipotetica eu tenho:

    Item 1: PRESTAÇÃO DE SERVIÇOS - R$ 100,00

    Item 2: PARAFUSOS - R$ 30,00

    No campo deve ser preenchido com R$ 30,00 (valor apenas do item 2) ou R$ 130,00 (somatoria de todos os itens, não fazendo distinção entre produtos e serviços).

    Eu li na página 151 do manual de integração, que o campo (332 - W07 - vProd) informa como "Valor Total dos Produtos e Serviços).

    Mas pelos tópicos que li, tem gente informando apenas o valor dos produtos.

    Como vcs estão preenchendo este campo ?

  6. Também estou com o mesmo problema.

    Eu não estou entendo é quais são os valores a serem usados.

    Tenho uma nota com apenas um item. Os valores são:

    CFOP: 5.101 - VENDA DENTRO ESTADO

    CST: 000 - TRIBUTADA INTEGRALMENTE

    01 cilindro VR 1.303,30

    ICMS 18% VR 234,59

    PIS 1,65% VR 21,50

    COFINS 7,60% VR 99,05

    A mensagem diz: 13188 -> REJEIÇÃO: TOTAL DO PIS DIFERE DO SOMATORIO DOS ITENS SUJEITO AO ICMS

    Pelo que eu entendi o "TOTAL DO PIS" (no meu caso na NF rejeitada é R$ 21,50) deveria ser igual ao VALOR DOS PRODUTOS ???? (nesse caso R$ 1.303,30)

    Alguma sugestão ?

  7. Então alguma coisa quebrou as linhas, isso está gerando o erro, uma saída seria baixar o XML original novamente, outra remover todas as quebras de linha do arquivo antes de lê-lo.

    Estou pensando em criar ua função para remover as quebras de linha.

    Vou procurar no Google algumas dicas em Delphi de como remover as quebras.

    Se der certo depois eu posto aqui para quem sabe servir para outros programadores.

    Obrigado.

  8. Qual o erro?

    Eu abri esse que foi postado aqui pelo IE e ele está cheio de quebras de linha no meio das tags, isso realmente vai fazer com que não se leia o XML.

    Inclusive no próprio IE ela já dá o erro.

    É esse mesmo o problema. Eu abri o XML como texto e também vi que a formatação dele está estranha.

    Lá no cliente em algumas maquinas o arquivo abre normalmente pelo IE, em outras maquinas não.

    O duro é que no programa Danfe View ele abre normalmente para visualizar o DANFE.

    Alguma sugestão ?

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.