Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

clube mobile


Cursos grátis para toda base ACBr
+ Promoção Clube Mobile para o ACBr Pro

Saiba mais

adriano santos

click.png

click.png

click.png

click.png

click.png

click.png

Gabriel Lazarin

Membros
  • Content Count

    20
  • Joined

  • Last visited

Community Reputation

4 Neutral

1 Follower

About Gabriel Lazarin

  • Rank
    Novato

Recent Profile Visitors

514 profile views
  1. Boa tarde Italo, Realizando dessa forma funciona perfeitamente. Apenas para contribuir, eu segui o exemplo do Acbr, onde está da seguinte forma: //Se tomador não é Contribuinte tomaNaoICMS.refCteAnu := ''; Alterado conforme passou, tudo ok. Agradeço
  2. Olá, estou com o seguinte problema no componente ACBrCTe. Estou emitindo um CTe de substituição, no qual o tomador não é contribuinte de ICMS. Foi emitido o CTe de anulação e estou passando os dados exatamente conforme manual: chCte= chave do Cte original refCteAnu= chave do Cte Anulação No Xml, não está gerando o campo refCteAnu, mas sim apresentando o grupo tomaICMS, que seria para tomador contribuinte, o que não é caso. Segue abaixo como está gerando: <infCteSub> <chCte>42201134977198000180570010000000551240750254</chCte> <tomaICMS> <re
  3. Olá.. Estava utilizando o componente IdHTTP para fazer uma requisição via POST com uma URL http, porém após adicionar um certificado, que passou a ficar com https, não consegui mais utilizar o IdHTTP. Mudei a rotina pra usar o componente HTTPClient, conforme código abaixo. Funcionou perfeitamente para o W10, mas para o W7 tenho o seguinte retorno: server certificate invalid or not present. Como poderia fazer essa requisição utilizando uma url com HTTPS que funcione para todas as versões do windows, ou então o ACBr possui algum componente que possa usar para esse tipo de requisição? lId
  4. Boa noite. O xml que existe é apenas do RPS que gera para ser enviado. Não salva nenhum xml de retorno na pasta configurada. O meu provedor aqui é o IPM. Se eu utilizo o envio sincrono retrona que não foi disponibilizado pelo provedor, bem como a opção de consulta do RPS, então não sei como obter o xml da NFSE. Uso a opção do exemplo "Enviar um RPS (Gerar)". Envia e autoriza o RPS normal, consultando no site, aparece a NFSE, baixo o xml, tudo normal. A linha onde retorna o erro é: sNomeArq := ACBrNFSe1.NotasFiscais.Items[0].NomeArq; isso por que o arquivo não está retornando do
  5. Olá. Não estou conseguindo obter o xml da nfse, pois a propriedade NomeArq está vazia. Configurei o componente conforme as linhas abaixo e estou usando o projeto exemplo. A nfse consta como emitida normalmente no site do provedor da prefeitura. Só preciso mesmo obter o xml de retorno. ACBrNFSe1.Configuracoes.WebServices.Salvar := True; ACBrNFSe1.Configuracoes.Arquivos.Salvar := True; ACBrNFSe1.Configuracoes.Geral.Salvar := True;
  6. Vou utilizar o componente para visualização com o Fortes Report, pois com ele gera certinho a visualização. Obrigado
  7. Olá. Sim, utilizando o componente para o FastReport o mesmo acontece no exemplo da ACBR. Se usar o fortes, funciona perfeitamente. Aunica alteração que fiz no exemplo da ACBR para usar o FastReport foi a seguinte: ACBrNFeDANFEFR1.FastFile := ExtractFileDir(application.ExeName) + '\Report\DANFeRetrato_Basic.fr3'; ACBrNFeDANFEFR1.FastFileEvento := ExtractFileDir(application.ExeName) + '\Report\EVENTOS.fr3'; Só passei o caminho dos arquivos de impressão. Eu acredito que seja alguma configuração no componente da nfe ou de impressão, mas já alterei várias propriedades e sempre gera co
  8. Olá. Estou imprimindo um cancelamento de NF-e, mas aparece "Carta de correção " e outra informações que não deveriam aparecer. O que estou fazendo de errado ?
  9. Olá Sérgio. Obrigado pelas dicas. Obtive o seguinte retorno: 8:12:24:461 TX -> [ENQ] - 18:12:24:669 RX <- 0[ETX][STX] 00250 0 0 0[ETX][STX] 00 UltimoPesoLido: 0 - Resposta: 0[ETX][STX] 00250 0 0 0[ETX][STX] 00 0,250 gramas Mas só para fins de conhecimento, sobre a porta estar em uso. Se eu ativo a balança e fecho a aplicação sem desativar ela, ao tentar ativar novamente depois, retorna o mesmo erro da porta em uso. Existe alguma forma de desativar o uso da porta sem reiniciar o micro?
  10. Olá.. Tenho uma balança Filizola conectada na porta COM1. Ao tentar ativar retorna a seguinte mensagem: erro ao ativar deviceCommunication error 5: Acesso negado Porta e taxa de transmissão foram configurados corretamente (COM1, 2400). Obs: O sistema operacional onde a balança está conectada é windows XP. Testei com outro aplicativo e comunica normal buscando o peso. Tentei utilizar o EmuladorBalanca no W10, mas ao clicar em Enviar peso retorna: Communication error 2: O sistema não pode encontrar o arquivo especificado.
  11. Bom dia. Ontem testei a transmissão e foi normal, sem alteração alguma nos fontes. Mas o link de homolgação é diferente do site da sefaz, sinceramente não sei o que acontece Quando precisar alterar a URL, não consigo mudar então ?
  12. Bom, eu consultei no site de AM e verifiquei que a URL de homologação está da seguinte forma: https://homnfce.sefaz.am.gov.br/nfce-services/services/NfeRetAutorizacao4 no arquivo ACBrNFeServicos está: https://homnfce.sefaz.am.gov.br/nfce-services-nac/services/NfeRetAutorizacao4 O que muda é (-nac), que no arquivo de serviços do ACBR têm, mas no link disponibilizado no site da sefaz de AM não. Foi isso que eu tentei alterar no arquivo, mas não deu certo, pois o componente ainda fica usando o que têm o (-nac), pois a alteração seria só remover isso. Posso estar errado, mas a
  13. Boa tarde Felipe. Entendi, acredito que seja a URL. Mas como faço para que as alterações no arquivo ACBrNFeServicos.ini tenham efeito ? Pois se eu alterar a URL neste arquivo, o componente parece que não busca dele. Eu alterei uma URL por exemplo, compilei os fontes do ACBR, mas ainda assim, não busca a URL que está dentro do arquivo. Consegue me ajudar quanto a isso ?
  14. Olá. Ontem começou a retornar a seguinte mensagem ao transmitir a NFC-e: Erro HTTP: 404 URL: https://homnfce.sefaz.am.gov.br/nfce-services-nac/services/NfeRetAutorizacao4 Teve alguma alteração na URL será ? OBS: Estou utilizando UF de AM e ambiente de homologação.
×
×
  • Create New...