Jump to content

Curso Dominando o ACBrMonitor
Novo Módulo Soluções de Varejo
Assine o SAC ACBr em qualquer plano e tenha acesso

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Rejane Lingner

Membros
  • Content Count

    17
  • Joined

  • Last visited

Community Reputation

8 Neutral

About Rejane Lingner

  • Rank
    Novato

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Oi @João Paulo Müller Parar o gerar já esta funcionando com as últimas alterações. Porém para o cancelar não (ao menos pra mim não..).
  2. Boa noite Italo. Realizei o teste com o programa exemplo, e ao cancelar, ocorre o mesmo erro que em minha aplicação.
  3. Boa noite. Consegui fazer um teste cancelando, mas tem um problema. Eu cancelo e retorna erro 500. Depois tento cancelar novamente e retorna crítica de que aquela nota já esta cancelada, e de fato a mesma se apresenta cancelada no site da prefeitura. Alguém conseguiu deixar 100% o cancelamento?
  4. Oi @João Bueno as quebras ali eu que fiz para melhor visualização. Nossa valeu mesmo, acho que foi o sono rsrsrs. Então pessoal, acho que esta OK agora. Não consegui emitir porque esta retornando uma critica no meu cadastro, mas deu certo, a critica esta vindo da validação do servidor. Inclusive tentei emitir uma nota já existente e me informou que ela já existe. Vou postar minhas alterações, se puderem validar e ver se é isso mesmo, só vou poder trabalhar nisso de noite. AlteracoesACBR.zip
  5. Boa noite @João Bueno Fiz algumas alterações no acbr para emitir, anexo o meu xml. Antes eu tinha o mesmo problema que os outros para emitir, agora deixando o xml dessa forma, esta dando novamente erro 500. Alguma ideia? 945-ger-nfse-soap.xml
  6. @Moacir Ezequiel Lamego Pelo que pude notar, está faltando o cpf/cnpj to tomador: Tomador.IdentificacaoTomador.CpfCnpj No xml ficará: <CPFCNPJTomador> <CNPJ></CNPJ> </CPFCNPJTomador>
  7. @Moacir Ezequiel Lamego Atualizei os fontes do acbr e peguei os .ini e schemas atualizados e funcionou, consegui gerar a nota. @Paulo Alexandre Hostert Também estou com dificuldade para recuperar os dados de retorno, você conseguiu? No xml esta correto, mas no objeto não consegui achar o numero e código de verificação. Para quem esta com erro 900, verificar se esta utilizado o método Gerar, ao invés de Enviar.
  8. Bom dia. Pelo que estou acompanhando no fórum, ainda não foi resolvido.
  9. Olá.. problema em meu fonte mesmo. Adicionei uma função que carrega as configurações padrões do cliente, e lá dentro dessa função tinha um Manifestos.Clear largado. Interessante que apesar do Clear os outros campos recebiam os valores, só em alguns ocorria o erro.
  10. Olá, fiz o teste com o exemplo do svn e não ocorre o erro, vou investigar para ver se não é um problema no meu fonte.
  11. Bom dia. Recentemente atualizei os fontes do ACBr, e esta ocorrendo Acess Violation ao montar os dados para o envio do manifesto, mas só em alguns campos. Exemplo: Na identificação, ao informar o modelo ('58') esta ocorrendo AV. Comentei essa linha, e a próxima a dar erro é a linha que informo verProc. Verifiquei que tanto o campo modelo, quanto o campo verProc são do tipo String. No campo verProc informo '3.0', se eu informar uma string 'A' por exemplo, não ocorre erro. Até então pensei que o erro esta relacionado aos campos string, porém ao passar do campo verProc, ocorre erro quando dou o comando infMunCarrega.Add. Outros campos, como exemplo, cUF;tpEmit;tpTransp;serie;nMDF, entre outros estão funcionando, sem Acess Violation. Alguém esta com esse problema também?
  12. Boa tarde. Eu adicionei esse recurso faz pouco tempo ao sistema e não consegui testar, porque em homologação dava esse erro ao gerar a nota. Então agora quando fui validar com o cliente, gerei a nota em produção, mas ao cancelar deu esse erro de hash. Como não consegui testar antes em homologação não sei dizer se foi a partir de alguma atualização do ACBR, porque atualizei os fontes antes de fazer o teste em produção.
  13. Oi Eduardo ainda não. Uma vez aconteceu esse erro cmg quando eu estava tentando enviar uma nota, mas era em homologação, em produção funcionava. Mas agora ocorre esse erro em produção ao cancelar. Entrei em contato com a Publica, mas me informaram que por se tratar de um erro com "hash" eles não poderiam ajudar, porque é um terceiro que trata isso.
×
×
  • Create New...