Jump to content

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png click.png click.png

Kirliam Maciel Dias

Membros Pro
  • Posts

    22
  • Joined

  • Last visited

About Kirliam Maciel Dias

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

Kirliam Maciel Dias's Achievements

Apprentice

Apprentice (3/14)

  • Dedicated Rare
  • Collaborator Rare
  • First Post
  • Reacting Well Rare
  • Conversation Starter

Recent Badges

0

Reputation

  1. Oi Victor, voltando à minha pergunta original: o ACBR permite que se incluam N títulos para baixar, usando o Boleto.IncluirTitulos. Então eu esperava ter um resultado de sucesso ou erro para cada título, e não um simples OK geral. O retorno do ACBR quando a operação é registro é seccionado por título, então esperava algo similar quando for operação de baixa. Algo como: [Titulo01] sucesso [Titulo02] erro
  2. Problema é que eu não tenho o request para enviar pelo postman. Não gera nada nos logs além daquele json.
  3. Na verdade estou usando o ambiente de homologação do BB. Está estranho também que não existe o log da chamada da API, como num envio de registro.
  4. Bom dia. Aquilo que eu postei é tudo que tem nos logs, tanto do monitor quanto da API. Na pasta de logs da API só foi gerado 1 arquivo ("536-registro_boleto.json"), só com aquela linha, diferentemente de uma operação de registro, onde são gerados pelo menos 3 arquivos. E o log do monitor é só aquilo ali mesmo.
  5. Boa tarde. Estou confuso quanto ao retorno recebido do ACBRMonitor quando é enviada uma remessa de Baixa. Quando a operação é registro, eu recebo a resposta de cada boleto em uma seção separada. Mas na baixa estou recebendo simplesmente um "OK". Esperava receber uma mensagem por cada boleto baixado, visto que pode acontecer de alguns darem certo e outros darem erro. 09/09/2021 17:18:43 - BOLETO.LimparLista 09/09/2021 17:18:43 - OK: 09/09/2021 17:18:43 - BOLETO.ConfigurarDados("C:\XXXXX\Boletos\bb_api_homologacao.ini") 09/09/2021 17:18:43 - OK: 09/09/2021 17:18:43 - BOLETO.IncluirTitulos("C:\XXXXX\Boletos\boleto.ini") 09/09/2021 17:18:43 - OK: 09/09/2021 17:18:43 - BOLETO.SetOperacaoWS(2) 09/09/2021 17:18:43 - OK: 09/09/2021 17:18:43 - BOLETO.EnviarBoleto 09/09/2021 17:18:45 - OK: Log da api (536-registro_boleto.json): {"numeroConvenio":3128557}
  6. Entendi. Então não dá para misturar registros e baixas num mesmo envio, certo? Essa alteração em breve, seria um parâmetro no "Boleto.EnviarBoleto"?
  7. Ah não, não alterei nada! Nem sabia que precisava... Como reportei no início da conversa, estou passando a lista de Boletos com BOLETO.IncluirTitulos("XXXX"), e incluindo a linha "OcorrenciaOriginal.TipoOcorrencia=1" nos títulos que desejo baixar, de forma similar a uma remessa via arquivo. É inviável ficar trocando no monitor e salvando. Vou aguardar vocês atualizarem então, e me passarem as instruções de como deve ser feito exatamente ao se trabalhar via arquivo.
  8. Acabei de testar aqui em ambiente de homologação, enviando um boleto para baixa. Achei estranho que o Header contem "Operacao=INCLUI_BOLETO". Seguem os arquivos. boleto.ini 390-registro_boleto.json 390-0009935389-retorno_registro.json ret0809211311.txt
  9. Oi José. Passei como booleano como você falou, mas ele não usou o valor indicado em "PercentualMulta", pelo visto usou o mesmo valor indicado em "ValorMoraJuros". boleto.ini DataMoraJuros=17/12/2021 DataMulta=17/12/2021 ValorMoraJuros=1,05 MultaValorFixo=1 PercentualMulta=6,00 boleto.json do log da API: "jurosMora": { "tipo": 1, "data": "17.01.2022", "valor": 1.05 }, "multa": { "tipo": 1, "data": "17.01.2022", "valor": 1.05 }
  10. Informando "MultaValorFixo" DataMulta=XX MultaValorFixo=XX o ACBRMonitorPlus não está preenchendo o campo tipo ao enviar para a API: "multa": { "tipo": 3, "data": "29.04.2022" } aí acabou recebendo um erro da API: "Campo tipo multa preenchido com dados inválidos." Mas se ao invés eu usar "PercentualMulta" DataMulta=XX PercentualMulta=XX aí o campo é preenchido: "multa": { "tipo": 2, "data": "29.05.2022", "porcentagem": 2 }
  11. Acabei de testar com a última versão de 64 bits, 1.4.0.46 - x64. Testei em dois computadores diferentes, deu o mesmo erro em ambos. Segue o log.txt em anexo. E ao que parece, o "AccessViolation" está ocorrendo sempre logo após o primeiro retorno com sucesso da API. Vou testar em seguida com a versão de 32 bits, mas pela página de downloads a última versão de 32 é a 1.4.0.45 - x64, está certo isso? LOG.TXT
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.