Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

consultoria_sticker.png

Conteúdo para desenvolvedores
 ao vivo de terça a quinta!
Saiba mais

dev.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


botao.png

beneficios.png

DBMGROUP SISTEMAS

Membros
  • Content Count

    12
  • Joined

  • Last visited

Community Reputation

2 Neutral

About DBMGROUP SISTEMAS

  • Rank
    Novato

Profile Information

  • Sexo
    Masculino
  • Location
    VITÓRIA - ES

Recent Profile Visitors

246 profile views
  1. Estava funcionando, inclusive no HOMOLOGAÇÂO ele esta correto, mais acho que deve ter tido algum erro e retornaram com o WEBSERVICE padrão, note que se você gerar direto pelo PORTAL ele estava colocando a versão 2.0 em alguns estados agora ele retornou com o 1.0 padrão. Estou enviando tudo pelo 1.0 que inclusive se colocar o versao="1.00" para de funcionar novamente. É pelo que vi eles devem ter ajustado vou alterar aqui e testar depois mando novamente a classe. Ele estava aceitando: Versão 1.00 - Os lotes do 1.00 <?xml version="1.0" encoding="UTF-8" standal
  2. Olá, eu havia postado pelo meu perfil no fórum publico vou postar aqui também os resultados. Este perfil aqui é o da empresa em que trabalho que acabou adquirindo o suporte pago por um mês para testes. GNRE_v1.0.zip GNRE_v2.0.zip
  3. Estes erros já são da integração, a comunicação funcionou agora o problema esta no seu XML da forma que você preencheu os dados. Tem um manual lá de preenchimento que é um CORINGA! tem configuração diferenciada por UF e por Tipo de Receita e em cada tópico tem uma série de considerações a ser feita na hora de preencher a guia eletrônica. Segue em anexo a GUIA que deu certo v1.0 pois DF ainda não aderiu a versão 2.0 1942193995-pro-rec.xml 1942193995-ped-rec.xml 20190424214007-rec.xml 36777-gnre.xml 20190424214006-env-lot.xml
  4. O mesmo ajuste fiz na versão 2.0 e agora estão todos enviando e tendo retorno function TGNREW.GerarXml2: boolean; var i : Integer; Doc: string; begin Gerador.ListaDeAlertas.Clear; Gerador.ArquivoFormatoXML := ''; { Ajuste DBM Sistemas Data: 24/04/2019 } Gerador.wGrupo('TDadosGNRE'); // versao="2.00" // Gerador.wGrupo('TDadosGNRE'); pgnreGNREW.pas
  5. Fiz um teste alterando o arquivo "pgnreGNREW" e passou a aceitar novamente o 1.0 que havia parado. Agora estou tentando ter sucesso com o 2.0 Alteração: Linha: 111 function TGNREW.GerarXml1: boolean; var i : Integer; Doc: string; begin Gerador.ListaDeAlertas.Clear; Gerador.ArquivoFormatoXML := ''; Gerador.wGrupo('TDadosGNRE'); // versao="1.00" <<<====== aqui a alteração // Gerador.wGrupo('TDadosGNRE');
  6. Boa noite, Identifiquei que em homologação passa, em produção não e se eu pegar os arquivos gerados e importar no portal ele tb é aceito.... só não passa pelo WebService
  7. Já configurei para as duas formas atualmente esta assim: Configuracoes.Geral.VersaoDF := pgnreConversao.TVersaoGNRE.ve200; Meus arquivos estão sendo gerados assim: 20190423145751-rec.xml 20190423145751-env-lot.xml
  8. Boa tarde pessoal, estou com um desenvolvedor trabalhando em cima de um problema do GNRE, já enviamos no forum publico mais replicarei aqui para ver se tenho uma atenção a mais. Desde a ultima atualização estamos com um erro: --------------------------- Error --------------------------- cvc-complex-type.3.2.2: Attribute 'versao' is not allowed to appear in element 'TDadosGNRE'. --------------------------- OK Já atualizamos o componente conforme solicitado pelo Italo, e continuamos com o mesmo erro ao tentar enviar a GUIA. XML´s enviados: --
  9. Já havia criado um tópico para o erro.. Favor ignorar este POST
×
×
  • Create New...