Jump to content

Delphi chamada_delphi.png acbr.png

C6 chamada_c6.png botao.png

Danfse - Erro Com Acbrnfsedanfsefr E Danfse.fr3


Valdir Dill
Go to solution Solved by Valdir Dill,
  • Este tópico foi criado há 2773 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro
Caros colegas,
 
Estou iniciando no envio de NFSe utilizando o ACBR para o servidor issCuritiba.
Consegui enviar o RPS, a nota foi confirmada e recebo o xml de retorno da nota. Tudo certo.
O problema está na hora de imprimir. Estou fazendo a impressão com ACBrNFSeDANFSeFR1 e utilizando o DANFSE.fr3. Ocorre que nesse .fr3, no campo "Nome / Razão Social" está configurado para imprimir apenas a razão social. Porém, o XML da NFSe retornado pela SEFAZ Curitiba, traz apenas o "NomeFantasia", sem a razão social. Aí, ao imprimir o DanfSe, esse campo ficam em branco.
A solução seria simples, ou seja, apenas alterar o .fr3 e mudar esse campo. Aí é que vem o meu problema que não estou conseguindo resolver. Se abro o .fr3 e faço qualquer alteração e salvo ele, ao tentar imprimir ocorre o erro "cdsParametros: Missing data provider or data packet" (print anexo).
Se eu utilizar o .fr3 do svn sem alterar nada nele, imprime normal, porém sem o nome fantasia.
 
Alguma dica? Será que é alguma incompatibilidade do Fortes Report instalado em minha máquina? Como resolver?
 
Obrigado.

Valdir Dill

Rio de Janeiro - RJ

 

 

Link to comment
Share on other sites

  • Consultores

Confere se seu arquivo midas.dll está na versão correta e se encontra no system32 ou junto ao delphi!

ou ainda pode adicionar o midaslib na uses do seu código!

acho que resolve seu problema!

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

  • Membros Pro
  • Solution

Confere se seu arquivo midas.dll está na versão correta e se encontra no system32 ou junto ao delphi!

ou ainda pode adicionar o midaslib na uses do seu código!

acho que resolve seu problema!

 

Obrigado pelas dicas Juliomar.

Fiz de tudo, inclusive em relação a midas que você sugeriu, mas não resolveu.

Olha que estranho: eu tinha os componentes ACBrNFSeDANFSeFR1 e DANFSE.fr3 em um dataModule. Só mudei eles para o form onde a impressão é chamada e resolveu.

Não sei o que pode estar gerando esse conflito, mas resolveu, que é o mais importantes, rs.

 

Obrigado pela ajuda!

Valdir Dill

Rio de Janeiro - RJ

 

 

Link to comment
Share on other sites

  • Consultores

O que pode ter ocorrido é que no datamodule não estar instanciado alguma uses necessária para a edição do relatório e assim ocasionando o problema mencionado!

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

  • 5 months later...
  • Este tópico foi criado há 2773 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.