Jump to content

Delphi chamada_delphi.png acbr.png

C6 chamada_c6.png botao.png

Erro Enviando Nfce Am - Resolvido Parcial Agora Erro 100 Qrcode Invalido


Go to solution Solved by gss200610,
  • Este tópico foi criado há 2817 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

estou testando em homologacao para estado AM

ja comparei o xml gerado com o do demo do acbr mais se valido o xml no sefaz rs da nfce

 

 

Regras de Negócio [Ambiente de Homologação (Testes)6 erros de validação
  • bullet_black.png702 - [simulacao] Rejeicao: NFC-e nao e aceita pela UF do Emitente
  • bullet_black.png704 - [simulacao] Rejeicao: NFC-e com Data-Hora de emissao atrasada
  • bullet_black.png709 - [simulacao] Rejeicao: NFC-e com formato de DANFE invalido
  • bullet_black.png209 - [simulacao] Rejeicao: IE do emitente invalida
  • bullet_black.png780 - [simulacao] Rejeicao: NFC-e com valor total superior ao permitido
  • bullet_black.png245 - [simulacao] Rejeicao: CNPJ Emitente nao cadastrado

 

obs: testei com mesmo dados do emitente no demo e passa

 

 

atualizei os fontes hoje 29/082014 e reinstalei usando acbrinstall mais nao vai. sempre o alerta: NFC-e nao e aceita pela UF do Emitente

 

ACBrNFe1.Configuracoes.Geral.ModeloDF := moNFCe;

ACBrNFe1.Configuracoes.Geral.VersaoDF := ve310;

 

segue meu xml gerado

 

 

solucao: estava faltando o parametro configuracoes.Geral.UF = AM

 

agora estou com o erro 100 de QRCODE invalido, estou usando acbr atualizado e em modo de homologação,

se alguem tiver uma sujestao ai, segue o link do qrcode gerado pelo proprio acbr.

 

 

 

http://homnfce.sefaz.am.gov.br/nfceweb/consultarNFCe.jsp?chNFe=13140808092092000199650010000000251000000251&nVersao=100&tpAmb=2&cDest=87910101287&dhEmi=323031342D30382D33305430373A33343A31312D30343A3030&vNF=8.00&vICMS=0.00&digVal=726B673968465439575050542F61474A442B7835684743624761493D&cIdToken=000001&cHashQRCode=BA321709DC18C3CA524415579CE10E670497D99E

13140808092092000199650010000000181000000184-nfe.xml

Edited by gss200610
Link to comment
Share on other sites

  • Solution

Resolvido.

 

verifiquei nos fontes do acbr que tinha uma observacao quanto ao modo de homologacao pra nao informar o token

 

ACBrNFe1.Configuracoes.Geral.Token   := '';

e com isso resolveu o erro do qrocde invalido, nao testei em modo de producao pois meu estado ainda nao vai aderir ao projeto

Link to comment
Share on other sites

  • Este tópico foi criado há 2817 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.