Jump to content

Assista click.png tectoy.png

C6 chamada_c6.png botao.png

Bloco G Não Está Sendo Gerado Paf - Sped


edsonmoretti
  • Este tópico foi criado há 2814 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

sped.getBlocoG().setDataInicial(dataInicial.getDate());
            sped.getBlocoG().setDataFinal(dataFinal.getDate());
            sped.getBlocoG().getRegistroG001().setIND_MOV(IndicadorMovimento.SemDados);
//            sped.getBlocoG().getRegistroG001().setIND_MOV(IndicadorMovimento.ComDados); Deu a mesma coisa
            RegistroG110 g110 = new RegistroG110();
            g110.setICMS_APROP(1.00);
            g110.setIND_PER_SAI(1.00);
//            g110.setMODO_CIAP("D");
            g110.setSALDO_FN_ICMS(1.00);
            g110.setSALDO_IN_ICMS(1.00);
            g110.setSOM_ICMS_OC(1.00);
            g110.setSOM_PARC(1.00);
            g110.setVL_TOTAL(1.00);
            g110.setVL_TRIB_EXP(1.00);
            sped.getBlocoG().getRegistroG001().getRegistroG110().add(g110);
            

Quando eu salvo:

|D001|1|

|D990|2|

|E001|1|

|E990|2|

|H001|0|

|H005|01092014|10,00|05|

|H010||UND|10,000|1,000000|1,00|0||PRODUTO DE TESTE 01||

|H005|01092014|10,00|05|

 

Mas não vem nenhuma informação do bloco G

Consequentemente no validador não vai.

Alguém já passou pelo o mesmo?

Edited by edsonmoretti
Link to comment
Share on other sites

Obrigado, mas eu já havia feito esse teste, e também não gerou. Estranho não

Tente informar toda a estrutura do bloco G e não somente o bloco G110, preferencialmente, com valores próximos a realidade, e verifique se os registros serão gerados. Observe que o layout específico no registro de abertura afeta diretamente os registros formados.

Link to comment
Share on other sites

Tente informar toda a estrutura do bloco G e não somente o bloco G110, preferencialmente, com valores próximos a realidade, e verifique se os registros serão gerados. Observe que o layout específico no registro de abertura afeta diretamente os registros formados.

Fiz, e novamente não gerou, nem levanta exceção, nem nada, só não aparece no arquivo.

 

obs: setei: 140,130,126,125,110,001 do bloco G

Edited by edsonmoretti
Link to comment
Share on other sites

Achei que poderia ser o SO, estava no XP testei no 7 e no 8 32 e 64, e deu no mesmo :sad:

 

Edit ------------------

Mesmo que não tenha dados ele não deveria vir? já que é um registro obrigatório deveria vir, ou estou errado e não é obrigatório?

 

tipo, se n tem registro, acima do bloco H

|G001|1|
|G990|2|

 

e encerrando:

|9900|G001|1|
|9900|G990|1|

Edited by edsonmoretti
Link to comment
Share on other sites

Achei que poderia ser o SO, estava no XP testei no 7 e no 8 32 e 64, e deu no mesmo :sad:

 

Edit ------------------

Mesmo que não tenha dados ele não deveria vir? já que é um registro obrigatório deveria vir, ou estou errado e não é obrigatório?

 

tipo, se n tem registro, acima do bloco H

|G001|1|

|G990|2|

 

e encerrando:

|9900|G001|1|

|9900|G990|1|

Olá edsonmoretti, homologuei o sistema essa semana, no bloco G alimentei apenas as informações de data inicial e data final, coloquei também como sem dados e gerou normalmente.

 

Att

Geovani Nicolau de Paula

Cell Corporação Tecnológica

Link to comment
Share on other sites

Olá edsonmoretti, homologuei o sistema essa semana, no bloco G alimentei apenas as informações de data inicial e data final, coloquei também como sem dados e gerou normalmente.

 

Att

Pois é não sei o que estou fazendo de errado: -(

 

sped.getBlocoG().setDataFinal(dataFinal.getDate());

sped.getBlocoG().setDataInicial(dataInicial.getDate());

sped.getBlocoG().getRegistroG001().setIND_MOV(IndicadorMovimento.SemDados);

 

 

Edit-------------------

Usei o teste do pacote e tbm não gerou o bloco g:

.....

|D990|2|

|E001|1|

|E990|2|

|H001|0|

|H005|08092014|10,00|01|

|H010|1|UN|8,000|5,500000|3,00|0|P|Texto Complementar|1.1|

|H020|00|100,00|7,00|

|H990|5|

|1001|0|

|1990|2|

|9001|0|

|9900|0000|1|

|9900|0001|1|

|9900|0005|1|

.....

Edited by edsonmoretti
Link to comment
Share on other sites

Olá edsonmoretti, homologuei o sistema essa semana, no bloco G alimentei apenas as informações de data inicial e data final, coloquei também como sem dados e gerou normalmente.

 

Att

Bom dia, vc pode me passar o seu Skype, se não for nenhum problema, pois vou homologar pela primeira vez, qria tirar umas dúvidas, ql foi seu perfil?

Link to comment
Share on other sites

Bom dia, vc pode me passar o seu Skype, se não for nenhum problema, pois vou homologar pela primeira vez, qria tirar umas dúvidas, ql foi seu perfil?

Bom dia edsonmoretti.

 

Homologuei o "W" e "X", meu skype é cell.atendimento2

 

Att

Edited by Geovani N. de Paula

Geovani Nicolau de Paula

Cell Corporação Tecnológica

Link to comment
Share on other sites

  • Este tópico foi criado há 2814 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.