Jump to content

Assista tectoy.png

Impressora Bematech Lb-1000


  • Este tópico foi criado há 2798 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Boa tarde.

 

Vou explicar a minha situação, para que vocês possam compreender o que de fato está ocorrendo.

 

Tenho um sistema que gera etiquetas a partir do Fast Report, deixando-as prontas para impressão. Funciona perfeitamente, sempre tive sucesso em impressoras comuns (jato de tinta) e em impressoras Zebra.

 

Um cliente comprou, porém, uma impressora Bematech cujo modelo era LB-1000, em suma, uma impressora própria para etiquetas de código de barra. Fui à página da Bematech e baixei o driver. Instalei-o e, ao efetuar os testes, nada acontecia. Não consegui sequer imprimir as páginas de teste, recurso que o próprio sistema de drivers de impressoras sugere. Revirei todo o site da Bematech, até que encontrei uma ferramente. Essa ferramente, entretanto, imprime normalmente. Fico em dúvida: será que há uma conexão direta com a impressora a partir desse sistema, totalmente independente do sistema de impressão do Windows? Isso não seria, em si, uma espécie de driver embutido?

 

Bom, procurei o suporte deles, tanto por telefone quanto por skype ou e-mail: é péssimo, não dão a atenção necessária para o cliente e, no fim, não se resolveu nada.

 

Procurando por aqui eu encontrei alguns tópicos referentes ao ACBrETQ e a sua possível comunicação com essa impressora. Recorri ao exemplo que, por algum motivo, não funcionou; preenchi com "USB" os campos referentes à porta, nada; preenchi com os valores pré-definidos e o sistema dizia que faltava um arquivo, algo semelhante.

 

Não sei como trabalhar com essa impressora. Alguém poderia me esclarecer mais sobre o porquê disso tudo? E não é possível imprimir nela a partir do Fast Report?

 

Obrigado!

Link to comment
Share on other sites

Você havia enumerado estes passos:

 

1 - instale o driver da Impressora no Windows
2 - Imprima uma página de testes, se tudo OK, vá ao passo 3, senão volte ao passo 1
3 - Mapeie a impressora na rede
4 - use o nome do recurso de rede na propriedade Porta do Componente Ex:
Porta := ''\localhost\@epson"
(supondo que vc mapeou a impressora com o Nome de Epson)

 

 

 

Mas, conforme eu disse anteriormente, a página de testes não imprime, voltando novamente ao passo 1 - e eu já o repeti várias vezes, inclusive com um drive que um rapaz do suporte deles deu a mim.

 

Mais alguma sugestão?

 

Muito obrigado!

Link to comment
Share on other sites

  • Fundadores

No caso dessa impressora, pode ser que realmente não exista uma Página de testes, ou driver que crie uma impressora compatível com o Windows (mas isso é com o fabricante)

 

A ideia de mapear a impressora no windows, é apenas para permitir que você consiga acessar a porta USB dela...

Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

Essa impressora provavelmente é PPLA...

 

Se ela tiver interface Serial, será mais simples...

 

Sim, sim, é possível fazer a comunicação serial nela. Eu vou ver se providencio o cabo amanhã, pois o cliente só enviou o USB.

 

Trabalhei com impressoras Argox PPLA há três anos, com o próprio ACBr. Amanhã eu digo aqui o que consegui através da comunicação serial.

 

Muito obrigado!

Link to comment
Share on other sites

Olá. Com um cabo serial, COM4, consequi imprimir a partir do exemplo do ACBr. Fazer a exemplo dele, porém, faria com que eu recriasse todo o sistema de posicionamento etc., visto que o meu sistema trabalha com relatórios Fast Report. Não há como imprimir nessa impressora através do FR?

 

Obrigado!

Link to comment
Share on other sites

  • Fundadores

A impressora se comportou como uma PPLA ?

 

Se SIM, experimente instalar os driver para Windows da Argox

http://www.argox.com/content.php?sno=0000033&P_ID=88

Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

A impressora se comportou como uma PPLA ?

 

Se SIM, experimente instalar os driver para Windows da Argox

http://www.argox.com/content.php?sno=0000033&P_ID=88

 

Desculpe, Daniel, mas que comportamento seria esse? Não trabalho com isso há mais de três anos.

 

No ACBr, como PPLA não imprime, mas sim como PPLB.

 

Muito obrigado!

Link to comment
Share on other sites

  • Fundadores

Nesse caso acho que o driver da Argox não será compatível... (A Argox usa a linguagem PPLA)

 

Você realmente precisaria de um Driver de Impressora padrão para o Windows fornecido pelo fabricante

 

Mas não custa tentar... veja o link do post anterior... baixe o driver e tente instalar...

Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

Nesse caso acho que o driver da Argox não será compatível... (A Argox usa a linguagem PPLA)

 

Você realmente precisaria de um Driver de Impressora padrão para o Windows fornecido pelo fabricante

 

Mas não custa tentar... veja o link do post anterior... baixe o driver e tente instalar...

 

Vou fazer isso agora mesmo.

 

Mais uma vez, muitíssimo obrigado!

Link to comment
Share on other sites

  • 3 months later...

Obrigado, Daniel. Desse modo, o erro é I/O error 1231 ou I/O error 58, dependendo do modelo selecionado. Testei com todos os modelos. A impressora deve corresponder a um daqueles modelos, certo?

 

Muito obrigado!

 

Tente usar no lugar de \\localhost\, \\127.0.0.1\<nome_do_compartilhamento>, tive um problema esses dias de I/O 58 e era isso.

Edited by Pedro Antonio Marchette
Link to comment
Share on other sites

  • Consultores

TENTE USAR NO LUGAR DE \\LOCALHOST\ , \\127.0.0.1\<NOME_DO_COMPARTILHAMENTO> TIVE UM PROBLEMA ESSES DIAS DE I/O58 E ERA ISSO 

Bom dia!

Seja Bem vindo ao fórum e obrigado pela contribuição!

 

peço para que se não leu, leia as regras do fórum

veja o item 6.3

 

desde já a equipe agradece!!

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

  • Este tópico foi criado há 2798 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.