Jump to content

click.png click.png click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

Falha no Schema XML quando ativo IncluirQRCodeXMLNFCe.


  • Este tópico foi criado há 1928 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Boa tarde, pessoal!

Vou iniciar a implementação da NFC-e em um de meus sistemas. Estou, antes de tudo, testando com o Demo do pacote ACBr. Estou enviando em ambiente de homologação e configurei a propriedade IncluirQRCodeXMLNFCe para True. Porém recebo mensagem de rejeição da Receita: "Falha no Schema XML da NF-e". Antes, a rejeição era porque as informações do QR-Code não constavam no arquivo XML. Pesquisei no fórum e descobri que a propriedade IncluirQRCodeXMLNFCe deveria ser configurada para true. Fiz isso e agora a mensagem é de falha no Schema. Abri o XML para ver como estava e, para minha surpresa, está com apenas uma linha. Vejam:

5300000001VENDA065112016-05-30T16:21:51-03:0011530010849721110ACBrNFe2016-05-30T00:00:00-03:00

Alguém pode me dizer o que estou esquecendo?

Link to comment
Share on other sites

Rapaz, então que "mistério" é esse?

Rodei o demo aqui novamente e cliquei no botão "Criar e Enviar", da aba NFC-e.

Pediu o PIN do certificado (o meu é A3), inseri, processou e retornou a mensagem de Rejeição (imagem anexa). 

Cliquei no OK e abri o XML gerado, coloquei no site da SEFAZ e está tudo certo.

Não entendi o que pode está provocando o erro.

mensagem_erro.png

Link to comment
Share on other sites

Boa noite, Juliomar!

Sinceramente não consigo entender o que está acontecendo. Estava usando um certificado A3, como lhe falei. Estava dando rejeição por falha no Schema XML do lote. Isso, nos meus teste com o demo. Os arquivos XML gerados eram validados corretamente no site da SEFAZ (https://www.sefaz.rs.gov.br/nfe/NFE-VAL.aspx). Se eu clicava com o botão direito no arquivo XML e pedia para abrir com o XMLEditor, não mostrava a estrutura do XML, apenas uma linha. 

Ontem, misteriosamente, fui testar novamente e funcionou. Enviou, retornou, etc. Isso com o demo, ainda. 

Hoje, meu cliente me enviou o arquivo do certificado dele, um certificado A1, da VALID. Consegui instalar o certificado, usando o instalador da VALID. Configurei tudo no demo e quando mandei gerar o NFC-e, adivinha, "Rejeição: Falha no Schema XML do lote NFe". 

Alguma ideia? :-(

Link to comment
Share on other sites

  • Este tópico foi criado há 1928 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.