Jump to content

click.png click.png click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

  • Este tópico foi criado há 1856 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Boa noite.Estou tendo problemas aoconsultar a nfc-e pelo qr-code se efetuar a consulta de uma nota no ambiente de produção,a nota e enviada e autorizada mas quando efetuo a consulta ao clicar na area de informações para o contribuinte e fisco aparece o erro na formatação do qr-code :código do hash do qr-code invalido mas nao recebo nenhuma rejeição a nota e autorizada sem problemas.alguem poderia me auxiliar?

Link to comment
Share on other sites

Em 30/07/2016 at 00:55, Antony Moraes disse:

Boa noite.Estou tendo problemas aoconsultar a nfc-e pelo qr-code se efetuar a consulta de uma nota no ambiente de produção,a nota e enviada e autorizada mas quando efetuo a consulta ao clicar na area de informações para o contribuinte e fisco aparece o erro na formatação do qr-code :código do hash do qr-code invalido mas nao recebo nenhuma rejeição a nota e autorizada sem problemas.alguem poderia me auxiliar?

@Antony Moraes seja mais específico, poste o XML para que possamos analisar.

Aqui https://www.sefaz.rs.gov.br/NFE/NFE-VAL.aspx tem o validador da NFe, pode carregar o XML lá e ver a mensagem, pois sempre que dá qr-code inválido mostra o que está diferente.

Em homologação você tem a mesma mensagem ?

Link to comment
Share on other sites

Boa tarde,

Estou com o mesmo problema... ( "Codigo de Hash no QR-Code difere do calculado" ).

Até dia 31/07/2016 emitia NFc normalmente. 

Já testei   Geral.IdCSC  e   Geral.CSC  de tudo jeito e o erro persiste.

Alguém tem mais alguma dica ?

Grato.

André 

 

Link to comment
Share on other sites

33 minutos atrás, André disse:

Boa tarde,

Estou com o mesmo problema... ( "Codigo de Hash no QR-Code difere do calculado" ).

Até dia 31/07/2016 emitia NFc normalmente. 

Já testei   Geral.IdCSC  e   Geral.CSC  de tudo jeito e o erro persiste.

Alguém tem mais alguma dica ?

Grato.

André 

 

André, eu componente está atualizado ? Já verificou o demo para ver como está implementado ?

Eu já tive este problema, no meu caso eu estava carregando o componente e executava o Validar, depois carregava mais algumas informações e outro Validar, ocorre que com as mudanças do componente o XML que era enviado não recebia a segunda carga de informações, o que fiz foi remover toda e qualquer chamada do método e somente executar após estar toda a informação carregada no componente.

Link to comment
Share on other sites

  • 4 weeks later...
  • Este tópico foi criado há 1856 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.