Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


Saiba mais

beneficios.png

click.png

click.png

click.png

  • Este tópico foi criado há 1552 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

  • Membros Pro

Boa tarde, amigos 

Estou com um problema e uma duvida, atualizei os fontes do ACBR segunda-feira(19/04) gerei um executável do meu projeto de CTe  e atualizei no meu cliente (transportadora) e para minha surpresa ao clicar em gerar a CTe o sistema começou a apresentar a mensagem de "O conjunto de chaves não existe" . 

Voltei o meu executável antigo e o mesmo CTe foi validado sem erros. Olhando o historico de alterações verifiquei que houve uma alteração referente a identificação do certificado digital , Capicom  e OpenSSL.  Nas minhas aplicações eu utilizo a CAPICOM , é esse o motivo que minha aplicação parou de funcionar? 

Lendo os posts anteriores no forum, não consegui ter certeza se o problema era a CAPICOM e consequentemente o que eu preciso fazer para resolver o problema.

Agradeço desde ja, e aguardo uma auxilio.

 

@Fábio Eduardo de Souza

 

 

 

 

Link to comment
Share on other sites

  • Membros Pro

BOa tarde , @Daniel Simoes

 

Voce poderia me ajudar com a duvida que descrevi acima ? 

Consegui instalar o certificado digital(A1) do meu cliente na minha máquina e a mesma versão que deu problema lá na base do cliente não está dando problema na minha máquina, instalei o certificado igualzinho meu cliente instalou...está faltando alguma instalação que tenha que ser feita na maquina do meu cliente?  Lembrando que um versão mais antiga da minha aplicação funciona perfeitamente.

 

Agradeço de ante mão 

 

@Fábio Eduardo de Souza

Link to comment
Share on other sites

  • Fundadores

Para analisarmos o problema, você precisa descrever um passo a passo, de como reproduzi-lo usando os demos do ACBr

Certificado A1 não precisa de instalação... basta apontar para o arquivo PFX...

Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Membros Pro

Obrigado, Daniel 

Problema solucionada. Desinstalei o ACBR da minha máquina, baixei novamente os repositorios, reinstalei tudo e depois fiz um BUILD na minha aplicação. 

Refiz os testes no meu cliente e a minha aplicação voltou a reconhecer o certificado digital.

 

@Fabio Eduardo de Souza

 

Link to comment
Share on other sites

  • Fundadores

Obrigado pelo retorno... pode ser que tenhamos corrigido nesse meio tempo... houveram várias melhorias e correções no DFe, após o "Bye bye CAPICOM"

 

Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Membros Pro

@Daniel Simoes , bom dia.

 

Meu amigo, agora fiquei um tanto preocupado com a frase "BYE BYE CAPICOM".....  minhas aplicações estão com a configuração do SSL = libCapicom e como eu havia dito anteriormente depois de tudo atualizado, voltaram a funcionar. Isso está correto??? Não deveriam ter parado de funcionar pelo fato da retirada da CAPICOM ?? e no meu código, eu estou passando para as configurações do componente o numero de serie do certificado ao inves do caminho do pfx e a senha.

Estou correndo o risco de parar minhas aplicações? 

@Fábio Eduardo de Souza

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.